none
Windows 10 Enterprise, desktop shortcuts with keyboard shortcuts, the keyboard shortcuts don't survive a logoff RRS feed

  • Question

  • My custom shortcut keys / hotkeys for desktop shortcuts (for example, to say that keystroke combination control-shift-alt-N opens Notepad) work fine until I logoff.  Next time, they don't work (even though the shortcut properties continue to indicate that shortcut keys are saved.) 

    Background: Desktop shortcuts can have a custom hotkey assigned as follows: Right click the shortcut, choose properties, click into the 'Shortcut key' box, pick a keyboard combination, then hit Apply, then OK). (By the way, If you don't use these, give it a try, you'll love it.)  (More background, I have all these shortcuts on my desktop (which along with the start menu, are the two places where you have to save them, if you want the custom shortcut key to work.)  And finally, this is a corporate environment where Windows is pretty carefully locked down, although I do have admin access.)

    Problem: 

    It seems to be after logging off or restarting.  When I return, the shortcut works fine when clicking on it, but hitting the saved shortcut-key for the shortcut will not activate it.  The shortcut keys still show up when I look at the shortcut's properties though, but they no longer function.)

    More background: With the pre-existing ones not working, I can create a NEW shortcut to something else, assign a new (different keystroke combination) custom shortcut key, apply and store it, and THAT new custom shortcut key will work, until the next logoff/restart.

    I can also successfully/permanent save a keyboard shortcut to a PROGRAM over in my PROGRAM data hierarchy (C:\ProgramData\Microsoft\Windows\Start Menu\Programs), and that saves/works permanently.  (It's difficult though, because there are some URLs and scripts I want to bookmark, and PROGRAMDATA isn't good for those).

    What I've tried:

    I found suggestions about Region settings and Language settings (I've only got one region and language selected, so that tip didn't apply), the registry ("nowinkeys", but that did not apply, it had NOT been previously disabled), and group policy edit ("turn off windows hotkeys"), but again, it had not been disabled previously.  I've tried re-saving the shortcuts, that doesn't work if I just do a single resave.  (If I remove the shortcut keys, save, then reopen and edit the properties again, and add the shortcut keys back, then apply and save, THEN it works again until the next logon).  And I have them specifically on the desktop, which is where they're supposed to be.   I've also tried putting the shortuts in my roaming profile (still doesn't survive a logoff), and also restarting EXPLORER to see if that woke up my shortcut keys, but it didn't.

    So, what's going on?  Any ideas?

    P.S. - A few odd things happen during logon, since this is a corporate environment, I'm going to assume that's part of the issue.  In the end though, at least visibly when looking at the  properties, the shortcut key definitions remain within the shortcuts.


    Sunday, October 20, 2019 11:30 PM

All replies

  • You can place the shortcut in this folder, or one of its sub-folders:

    C:\ProgramData\Microsoft\Windows\Start Menu\Programs

    *note ProgramData is hidden by default. you must first sign out and back in or restart your computer for the shortcut to start working.


    S.Sengupta,Microsoft MVP Windows and Devices for IT, Windows Insider MVP

    Monday, October 21, 2019 12:01 AM
  • Use the highest privilege to run your privilege at startup. Such as Task Scheduler and Computer startup script.

    If use task scheduler, tick Run whether user is logged on or not and Run with highest privileges options.

    If use Startup script, it runs as system account which has the highest privilege.

    Regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, October 21, 2019 2:24 AM
    Moderator
  • Thanks for the replies

    @Sengupta, yes, the one place I can get a keyboard shortcut to work is when I save it in ProgramData, where it works for installed programs, but not for making a shortcut to a URL, document, or anything that isn't a program, so my question is how to store a shortcut with a keystroke shortcut on the desktop, where it would work as it's supposed to work. 

    @Teemo, the scripts are owned/controlled by the IT department, so I don't have control over any of the startup settings.

    Monday, October 21, 2019 3:14 PM
  • I'll follow up when I find the official answer.  A couple other programs don't properly store their settings as well, which I bet are somehow related to the way profiles are loaded at logon, so when that gets fixed, I bet the shortcut keys get fixed as a byproduct.

    In the meantime, wow, I forgot how great Autohotkey is.  It's open source, has a great reputation, its own ecosystem, and a cult following.  It's also faster (on average), since windows built-in shortcut keys are subject to 3 second delays at least now and then for people who keep lots of windows open.  (it also has regular typing hotkeys for text, scripting, etc., but can be just for hotkeys too.) 

    I did choose the windows shortcuts with shortcut keys all these years, since they are universal and not dependent on a piece of software though.  And there's a time and place for doing it the old established way.  At least now I don't need to throw away the new computer. 

    Tuesday, October 22, 2019 3:20 AM
  • Ok, you have done a good job, thanks for sharing

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, November 5, 2019 8:10 AM
    Moderator