none
Windows 7 connection Status Indicator in System Tray

    Question

  • Hi,

    I recently installed Windows 7 X86 RC, the installation went well and I have no worries. I am wirelessly connected to my Secure Home Network and have been surfing the internet quite happily.

    However the network status indicator in the system tray is greyed out with a red 'X' over it instead of the globe...???? As if I am not connected? Its not really an issue as I have access to the web and online stuff, I'm just wondering if anyone else has come across this and if they have managed to fix it ???? Alternatively if there is anybody out there who knows what the issue is?

    As I said, its not really a problem I would just like 'all the pretty lights to come on'.

    Thanks.

    JD
    Wednesday, May 06, 2009 4:21 PM

Answers

  • Yea, it says the name of my network and internet access. The connection works fine, just shows the wrong icon. As of a couple days ago after a reboot to finish some updates the icon has fixed itself, no longer has the red X over it. That was a minor issue, just wish my ATI tuner driver would quit giving a BSOD right in the middle of a recording. It sucks watching a show only to have it end right when the plot is building.  :-{  I even loaded a new updated beta driver that was offered and still does the same thing. I just installed the RC on a second desktop, have to move the tuner to that machine and see if it does any better.
    • Marked as answer by Adam M MCP Thursday, June 18, 2009 1:27 PM
    Tuesday, June 16, 2009 4:35 AM

All replies

  • If your PC has both wireless and wired (RJ45 port) capability, then the greyed out with red X is for your wired connection since you're using wireless instead of wired. It's just saying your wired connection is not connected.
    Wednesday, May 06, 2009 5:51 PM
  • Thanks alot, I considered that. Wasn't 100% though.
    Wednesday, May 06, 2009 10:19 PM
  • I have this same issue on Windows 7 x64 RC. Even when both my Ethernet and Wireless are both connected it still shows a read X. Come to think of it I haven't seen it have the globe in a good while.
    Thursday, May 07, 2009 1:20 PM
  • I don't believe what The Digital Jedi said is correct. What The Digital Jedi is talking about I think is the Network Connections Applet (ncpa.cpl) and not a disconnected network connection. I don't see why having a disconnected network connection should reflect a red X in the Network Status System Tray. A lot of people have both Wired and Wireless enabled at any given time but yet not using both. Also disabling any connections not in use does not effect the red X for the Network Status System Tray Icon.
    Friday, May 15, 2009 4:35 AM
  • I have the same issue as well on x86 RC with only a wired connection. In the beta the icon was fine. Beyond that my networking works better than any previous Windows setups. I can even access workstations across a persistant VPN on a separate subnet with almost no delay in showing the shares. I've got a mix of Win7, Vista, Server 2K3, XP Home and Pro, and one Home Server. My only real problem is my ATI TV Wonder driver blue screening in the middle of recording a TV show.
    Monday, June 01, 2009 4:37 PM
  • If you hold your mouse pointer over it does it say anything? (ie media disconnected etc?)
    Monday, June 15, 2009 6:59 PM
  • Yea, it says the name of my network and internet access. The connection works fine, just shows the wrong icon. As of a couple days ago after a reboot to finish some updates the icon has fixed itself, no longer has the red X over it. That was a minor issue, just wish my ATI tuner driver would quit giving a BSOD right in the middle of a recording. It sucks watching a show only to have it end right when the plot is building.  :-{  I even loaded a new updated beta driver that was offered and still does the same thing. I just installed the RC on a second desktop, have to move the tuner to that machine and see if it does any better.
    • Marked as answer by Adam M MCP Thursday, June 18, 2009 1:27 PM
    Tuesday, June 16, 2009 4:35 AM
  • Quick update to this minor problem with the icon. The red X appears intermittently, with no real pattern or reason as to when it will show up. I did find what I believe is causing the icon to show the network connection as disabled yet the pop up text states "Internet Access". I was in the Local Area Connection status window to make a change and I noticed under Connection it shows <<<IPv4 Connectivity:    Internet>>> and <<<IPv6 Connectivity:   No network access>>>. Now in the Properties tab I have IPv6 unchecked since I don't need it and I just adds alot of extra info to Route Print commands and such. I checked the box again to see if that changed anything but since I don't use IPv6 on my network it still says "No network access". I will leave it that way for a while and see if there is any change in the icon, but as of this posting I still have the red X. As a note I am only using a wired connection and have no wireless hardware on any of my systems.
    Saturday, July 11, 2009 4:38 AM
  • If your PC has both wireless and wired (RJ45 port) capability, then the greyed out with red X is for your wired connection since you're using wireless instead of wired. It's just saying your wired connection is not connected.

    I disagree because i have both, and this is not happening to me.
    Sunday, July 12, 2009 1:20 AM
  • I actually ran into a problem like this when i decided to try out static networking to try to resolve another problem.

    My icon would show four bars, with a yellow triangle, saying no internet access, however, i was able to connect to google, use irc, chat, etc.

    As soon as I switched back to dhcp configuration, the icon resumed working the way it is expected.
    Sunday, July 12, 2009 1:22 AM
  • I have a static IP configuration on my IPV4 network and the same problem is occuring to me.  When I first installed the Windows 7 RC, the indicator icon was functioning normally, however now it says that I'm not connected to any networks, though I certainly am.  It's not a big hassle for me, except that I cannot connect to my VPN because Windows says I need an active connection.
    Friday, July 17, 2009 1:33 AM
  • I have a static IP configuration on my IPV4 network and the same problem is occuring to me.  When I first installed the Windows 7 RC, the indicator icon was functioning normally, however now it says that I'm not connected to any networks, though I certainly am.  It's not a big hassle for me, except that I cannot connect to my VPN because Windows says I need an active connection.
    Thats interesting because mine has never effected connecting to my office VPN. Seems to be a complete status icon issue and nothing more, if I hover over the icon it does say connected to internet.
    • Proposed as answer by kozdal Saturday, November 07, 2009 6:47 PM
    Friday, July 17, 2009 5:57 PM
  • Hi,

    I recently installed Windows 7 X86 RC, the installation went well and I have no worries. I am wirelessly connected to my Secure Home Network and have been surfing the internet quite happily.

    However the network status indicator in the system tray is greyed out with a red 'X' over it instead of the globe...???? As if I am not connected? Its not really an issue as I have access to the web and online stuff, I'm just wondering if anyone else has come across this and if they have managed to fix it ???? Alternatively if there is anybody out there who knows what the issue is?

    As I said, its not really a problem I would just like 'all the pretty lights to come on'.

    Thanks.

    JD
    hi I have same problem but my clour is YELLOW. everything 's working good and I connected via wireless but desktop network icon is yellow !! please help
    Saturday, November 07, 2009 6:49 PM
  • Static addressing could be the problem as that is what I use due to the size of my network and I prefer to always know the IP of a specific computer. I have moved up to the release version of Windows 7 and I hate to say it but the red X is still there, and my network still is working fine. The icon is functionally useless as compared to the icon in XP and earlier. It does not show send and recieve activity, or the amount of data transfered. You cannot click on it to bring up the status window to quickly change properties etc. That one lacking feature is what I really miss, now you must go thru the Network and Sharing Center to get to the link for the status of the connection. I don't bother showing it in the tray anymore, saves room for other icons.
    Windows 7 (x86) ver. 6.1.7100.2.0.0.256.1
    Monday, November 09, 2009 5:52 AM
  • WIN 7 Pro...

    All connections are good.  Icon does not blink to show activity on line.  No 'visual' as on XP Pro.
    Just a plain gray icon that implies if present and no other notification all is great with connection(s).
    One must rely on other communications devices lights to determine if movement on line(such as modem, router, etc.)

    Have moved all com physical devices within the peripheral field of vision, so can detect activiy on the line.

    How'bout dem apples!
    .


    SPA
    Friday, April 02, 2010 12:17 PM
  • I had the same problem. To fix it, I uninstalled the drivers for the LAN and Wireless adapters, rebooted the computer [don't know if I needed to reboot in Windows 7 but it can't hurt.] then reinstalled the drivers. If you need to, you should download the driver installers off the internet before uninstalling the drivers, obviously.

     After that the icons worked great! In my case I think the registry got corrupt when I installed Orical Virtual Box, and Virtual Box installed a virtual network adapter, so, reinstalling the drivers fixed the registry.

     

    Hope I was helpful.

    Sunday, June 06, 2010 5:06 AM
  • Hello All ,

    I faced same problem last week am using (win7 ulitmate x86 ) i recently installed VM-ware workstation and my tray connection shows am disconnected while am not (am using wired network) .

    Since VM installs 2 other vriual network cards i check it out and fixd the problem for me , I did the following:

    1. Disable my main network card .

    2. I waited tell my network tray shows the yellow tringle .

    3. Disable the 2 vriual network cards created by VM (The blue circle starts to spin looking for a network).

    4. Waited tell it show me am diconnected .

    5. Enable my main network card (that solve my problem) Tray icon back to normal and shows am connected.

    I hope thats help some of you guys :)

    • Proposed as answer by Selyo Wednesday, June 16, 2010 7:13 AM
    Wednesday, June 16, 2010 7:11 AM
  • I tried one thing in here and that was the correct answer.  For most of you, things work, just the icon shows wrong.  I am the IT for Lighting Science and this is my command machine.  Well this is the ONLY one that it does this on.

    So I went into the adapter settings and unchecked IPv6 as I don't use it.  Most people and places do not.  Why would they?  Anyway, as soon as I did that the icon showed fine.  no need to disconnect, reinstall, reload, format, or anything.  If you are like most people and do no use IPv6, uncheck it in your net adapters.  Problem solved.
    • Proposed as answer by Armand B Saturday, March 26, 2011 3:53 AM
    Thursday, July 15, 2010 7:15 PM
  • Brad,

    I try your suggestion but the issue continue. I see the 4 bars with a little orange sun (or asterik?) on it... Have internet connection OK. But can't find a reliable way to recover the Icon without this orange asterik...

    I would appreciate some well fundamented recovering answer from Microsoft...

    g.

    Tuesday, July 20, 2010 1:40 AM
  • I also have the same problem and also none of the solutions listed here works for me. Could you solve it already or not?
    Wednesday, August 04, 2010 9:20 PM
  • This is the only thing i tried and it worked. I unchecked the IPv6 and the icon was back to normal. After you get the icon back to normal, you can re enable the IPv6 and the icon remains normal.
    Saturday, March 26, 2011 3:54 AM
  • I ran into a similar problem after toying with VPN in Windows 7. Both my work PC and my home PC suffered from similar issues as described in this post, a red X over the connection icon in the notification area, but a consistent internet connection none the less. My work PC is a member of a domain, and my home PC is on a peer to peer network. Although the issue is inconsitent, I think it has something to do with the implementation of the seperate VPN connection listed below my wired connection in the notification area. It seems as though even when I delete the VPN connection, and incoming connection it still changes of its own accord. To resolve the issue I uninstalled the driver for my gigabit NIC (Which in this particular instance took considerably longer than normal) and let it reinstall itself on reboot. Fixed the problem on both my home PC and work PC.

    Even in dissimilar instances, I think trying a)uninstalling and re-installing NIC driver, and b)updating NIC driver to the latest version might be a good place to start. Even if it is a WLAN card, give it a try and see what happens. I see this solution has worked for other people in this post, and there seems to be a common theme: when having one or more connections present windows can potentially display the status of an inactive connection, while still utilizing the active connection to communicate.

    Friday, August 19, 2011 1:30 AM
  • I only have wireless and the icon always has shown connected with 5 bars until about a week ago.  I don't know why it happened.


    • Edited by d_c_d1978 Tuesday, October 11, 2011 2:32 PM
    Tuesday, October 11, 2011 2:31 PM
  • Mine does not show any identification when I hover over with the pointer.  However, it used to do so.  I cannot connect to the other computers in my home network.

    Tuesday, October 11, 2011 2:37 PM
  • Well I had the same problem.
    I remember back when I was doing a lot of online gaming and I didnt have a wireless receiver for my 360 so I bridged one of my connections and It didn't start it the display problem immediately, but it came up a little while ago.  Yesterday I deleted the bridge and it fixed the problem. Hopefully this helps but idk if you have any bridged connections.

     

    Thursday, January 05, 2012 12:09 AM
  • this is doing the same thing to me, has been like that for months, grey with a red X

    its not a problem for me untill i wanted to use my windows media center to connect my xbox slim i had to put a code in, i did this but it says i am not connected to a network when i am, its been like this about 5 months now and i would really really like ti fixed as me and my sister are using the same network but her is working fine and has all white bars and says its connected. thank you in advnace 

    x

    Saturday, February 11, 2012 10:06 PM
  • Well I had the same problem.
    I remember back when I was doing a lot of online gaming and I didnt have a wireless receiver for my 360 so I bridged one of my connections and It didn't start it the display problem immediately, but it came up a little while ago.  Yesterday I deleted the bridge and it fixed the problem. Hopefully this helps but idk if you have any bridged connections.

     

    i did this with my old xbox 360, will this be the problem? how do i unbridge? thank you xx
    Saturday, February 11, 2012 10:07 PM
  • Hi, i'm new to the site; and, i have the same issues with my network icon displaying a red X in the systray.  But after lots of testing, I might have found a solution.  Now before you get too excited! I got some of my ideas from others solutions that I have read, thus far about the problem.  So to get to the point:...

    Step 1

    A.  Disable your Network Adapter. (Right click Network icon and open Network and sharing center {Or open through Control panel}.)

    B.  Select in top left control of window, select Change adapter settings .

    C.  Right click Local area connection, and select Disable.

    Step

    A.  Press Ctrl + Alt + Delete all at the same time, then select Start Task Manger.

    B.  Select the Processes tab. and look on the list for explorer.exe. Right click and end Process.

    C.  Then go to the top left corner of the Task Manager window And select File < New Task (Run). (continued On another Post) p.1/2

    • Proposed as answer by xXValdisXx Saturday, March 03, 2012 12:40 AM
    Saturday, March 03, 2012 12:31 AM
  • D. Type explorer.exe in the box, and hit enter.

    Step 3

    A. Reverse the process from (Step 1, C) to re-enable your network adapter.

    I hope this helps. It might only be a temporary fix.  If this doesn't fix your problem, you might need to check network settings. or have your ISP come and attempt to repair something fishy with your network.  I know it sounds weird but this only started happening to me; when my Network monitoring gear detected that my ISP changed my DNS server info 15 times in 30 min. Last remark was more of "just a thought." ^.^

    Good luck i will update if needed...   

    • Proposed as answer by xXValdisXx Saturday, March 03, 2012 12:40 AM
    Saturday, March 03, 2012 12:40 AM
  • To Fix my last post Before re-enabling your Network adapter Be sure to wait for windows you try and get a internet connection. Once you see your Red x in the systray Network icon. Continue with Re-enabling your Network Adapter. p.1/3
    • Proposed as answer by xXValdisXx Saturday, March 03, 2012 12:55 AM
    Saturday, March 03, 2012 12:55 AM
  • Well I had the same problem.
    I remember back when I was doing a lot of online gaming and I didnt have a wireless receiver for my 360 so I bridged one of my connections and It didn't start it the display problem immediately, but it came up a little while ago.  Yesterday I deleted the bridge and it fixed the problem. Hopefully this helps but idk if you have any bridged connections.

     

    i did this with my old xbox 360, will this be the problem? how do i unbridge? thank you xx

    Don't know if this will help lizzi3b but you can check it out/give it a try:

    Go to, Network and Connection Center

    Click on, Advanced sharing settings and under Home or Network (not Public) check these settings:

    Network discovery on

    File and printer sharing on

    Media streaming is on

    Password protected sharing is off

    Allow Windows to manage home group connections

    I haven't really spent time with what you are trying to do but give this things a look. You may also have to allow sharing of folders where media is actually stored, I don't think so but maybe.


    • Edited by Jingoist Sunday, March 04, 2012 6:01 PM
    • Proposed as answer by prjdmd Saturday, June 16, 2012 4:55 PM
    • Unproposed as answer by prjdmd Saturday, June 16, 2012 4:55 PM
    Sunday, March 04, 2012 5:57 PM
  • Hi,

    I had a similar problem develop.  The red x was overlaid on top of my network icon but my internet connection was working fine.  I found the easiest way to remedy the problem was to delete the unused icons in the icon tray using the registry edit in the following article:

    http://www.ghacks.net/2010/02/09/remove-old-notification-icons-in-windows-7/

    After deleting the "icon streams" and "past icon streams" registry keys, terminating the "explorer.exe" process in task manager and restarting "explorer.exe" from the New Task Run under File in task manager, when the new icons emerge the red x will be gone. 

    It seems that the red x overlay will persist as the normal network icon even with a working internet connection until the system tray is reset. 

    Hope it works for others.  It is quite an easy fix.

    prjdmd


    • Edited by prjdmd Saturday, June 16, 2012 5:08 PM
    • Proposed as answer by Mahesh Birajdar Friday, August 03, 2012 8:13 AM
    Saturday, June 16, 2012 5:08 PM
  • Hi

    worked correctly for me in Win 7 Home.  Thanks.

    Friday, June 22, 2012 11:53 PM
  • Same problem. I tried the solution from xXValdisXx first but Jingoist brought me on the idea of changing the hidden network properties.

    Go to the Network and Sharing Center and click the active network icon (the house if it's a home network). This opens a window Set Network Properties and a link to Merge or delete network locations. I had 10 entries for my home network and deleted all instances which were not in use. After that I had my icon back.

    Tuesday, August 14, 2012 7:37 AM
  • I am on win7 home and i experienced the same problem but with a different wrong icon. The fix for this problem for me was to simply delete the explorer.exe then rerun it through new task on the Start Task Manager. This is a perfect solution thus you wont have to reboot nor disconnect from internet. I hope it helped.
    • Proposed as answer by moroccandh Friday, August 31, 2012 5:30 AM
    Friday, August 31, 2012 5:29 AM
  • Hey:

    Using Win7 Home Premium, v6.1 build 7601 SP1, on a HP laptop, I've tried just about everything above:  using regedit, disabling unused net connections, updating drivers, unchecking IPv6 etc etc. The only thing that consistently got rid of the indicator showing bars with the orange asterisk (and showing that I DID have Internet Access when hovered on) was ridiculously easy:  Turn off the WiFi on the keyboard before shutting down.  After booting up next time and everything is loaded, turn WiFi on.  Works fine every time.  (BTW I still have unused connections disabled and IPv6 turned off.  Why mess with what works for now : )

    Hope this helps.

    Friday, December 28, 2012 3:59 PM
  • Thank you, it worked for me

    Saturday, November 09, 2013 12:28 PM
  • i have this too. Did you fix it?
    Friday, February 14, 2014 7:21 AM
  • WARNING WARNING WARNING WARNING WARNING WARNING WARNING

    hi

    1. if u have a bluetooth device disable that.
    2. and then disable network connection and turn it on then.
    3. AFTER YOU ENJOOOOOOOOOOOOOOOOOOOY IT!!!!!!!

    it really work.

    Sunday, March 30, 2014 9:37 PM