none
Logon script delayed by 5 minutes (300 seconds) RRS feed

  • Question

  • It appears Windows 8.1 may have a built in delay processing logon scripts of 5 minutes.  Obviously, seems how it is brand new I'm not finding an ounce of information about it anywhere.

    Basically, I have troubleshooted this problem for hours now.  It boils down to the simple fact that I have several brand new Windows 8.1 systems joined to a Server 2003 domain.  Users have a GPO applied to them that assigns a logon script that maps network drives and printers.  After logging in, the script does not execute until 5 minutes have passed.

    I have removed all other GPOs, eliminated all non-microsoft services and shut off all startup items.  It makes no difference of admin or limited account, roaming profiles or folder redirection makes no difference.  Looking through the event viewer -> Microsoft -> Group Policy I can follow the the process step by step and everything looks great.  The event log shows the policy processing and application is happening within milliseconds.  Then there is exactly a 5 minute delay down to the second between:

    Group Policy Winlogon Start Shell handling complete

    and

    Starting Logon script for domain\user

    Task manager confirms that wscript.exe does not run until 5 minutes after logging in.  Once wscript.exe starts the logon script is processed as normal and the drives and printers are mapped as expected.

    I do not have any Windows 8 machines at this location, but I checked another location that has very similar policies and scripting and Windows 8 processes the logon script immediately.  This issue appears isolated to Windows 8.1.

    It appears that part of Microsoft's attempt to optimize the startup and logon process of Windows they may have added a 5 minute delay before processing logon scripts.  What I need to know is why, and where is the registry key to change this.

    Thanks

    Tuesday, October 22, 2013 4:31 AM

Answers

All replies

  • Mark Russinovich had a very good session about troubleshooting slow logins this year at Teched.  I highly recommend you try running Procmon during bootup to identify exactly why its taking so long.  In his example it was trying to access a path for updates that no longer existed and it waited until it timed out and then continued on.  Another example of this was an environment that was installing McAffee every time during bootup which was causing slow logons.  Its worth a shot to at least ensure all your policies have been applied as the event log isn't verbose enough.

    This is not my blog, nor am I affiliated, but it seemed like a good tutorial for doing this.

    http://www.msigeek.com/6231


    Be kind and Mark as Answer if I helped.

    Tuesday, October 22, 2013 1:49 PM
  • I saw a nice article about this here:

    http://www.petri.co.il/group-policy-in-windows-8-1-new-features.htm

    Basically, you control the delay by a group policy setting.

    • Marked as answer by Appleoddity Friday, October 25, 2013 1:10 PM
    Thursday, October 24, 2013 3:48 PM
  • Excellent - that was exactly what I was looking for.  I knew there was an arbitrary 5 minute delay added in for some reason.

    However, I currently am running a Server 2003 domain controller.  Do you have any reference for what registry key this policy changes to effect the login script delay?  Obviously, I do not have this new group policy setting on a 2003 domain controller.

    Thanks for your help!!!

    Friday, October 25, 2013 1:13 PM
  • I have 2008R2, so technically my servers don't have this either. What I did was download the Remote Server Admin Tools for Windows 8.1 (http://www.microsoft.com/en-us/download/details.aspx?id=39296), install them on my PC and was able to add the setting to group policy from there.
    Friday, October 25, 2013 3:12 PM
  • Awesome, thanks Bret. I've been struggling over this one for days.

    Why the hell don't Microsoft tell you about this sort of stuff??!!???

    Friday, November 29, 2013 4:16 PM
  • Hi, How do you add the template existing in Windows 8.1 that do not exist in Windows Server 2008 R2 ?

    I tried "Remote Server Admin Tools for Win 8.1", configure the setting "Configure Logon Script Delay" and when I look in my Windows Server 2008 R2, the template is not added and I have a message in Group Policy that tell me to update the .adm files.

    What can I do ?

    Wednesday, January 8, 2014 8:14 PM
  • I didn't add it on the server. I added it from my Windows 8.1 computer signed in as a domain admin. So if you install the remote server admin tools on your Windows 8.1 computer, you should be able to edit the group policy with it and configure that setting.

    All our servers are still 2008R2 as well, but you're not editing the server settings, you're editing the group policy object in the active directory domain.

    Wednesday, January 8, 2014 8:40 PM
  • OK It is working now. I had applied my GPO to users of my domain instead of computers. 

    Thank you.

     
    Wednesday, January 8, 2014 9:13 PM
  • I found a way to add administrative templates in my Windows Server 2008 R2. I have created a central store for GPO administratives templates. I follow this article for that:

    http://larslohmann.blogspot.ca/2013/02/create-central-store-for-gpo.html

    Then you can copy the policy definitions in C:\Windows\PolicyDefinitions from the Windows 8.1 to the server. Or you can download them at:

    http://www.microsoft.com/en-us/download/details.aspx?id=41193

    • Proposed as answer by no0000000 Monday, February 23, 2015 8:43 PM
    Thursday, January 9, 2014 8:55 PM
  • We have followed the procedure to create a central store for GPO administratives templates on our Smal Business Server 2011. Then we have added the Windows 8.1 policy definitions to the SBS2011.

    We have disabled the 'Configure Logon Script Delay' in our GPO.

    But it seems that this GPO change is not distributed to our Windows 8.1 workstations. Other changes in the same GPO are distributed to our workstations.

    Any ideas?

    Tuesday, February 11, 2014 4:09 PM
  • @Bert Miller - Thank you soooooooo much, you just stopped my eyes from bleeding...
    Thursday, May 25, 2017 12:25 PM