none
FRUSTRATED - Windows Media Player 12 and constant buffering loop when streaming recorded tv from my remote desktop

    Question

  • Hi,

    I understand that WMP 12 has streaming features built in. I've followed the instructions on enabling streaming on my home PC for when I'm on the road. When I'm travelling, I can access the remotely recorded TV shows using WMP 12. However, once the show starts playing, I constantly encounter a rebuffering loop. It seems (from looking at the connection speed) that the remote WMP 12 transcoder is NOT properly transcoding the video rate low enough (it will show up as 2000 kb/s, which is apparently NOT low enough for my UPstream bandwidth on my remote desktop). Essentially, the constant buffering makes the remote streaming of videos/TV shows on my home desktop unwatchable. I've tried adjusting the performance setting in WMP12 on the CLIENT and the SERVER to 28.8 kb/s, but that doesn't seem to make a difference. I've tried to buffer 60 seconds of video on the client, but WMP12 doesn't seem to buffer a full 60 seconds before trying to stream.


    • Edited by Da Pupster Thursday, March 08, 2012 8:22 AM
    Thursday, March 08, 2012 8:17 AM

All replies

  • Hi,

    First of all, let us double check the options below on both share and remote site.

    1. Launch Windows Media Player, click Organize, Options…

    2. Switch to Devicestab, click Advanced…

    3. Make sure “Allow video files to convert in the background”, “Allow audio files to convert in the background” and “Choose quality over speed when converting video (increases the conversion time)” have been marked.

    4. Click OKand re-launch Window=s Media Player.

    Best Regards,

    Kim Zhou


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Monday, March 12, 2012 9:38 AM
    Moderator
  • Hi,

    First of all, let us double check the options below on both share and remote site.

    1. Launch Windows Media Player, click Organize, Options…

    2. Switch to Devicestab, click Advanced…

    3. Make sure “Allow video files to convert in the background”, “Allow audio files to convert in the background” and “Choose quality over speed when converting video (increases the conversion time)” have been marked.

    4. Click OKand re-launch Window=s Media Player.

    Best Regards,

    Kim Zhou


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    I've done this, and I'm still getting buffering loops. How come Windows Media Player 12 streaming service is still trying to transcode and send at a higher bit rate than what the upload speed allows...?


    • Edited by Da Pupster Tuesday, March 27, 2012 5:05 AM
    Tuesday, March 27, 2012 5:05 AM
  • Hi,

    Please delete Transcoded Files Cache.

    Meanwhile, reference the link below please:

    http://support.microsoft.com/kb/307650

    Best Regards,

    Kim Zhou


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Monday, April 02, 2012 6:55 AM
    Moderator
  • Still no luck. It's still going into buffering loops. I have unchecked UDP and it actually worked WORSE. I don't think NAT traversal is an issue, since both computers are on the same network 192.168.2.xxx (they are connected via two routers that are connected using OpenVPN to link the two separate networks into one virtual network).

    Additionally, for some reason now, my shared library files aren't showing up in the remote Windows Media Center (the list wasn't being properly updated on the client, so I "removed" the library from the client's list and then attempted to readd the library of the remote account, but it's not showing up anymore as an option to check) -- is this a server or client side issue, and how do I fix this? I can view all the "guest" recorded TV files, but I can't view any of the recorded TV files off my main account on the home machine w/ all the recorded TV.

    Friday, April 13, 2012 6:34 PM
  • Hi,

    Please perform the following suggestions:

    1. Set TCPBurstLimitMS and enable TCP Offloading if the hardware support it.

    http://support.microsoft.com/kb/951037/en-us

    http://support.microsoft.com/kb/828566

    2, Begin migration to Smooth Streaming.

    3. Re-encoding the content to lower bitrates to less than 2Mbps..

    Should you have any problem, please let me know. Thanks for your time.

    Kevin Ni


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Tuesday, April 17, 2012 9:52 AM
  • Um...are you saying to do these steps on the "server" computer? I'm using Windows 7 Premium on the "server." The links seem to imply I have to be using Windows Server 2008, which I'm not.

    Thursday, April 26, 2012 5:32 AM