locked
Packet loss in Win7/vista but not XP RRS feed

  • Question


  • brokennarrow is on a distinguished road


    Join Date: Feb 2010
    Windows 7
     
      brokennarrow is online now Add to brokennarrow's Reputation   Report Post  

    Packet loss in Win7/vista but not Xp

    Hello,

    Just curious if anyone has noticed packet loss in Vista/Windows 7 systems which is not present in WinXp.

    I have tested this on both Comcast and Brighthouse residential internet connections. Two different intel i920 based computers, one with onboard Marvell NIC and the other with onboard Realtek 8111C NIC, both with dual boot configuration, and both connecting to the internet via motorola surfboard cable modems and Dlink DGL-4500 or Dir-655 routers. I even added an intel pci express NIC to one of the systems and using the intel (gigabit CT) NIC, the results are the same. I tried doing a safe mode boot with networking and the results are also the same.

    Results:
    Both computers running under XP experience 0% dropped packets when using ping test easy (Ping Test Easy - Free software downloads and software reviews - CNET Download.com ). I ping www.Google .com with default settings (ping rate of 1 ping every 0.6 seconds and time out threshold of 500ms). Even if left to run for hours, there is 0% packet loss, or rarely if left running long enough, a max of 0.2% loss.

    Both computers running under Win 7 (64 bit) pinging google with the same parameters will invariably show around 6-8% packet loss. The dropped packets will show up pretty quickly at the default ping rate.

    Interestingly though, my brother has a computer with an onboard realtek 8111D NIC running under Windows 7 pro (64 bit) and his system has 0% packet loss when pinging google with the same parameters. He has comcast internet service with a motorola cable/phone modem and a linksys router.

    Anyone have an explanation for these observations?

    Thanks in advance for any info.
    Friday, February 19, 2010 1:23 PM

Answers

  • some posting have point to the Task offloads cause slow networking on vista and now win 7

    http://msdn.microsoft.com/en-us/library/bb332213.aspx

    3. Run the following command to disable all Task offloads:

    C:\Windows\system32> netsh int ip set global taskoffload=disabled

    OK.

    This should disable all the offloads.

    4. Disable and Enable the NIC from “Control Panel – Network and Internet Connections
     – View Network Status and tasks – Change Adapter Settings“.

    5. To check if all Offloads are disabled run the following command:

    C:\Windows\system32> netsh int ip show offload

    Nothing should be listed. This should help.

    Also you may try disabling the power management option on the NIC as follows:

    1. Click Start, right click “Computer” select Properties.

    2. Click Device Manager. Right-click your NIC and choose Properties.

    3. Choose Power Management tab and uncheck “Allow the computer to turn off this device to save power.”

    4. Restart the computer and check if it works.

     

    • Proposed as answer by Chris.C Sunday, February 28, 2010 4:59 AM
    • Marked as answer by Novak Wu Tuesday, March 2, 2010 2:44 AM
    Friday, February 19, 2010 5:24 PM

All replies

  • some posting have point to the Task offloads cause slow networking on vista and now win 7

    http://msdn.microsoft.com/en-us/library/bb332213.aspx

    3. Run the following command to disable all Task offloads:

    C:\Windows\system32> netsh int ip set global taskoffload=disabled

    OK.

    This should disable all the offloads.

    4. Disable and Enable the NIC from “Control Panel – Network and Internet Connections
     – View Network Status and tasks – Change Adapter Settings“.

    5. To check if all Offloads are disabled run the following command:

    C:\Windows\system32> netsh int ip show offload

    Nothing should be listed. This should help.

    Also you may try disabling the power management option on the NIC as follows:

    1. Click Start, right click “Computer” select Properties.

    2. Click Device Manager. Right-click your NIC and choose Properties.

    3. Choose Power Management tab and uncheck “Allow the computer to turn off this device to save power.”

    4. Restart the computer and check if it works.

     

    • Proposed as answer by Chris.C Sunday, February 28, 2010 4:59 AM
    • Marked as answer by Novak Wu Tuesday, March 2, 2010 2:44 AM
    Friday, February 19, 2010 5:24 PM
  • Hey thanks Bubbapcguy!

    I'll give those a shot when I get home and report back.
    Friday, February 19, 2010 5:33 PM
  • Please be aware that packet loss can also come from your cable modem.  I have Time Warner cable and have wideband connectivity.  I logged into my Motorola DOCSIS 3.0 cable modem and changed the following setting and my packet loss went from 60% to 0%.

    IP address 192.168.100.1
    user: admin
    password: motorola

    Modem settings under the Firewall tab:

    turn off -> IP Flood Detection

     

    Friday, June 24, 2011 2:56 PM