none
Map network drive not working...

    Question

  • I am trying to map a network drive, and keep getting a network address not found error. I know the drive is alive and well, since I can connect to it from another (XP) computer.
    Any ideas?
    Thanks.
    Wednesday, January 14, 2009 5:14 AM

Answers

  • SOLVED for me!!

    Okay fellas, the fix suggested here did, indeed, work fine for me. To summarize, I changed the two settings in the security policies (secpol.msc) as suggested:

    1. "Network Security: LAN Manager Authentication Level":
            FROM "Send NTMLv2 response only"
            TO "Send LM & NTLM - use NTLMv2 session if negotiated"


    2. "Network Security: Minimum session security for NTLM SSP Based (including secure RPC) Clients"
             FROM "require 128 bit"
             TO unchecked (No Minimum)

    I can now connect to the network drive, and all is well with the world again. A huge thanks to dnegrich.
    • Marked as answer by pavanmaverick Friday, January 16, 2009 6:23 PM
    Friday, January 16, 2009 6:18 PM

All replies

  • Which firewall are you using on the win 7 machine
    Wednesday, January 14, 2009 12:36 PM
  • Turned off all firewalls on the Win 7 machine. I tried a bunch of tweaks recommended for Vista, connecting to a Samba share, but no luck.
    Thursday, January 15, 2009 1:47 AM
  • I've been frustrated with a similar problem.  I'm just trying to simply map to a FTP folder. I get an "FTP Folder error" that says "Details: The handle is invalid".  I can do it no problem with XP and VISTA on the same network. Turning firewall off doesn't help.  I hope someone can give some insight.
    Thursday, January 15, 2009 3:01 AM
  • While it does work for me. Not in the way I would expect. It loses them on reboot. But it does work so long as I dont reboot.
    Thursday, January 15, 2009 12:47 PM
  • Bump. Anyone with any insights?

    Did you guys trying using the security policies fix posted here?

    Friday, January 16, 2009 4:00 AM
  • Just tried that out and it didn't resolve my problem.

    Just wish I knew for sure if this is a Win7 bug so I can sleep at night :)
    Friday, January 16, 2009 3:26 PM
  • This is one error message that I have never seen before, and it dropped the listed 3 mapped drives during usage of explorer.

    Z:\ is not accessible.
    Y:\ is not accessible.
    X:\ is not accessible.

    The semaphore timeout period has expired.
    JohnWL
    Friday, January 16, 2009 3:35 PM
  • pavanmaverick said:

    I am trying to map a network drive, and keep getting a network address not found error.


    Can you connect using the IP address?
    e.g. \\ip.ad.dr.ess\share in stead of \\hostname\share

    If so, win7 might require a Fully qualified domain name  \\pcname.dom.tld\share.

    What kind of Samba related tweaks did you do, and would you be able to reverse them?
    Friday, January 16, 2009 3:41 PM
  • SOLVED for me!!

    Okay fellas, the fix suggested here did, indeed, work fine for me. To summarize, I changed the two settings in the security policies (secpol.msc) as suggested:

    1. "Network Security: LAN Manager Authentication Level":
            FROM "Send NTMLv2 response only"
            TO "Send LM & NTLM - use NTLMv2 session if negotiated"


    2. "Network Security: Minimum session security for NTLM SSP Based (including secure RPC) Clients"
             FROM "require 128 bit"
             TO unchecked (No Minimum)

    I can now connect to the network drive, and all is well with the world again. A huge thanks to dnegrich.
    • Marked as answer by pavanmaverick Friday, January 16, 2009 6:23 PM
    Friday, January 16, 2009 6:18 PM
  • What kind of Samba related tweaks did you do, and would you be able to reverse them?


    Yes. All tweaks are reversible. The tweaks consisted of the changes to the securities policies as outlined in me previous post. In addition, I have changed two registry keys:
    1. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\lmcompatibility
        TO 1

    2. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanworkstation\parameters\enableplaintextpassword
        TO 1

    I had initially not applied change #2 from my previous post (to the security policies), and I think that was the issue. If I have time today, I will reset all changes and post exactly which one did the trick. I suspect that its actually #2 from my previous post.
    Friday, January 16, 2009 6:22 PM
  • While the above solution may work if you cannot get network shares to work. It does not seem to solve the problem whereby W7 loses mapped drives upon reboot. 
    Saturday, January 17, 2009 12:45 AM
  • No.
    But pay close attention to the first line:

    Open a command prompt and type
    net use [enter]

    If you see "New connections will not be remembered" that means just what it says.

    To change this behaviour use:

    NET USE [/PERSISTENT:{YES | NO}]


    (it's been around since at least NT4).


    @ pavanmaverick:
    I had initially not applied change #2 from my previous post (to the security policies), and I think that was the issue. If I have time today, I will reset all changes and post exactly which one did the trick. I suspect that its actually #2 from my previous post.



    You might want to check for a more recent Samba version then.. EnablePlaintextpassword is regarded as deprecated behaviour for quite some time now.
    http://www.informit.com/articles/article.aspx?p=169560&seqNum=4 - bottom section - and keep in mind that remark is already 4 years old.

    • Proposed as answer by Will01 Wednesday, January 21, 2009 5:19 PM
    Wednesday, January 21, 2009 4:51 PM
  • Thanks for this advice, pavanmaverick! I'd had a similar problem - one moment my drive Z: was active, the next it was inaccessible giving me a "the account is not authorized to log in from this station" yet I could still access the firmware with an http://storage call. I followed your suggestion (after tinkering with the security calls) and was able to log in with \\ip.add.res.cal\public and now have my drive Z: back!

    Many thanks - but why was it working one minute and not the next - that is the puzzle!

    Ian B
    Thursday, July 2, 2009 11:33 AM