none
Win 7 RC - SharePoint WebDAV performance suddenly slower again (had improved from earlier beta)

    General discussion

  • After being quite happy with SharePoint WebDAV performance with a beta latre than Beta 1, suddenly performance has dropped off again in the RC. When the RC was first installed, performance was fine--now, however, when accessing a SharePoint folder via Windows Explorer, it takes 30 seconds or longer for the folder to open and become accessible. Navigating to a subfolder and then opening a file (which is also much slower) is so tedious as to be unusable.

    Anyone else eexperience this problem or have any ideas on how to resolve it? Nothing changed on my system locally or on the SharePoint server itself (I'm the server's admin), but I can't testify that nothing changed on our network.
    Wednesday, May 27, 2009 6:11 PM

All replies

  • We are seeing the exact same behavior.  Using SharePoint from Office 2007 is painfully slow with long delays navigating document libaries from the file open and save dialogs.  I have seen posts with others having the same issue.  If I come across anything, I'll post it here.
    Monday, June 01, 2009 2:06 PM
  • Well, I rebooted again (which I'd done numerous times when the problem persisted), and lo and behold! Everything's working fine again. So, not sure what that means...
    Monday, June 01, 2009 4:04 PM
  • Same here.  All of a sudden it started working and seems to keep going fine after a reboot.  I can't see anything that appears to have changed.  We're going to be moving to Windows 7 RC2 when it becomes available to Microsoft Partners on June 11th or 12th and quickly to the RTM which is supposed to happen before the end of July.  This will be the first thing that we test.  If anyone on my team runs into this again, I'll update this post.

    Good luck with your testing.
    Thursday, June 04, 2009 5:15 AM
  • I've the same problem.
    Rebooting everything brings it back, but it rapidly deteriates to unusable.

    XP, inside the VM on Win7 has no problems, so I know it isn't network or the server. No Vista or XP PC on the network has any problems.

    Windows 7 RC cannot reliably talk to Sharepoint (or any WebDav connection) runnning on a Windows Server 2003 box for more than a few hours before something goes wrong.

    (BTW, I didn't notice this on the beta, though to be fair, I did very little real testing with the beta)

    Thursday, June 04, 2009 10:17 AM
  • Everyone,

    I experienced the same issue with Win7 RC (7100) x64.  WebDAV worked fine initially after the install, then a few weeks later it began a gradual slowdown when accessing SharePoint.  Restarting WebClient service or the whole computer had no effect.

    I was able to fix it by restoring IE8 to factory defaults.  Close IE8, go to Control Panel, Internet Options.  On the Advanced tab, click Reset button; I didn't need to tick the check-box to delete personal settings.  Afterwards, WebDAV shares were opening rapidly again when using Explorer View from SharePoint or a mapped drive letter. 

    It seems like a caching problem, though just deleting the browsing history didn't fix it.  If the issue reappears, reset IE8 again.

    --Mancer, MCITP-EA
    Tuesday, June 16, 2009 6:09 PM
  • Mancer - Thanks for the info. The next time it happens (performing great right now, which lends credence to your theory) I'll give your fix a shot and will report back with the results.
    Tuesday, June 16, 2009 10:58 PM
  • I have noticed similar issue. One fix that works for me is to make sure that the proxy settings in IE are disabled.  For some reason, at times, the settings "Automatically Detect Settings" In the connection tab reset itself. If it is disabled it works great.

    daniel
    Monday, June 22, 2009 2:08 AM
  • Unchecking "Automatically detect settings" as described above instantly made my SharePoint WebDAV over SSL (Explorer View) more responsive.  I'm using Windows 7 Pro 64-bit build 7600 with all available updates installed.
    Tuesday, September 08, 2009 8:18 PM
  • indeed, unchecking "Automatically Detect Settings" resolved this for me instantly as well, thanks!  I'm using RTM (Build 7600).
    Thursday, September 17, 2009 6:48 PM
  • Indeed - switch off checkbox Automaticaly detect setting in IE8 / Tools / Internet Options / Connections / LAN settings / Automatic configuration. Then it is light speed again.
    Monday, October 05, 2009 5:00 PM
  • Normally I hate "me too" posts but I just had to say thanks to you guys for this tip. I have been pulling my hair out on this problem with Win 7 beta, then RC and now with a complete reinstall of full RTM. Disabling the automatic proxy configuration worked perfectly.
    Monday, December 21, 2009 8:41 AM
  • I may acknowledge as well.
    Unchecking automatic detecion speeds up process hundreds of times.
    This impacts also retail versions of "7" (here Ultimate x64).
    Thank you for your help,

    Piotr Czekalski

    TECHBAZA.PL
    Friday, January 15, 2010 12:20 PM
  • Daniel, quite a late respons, but thanks a lot! This worked fine for me for Win7 x64!
    Thursday, January 28, 2010 8:18 PM
  • Thanks Mancer, that worked. Althoug, I would like to know with setting precisely caused the issue in IE8.. anyone knows?
    Wednesday, February 17, 2010 3:54 PM
  • Likewise, it is well into 2010, getting close to SP1 for Win7, but I was having this exact issue. Wasn't sure what I was going to do as I use SharePoint heavily. Thanks so much for this fix! Works like it did in Windows XP
    Monday, July 19, 2010 3:24 PM
  • I know that this is a late response, but this also just worked for me in our environment.  You saved me a ton of user complaints!  Thank you!
    Friday, February 04, 2011 8:37 PM
  • Took me way too long to find this, but it sure worked!  Thanks, Daniel!
    Saturday, February 19, 2011 1:00 AM
  • Took me way too long to find this

    Same here, but FWIW the recipe did not help me with a "SkyDrive". Clearly WebDAV works, because a "SkyDriveSimpleViewer" can show me the name of a test file in the documents folder, but all obvious ways to access the SkyDrive (= Windows Live Office, etc.) as network drive fail.

    Wednesday, March 02, 2011 1:54 PM
  • This works great. But now we have IE9 and it is VERY slow again (WebDav uses IE functions to navigate). Anyone knows a way to solve this, other then just keep using IE8!?  
    Wednesday, September 28, 2011 11:10 AM
  • This works great. But now we have IE9 and it is VERY slow again (WebDav uses IE functions to navigate). Anyone knows a way to solve this, other then just keep using IE8!?  
    Wednesday, September 28, 2011 11:24 AM
  • Exactly as you said. Now is blaizingly fast!
    Tuesday, August 21, 2012 5:54 PM
  • It works for us with Win7 Prof. 32 bit & IE 9
    Thursday, August 23, 2012 7:19 PM
  • I had given up for the longest time on this issue! I'm so glad to have found the solution here.

    Works with Windows 7 Professional 64-bit, SharePoint 2007, IE 8.

    Monday, November 04, 2013 4:17 PM