none
Outlook asks for domain credentials then immediately asks for a Microsoft account RRS feed

  • Question

  • I recently just migrated from Exchange 2010 (SBS 2011 platform) to Exchange 2016. I'm having issues with the end user's Outlooks failing to work. I've run through the free online Labs and followed the exact steps, but replacing the information with my company info. 

    THE PROBLEM:

    When the client's Outlook tries to add another profile and connect it prompts me for a domain account: 

    I enter the email when Adding an account, Then it asks 'What account type are you adding:' so I click Exchange.


    So far this is normal as they are using a self-signed cert for now. Normally I would get prompted for a domain account to enter for this to communicate to the exchange server but instead I get a Microsoft account prompt.

    This client is not setup with Microsoft accounts nor is this a hybrid model. This is strictly a local exchange server and only a local domain.

    Anyone run into this or know how to fix it?

    Assumptions:

    I would assume this has to do with the autodiscovery configuration pointing to Microsoft outlook servers vs my local exchange, but I don't know how to change that nor have I been able to find that information.

    Thursday, November 21, 2019 9:06 PM

Answers

  • Hi,

    Do you mean that when you login an on-premises Exchange mailbox, a Office 365 Pop-ups asks password for this account? Like picture below:

    If you I would suggest you try to take one of suggestion below:

    Suggestion 1:

    Enable the ExcludeExplicitO365Endpoint registry key (1) under  HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\AutoDiscover.  

    Suggestion 2:

    Try to sync this AD account to Exchange online, then this request will be redirected back to on premises rather than an Office 365 Pop-ups.

    Regards,

    Kyle Xu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Monday, November 25, 2019 8:06 AM
    Moderator

All replies