none
How can I make the On Screen Keyboard display at the login page?

    Question

  • I have 3 touch screen PCs.  Is there a way to force the On Screen Keyboard to display on the login screen without asking the user to select the Ease of Use button?  These machines will be on a domain.
    Thursday, September 22, 2011 10:45 AM

Answers

  • Try this:

    1. Go to the Easy of Access control panel, choose Use the computer without a mouse or keyboard, check Use On-Screen Keyboard, click Ok.
    2. Go to the Easy of Access control panel, choose Change administrative settings, check Apply all settings to the logon desktop, click Ok.
    • Proposed as answer by Nano Warp Friday, September 30, 2011 10:25 AM
    • Marked as answer by Robinson Zhang Thursday, October 06, 2011 4:13 PM
    Wednesday, September 28, 2011 11:38 AM

All replies

  • Thursday, September 22, 2011 11:01 AM
  • Add OSK.Exe to your startup folder for the All users profile (C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup)

    Thursday, September 22, 2011 12:26 PM
  • Done that - since the machines are not yet on a domain, I get the standard Windows 7 login screen with the user icons showing.  When I select an icon, I don't get the keyboard.  I have to manually open the keyboard from the button on the left side of the screen.  I want it to pop up automatically.
    Wednesday, September 28, 2011 10:47 AM
  • Done that - since the machines are not yet on a domain, I get the standard Windows 7 login screen with the user icons showing.  When I select an icon, I don't get the keyboard.  I have to manually open the keyboard from the button on the left side of the screen.  I want it to pop up automatically.
    Wednesday, September 28, 2011 10:47 AM
  • Try this:

    1. Go to the Easy of Access control panel, choose Use the computer without a mouse or keyboard, check Use On-Screen Keyboard, click Ok.
    2. Go to the Easy of Access control panel, choose Change administrative settings, check Apply all settings to the logon desktop, click Ok.
    • Proposed as answer by Nano Warp Friday, September 30, 2011 10:25 AM
    • Marked as answer by Robinson Zhang Thursday, October 06, 2011 4:13 PM
    Wednesday, September 28, 2011 11:38 AM
  • Hi,

    Please refer the following article to add osk.exe as a service:

    http://www.pcreview.co.uk/forums/screen-keybaord-windows-log-xpe-sp1-image-t527938.html

    If you have further question about this problem, please feel free and let me know.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Edited by zhen tan Friday, September 30, 2011 4:17 AM
    Friday, September 30, 2011 4:17 AM
  • Try this:

    1. Go to the Easy of Access control panel, choose Use the computer without a mouse or keyboard, check Use On-Screen Keyboard, click Ok.
    2. Go to the Easy of Access control panel, choose Change administrative settings, check Apply all settings to the logon desktop, click Ok.


    MCCZ's post worked for me. Takes a couple of reboots for it take effect. Be sure to click the OK boxes at the bottom. They are out of the way and I forgot one one time. #2 is blue letters option in the left pane.

    Thanks MCCZ.

    Friday, September 30, 2011 10:29 AM
  • Try this:

    1. Go to the Easy of Access control panel, choose Use the computer without a mouse or keyboard, check Use On-Screen Keyboard, click Ok.
    2. Go to the Easy of Access control panel, choose Change administrative settings, check Apply all settings to the logon desktop, click Ok.

    Sorry, I have tried this multiple times now, but it simply does not work on my Win7 Ultimate system the way I'd expect to, because it simply takes too long. I have two users with an icon on my logon screen, and I see the accessibility options on the lower left side of my screen. I have logged on as an Administrator, enabled the Onscreen Keyboard, applied the settings to "administrative settings", but when I restart my system, I see the logon users dialog, but it takes onother 30-60 seconds until the OSK appears at all, even though my system is quite fast (Intel E8400 dualcore with 4GB of RAM). If I click on the accessibility options on the lower left, and force the keyboard to appear manually, it appears much faster. Is there any way to make the whole automatic process start faster?


    • Edited by Erik78 Tuesday, February 21, 2012 11:02 AM
    Tuesday, February 21, 2012 8:59 AM
  • Hi Erik78,

    Perhaps there is something running in the background during startup which is delaying the appearance of the OSK. eg. malware, anti-virus scan.

    Click Start=>type msconfig in the search box and then select it from the results.

    Click on the startup tab and observe which applications are set to run at startup. Some may run pre-logon, some may run after. If you uncheck those one at a time and test (reboot) you may find which is delaying the OSK.

    Don't forget to return to msconfig and recheck or enable the application on start-up again.

    Check the boot scan settings in the preferences of the anti-malware application that you are using. Temporarily turn-off the boot scan and test the OSK behavior on boot.

    Again, don't forget to turn it on again for security.

    Tuesday, February 21, 2012 1:17 PM
  • thanks a lot for your detailed answer, however, I have seen this behaviour on many freshly installed PCs I have tested here, no additional software installed. Can you please check at your place and tell me for sure that the delay is not happening on all systems? At the moment, I have tried, but cannot find any delaying process causing this behaviour, but maybe I am not seeing something.

    I have another question: I would like to automate the whole Process, i.e. turn the OSK.exe for logon on and off using a powershell script. Can you please tell me which registry settings are made by the two essential steps mentioned earlier, i.e.:

    "

    1. Go to the Ease of Access control panel, choose Use the computer without a mouse or keyboard, check Use On-Screen Keyboard, click Ok.
    2. Go to the Ease of Access control panel, choose Change administrative settings, check Apply all settings to the logon desktop, click Ok"

    I'd like to turn these on and off using two different scripts if possible.


    Thanks.


    • Edited by Erik78 Tuesday, February 21, 2012 1:57 PM
    Tuesday, February 21, 2012 1:57 PM
  • I followed your proposal and it worked for the logon screen.

    However, after locking the system (e.g. by using Win+L) the input panel won't show up even when you press the Ease of Use button in the lower left corner (where the "Type without the keyboard" option is checked by the way??)

    Edit:

    Only if you uncheck the  "Type without the keyboard" option and check it again the input panel will be reloaded and is shown... 

    Any hints?

    Thanks!



    • Edited by meek17 Friday, September 07, 2012 7:56 AM
    Friday, September 07, 2012 7:50 AM