none
HP Deskjet 710c not working on Windows 7 64bit

    Question

  • Hello,

    I tried to run a HP Deskjet 710c printer on Windows 7 64bit, but it's not working. Every time I try to print, the spooler service will crash. The printer is connected via centronics interface. I've also tried to connect the printer via USB cable but without success - same problem.
    On Windows 7 32bit everything is fine. Seems that the printer driver has a problem.

    Could someone please help to make this printer run on 64bit?

    Thanks in advance
    Andre
    Tuesday, February 23, 2010 10:05 AM

Answers

All replies

  • Hi Osiris77,
    I would suggest that you use the usb type connection. First uninstall any instances of the printer or HP software.
    Then use this method recommended from HP support: http://h10025.www1.hp.com/ewfrf/wc/document?docname=c01874792&lc=en&dlc=en&cc=us&lang=en&product=59307

    That is the link you get when you try to get drivers for Windows 7 64-bit for this printer.

    Did you get it from the Smithsonian Institute? They probably want it returned;-) 
    Tuesday, February 23, 2010 12:21 PM
  • Hi Nano,

    hmm my printer does not have an usb interface..that's why the HP site does not really help..;-) however I tried an USB to parallel converter cable and attached it to the usb interface at the computer - but still same problem.

    Regarding the printer software - there comes an standard printer driver with the OS, but I did uninstall it and connected the printer again to the computer. The driver then installed itself. Still same problem.

    By the way I'm running Win7 64 bit Ultimate.

    Any ideas?

    Andre
    Tuesday, February 23, 2010 7:06 PM
  • I couldn't find the direct reference, but this page at HP support, displays this method of setting up the 712c (similar) on a parallel cable in a Vista 64-bit OS and selecting the Deskjet 500c drivers.

    http://h10025.www1.hp.com/ewfrf/wc/document?docname=c01655752&lc=en&dlc=en&cc=us&product=58747&lang=en

    Uninstall the device and try this method and to manually force the 500c drivers.  
    Tuesday, February 23, 2010 8:15 PM
  • Hi Andre,

     

    Please refer to this HP support article: Deskjet 710/720/810/820/100 Series printers - Patch for 64 bit Vista and WIndows 7

     

    Please Note: The third-party product discussed here is manufactured by a company that is independent of Microsoft. We make no warranty, implied or otherwise, regarding this product's performance or reliability.

     

    Hope this helps.

     

    Regards,

    Linda

     

     

    • Proposed as answer by Nano Warp Friday, February 26, 2010 7:14 PM
    • Marked as answer by Linda Yan Tuesday, March 02, 2010 2:41 AM
    Wednesday, February 24, 2010 7:39 AM
  • Hi Linda,

    thanks very much for this, after applying the patch it's working now! :-))

    kind regards
    Andre
    Friday, February 26, 2010 10:30 AM
  • Hi Andre,

     

    Glad to hear it helped. J

     

    Regards,

    Linda

     

     

    Tuesday, March 02, 2010 2:41 AM
  • hi,

    I have the same problem.But I tried to "connect" to shared hp710 on a XP and there is "no driver".On laptop I have win7 64bit.

    I applied that patch with no results.It's searching for .inf file I think.

    thanks,

    Tuesday, January 08, 2013 12:34 PM