[Solved] partitions impossible to delete even with diskpart RRS feed

  • Question

  • Hello,

    I installed system on a new disk and I want to completely format the old one. I can't seem to extend or even allocate space on the disk. When I try to allocate, windows tells me there is not enough disk space. I can't send pictures because I'm not verified apparently.

    I tried deleting the partitions with diskpart prompt but impossible to delete any of them.


    Partition ###  Type              Size     Offset
      -------------  ----------------  -------  -------
      Partition 1    Dynamic Data       349 GB    31 KB
    * Partition 2    Recovery           875 MB   349 GB
      Partition 3    Dynamic Data       581 GB   350 GB

    DISKPART> delete partition override

    Virtual Disk Service error:
    The operation is not supported by the object.

    The specified command or parameters are not supported on this system.


    It has no volume. I tried to format it with Linux but I got an error too.

    I'm completely lost, I don't know what to do. Does anyone have a clue?

    • Edited by NekiCoule Wednesday, May 29, 2019 1:57 PM Solved
    Friday, May 24, 2019 9:28 AM

All replies

  • You may try the following third party tool:


    S.Sengupta,Microsoft MVP Windows and Devices for IT, Windows Insider MVP

    Friday, May 24, 2019 9:53 AM
  • Thanks for the answer! The scan is a bit slow and I'm not sure if I selected the right options, but it's running. I get back to you when it's done
    Friday, May 24, 2019 10:15 AM
  • I didn't mention it, the disk is pretty old (arround 6 years). It may be dead, even if I ran a test with the seagate tool a few month ago and everything seemed OK. If trying to recover it, or trying to format it, is too hard, too long, and maybe not worth it, I'd rather forget about it and buy a new one. It's old and I'm not safe from a failure or a sector to break.
    Friday, May 24, 2019 10:56 AM
  • If you get picture ability, it will help, but you should post more info regarding the disk. Put into there the output of these commands.

    Detail disk
    sel part 2
    detail part
    list vol

    Friday, May 24, 2019 4:38 PM
  • Sorry for the late answer! I had a lot of work!

    Here are the command you asked:


    DISKPART> detail disk

    WDC WD10EZEX-08M2NA0
    Disk ID: 223FBBE6
    Type   : SATA
    Status : Online
    Path   : 1
    Target : 0
    LUN ID : 0
    Location Path : PCIROOT(0)#PCI(0103)#PCI(0001)#ATA(C01T00L00)
    Current Read-only State : No
    Read-only  : No
    Boot Disk  : No
    Pagefile Disk  : No
    Hibernation File Disk  : No
    Crashdump Disk  : No
    Clustered Disk  : No

    There are no volumes.

    DISKPART> detail part

    Partition 2
    Type  : 27
    Hidden: No
    Active: No
    Offset in Bytes: 374893182976

      Volume ###  Ltr  Label        Fs     Type        Size     Status     Info
      ----------  ---  -----------  -----  ----------  -------  ---------  --------
    * Volume 3                      NTFS   Partition    875 MB  Healthy    Hidden

    DISKPART> list vol

      Volume ###  Ltr  Label        Fs     Type        Size     Status     Info
      ----------  ---  -----------  -----  ----------  -------  ---------  --------
      Volume 0     E                       DVD-ROM         0 B  No Media
      Volume 1     G   The Void     NTFS   Partition    931 GB  Healthy
      Volume 2     C                NTFS   Partition    465 GB  Healthy    System


    The void is my third hard drive. C is a SSD. Because I deleted everything by trying to format the disk, it has no volume currently. I tried to make a 400Gb volume but the volume didn't show up.

    Tuesday, May 28, 2019 6:33 PM
  • Hi,

    Also, you could refer to this:

    [Solved] Diskpart Delete Partition Override Not Working


    Please Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Best Regards,

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, May 29, 2019 2:37 AM
  • I already saw this post. I don't like third party software. I gave it a try anyway but with no result.
    Wednesday, May 29, 2019 12:44 PM
  • I managed to make it work with Acronis. I used Wester Digital software to initialize my disk back. After Acronis was done, I was able to allocate and make a volume of 930Gb. Thanks everyone for your help and kindness!
    Wednesday, May 29, 2019 1:56 PM
  • Hello,

    Did you try to "Clean" the drive with Diskpart?

    I would have thought that should have wiped the drive of all partitions

    Thanks, Darrell Gorter [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Wednesday, May 29, 2019 10:55 PM
  • You Sir.........are a incredible life saver. thank you very much, so simple and worked in 2 seconds. with that it was easy to forget the 3 hours I spent to search and finding over and over again the same diskpart story. Darrell Gorter for president, lol
    Wednesday, January 8, 2020 3:54 PM
  • Hello,

    Did you try to "Clean" the drive with Diskpart?

    I would have thought that should have wiped the drive of all partitions

    Thanks, Darrell Gorter [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    egads! This solved my problem before I even realized it! Thank you!
    Wednesday, January 22, 2020 4:45 PM
  • DUDE, you are a savior, making this comment just to let you know that I really appreciate your help !
    Thursday, March 26, 2020 10:51 PM