none
Host process for windows services stopped working and was closed

    Question

  • My laptop had been working fine until yesterday, when after a Windows Update failed with an error code 80070017 showed up then i got this message saying Windows services has stopped working and was closed", now I am getting it continuously and it has slowed my laptop down considerably and most programs will stop responding after a couple minutes. I searched hours for a solution and have tried many but to no avail. I downloaded the BITS program but when I start it,it just tells me that there is no need for it to be used. Any help or suggestions as to what to try would be greatly appreciated.

    Product

    Host Process for Windows Services

    Problem

    Stopped working

    Date

    1/29/2011 4:37 PM

    Status

    Not Reported

    Problem signature

    Files that help describe the problem

    Version.txt

    AppCompat.txt

    memory.hdmp

    minidump.mdmp

    Problem Event Name: InPageError

    Error Status Code: c000009c

    Faulting Media Type: 00000003

    OS Version: 6.0.6002.2.2.0.256.1

    Locale ID: 1033

    Additional Information 1: 42f5

    Additional Information 2: 774e7a4a2baa41eb93d8de8e07266fc0

    Additional Information 3: 9245

    Additional Information 4: 0e9f0413ef413f3f8216b1615d9f265f

     

     

    • Edited by chickaboo Sunday, January 30, 2011 12:23 AM had to rearrange
    Sunday, January 30, 2011 12:15 AM

Answers

  • Well you know what, the problem seems to have gone away on its own? I'm hoping so anyways, because I haven't recieved the host process message all day. The only reason why I can think of is that I had downloaded Internet Explorer 9 Beta and had been using it for a couple weeks now. Just this morning I uninstalled it and went back to IE 8, now I have not had any problems! So I hope this was the problem and will not not come back, but I just wanted to thank ya'll for your help and suggestions! Greatly appreciated! =)
    • Marked as answer by chickaboo Wednesday, February 09, 2011 5:31 AM
    Wednesday, February 09, 2011 5:30 AM

All replies

  • Problem Event Name: InPageError

    Error Status Code: c000009c

    //
    // MessageId: STATUS_DEVICE_DATA_ERROR
    //
    // MessageText:
    //
    //  STATUS_DEVICE_DATA_ERROR
    //
    #define STATUS_DEVICE_DATA_ERROR         ((NTSTATUS)0xC000009C L)

    You have a HDD issue. Check the HDD with chkdsk C: /r /f and a diagnostic tool from your HDD manufacture.

    André


    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Sunday, January 30, 2011 1:43 PM
  • Where do I get the diagnostic tool from? Is it something worth trying to fix myself, or is it better to just bring it in to get fixed. Also I booted in safe mode and the "windows services stopped working" message does NOT appear. I read somewhere that if this happens, it is most likely an incompatible driver issue? If I recall correctly my son had an mp3 plugged in right before all this started. Anyway I am still getting the message constantly, almost as soon as I close the box, it pops up again. I am still able to get online and use other programs, but they are slower.

    Wednesday, February 02, 2011 11:16 PM
  • Which HDD do you use? Go to the website of the manufacture and download the diagnostic tool. Have you tried chkdsk?

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Thursday, February 03, 2011 3:09 PM
  • Okay, so i tried chkdsk, it ran and nothing came up. I also found the diagnostic tool on my laptop and ran it, and it passed every test =/ and the problem is still there.....

    Friday, February 04, 2011 2:16 AM
  • Do you have the following files?

    Version.txt

    AppCompat.txt

    memory.hdmp

    minidump.mdmp

    If yes, upload them.


    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Friday, February 04, 2011 3:13 PM
  • How do i upload them? =) yes i do have the files

     

    Tuesday, February 08, 2011 1:18 AM
  • You can upload the collected files to SkyDrive, and let me know the URL by replying this thread. For detailed steps on how to upload files with SkyDrive, please refer to:

     

    http://social.technet.microsoft.com/Forums/en-US/w7itproui/thread/4fc10639-02db-4665-993a-08d865088d65

     

    The above Windows Live ID is ONLY for collecting troubleshooting information. Please do NOT send your questions to it. For any new questions, please post in the forums so that more MSFT, MVP and community members can help you.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Tuesday, February 08, 2011 8:46 AM
    Moderator
  • Well you know what, the problem seems to have gone away on its own? I'm hoping so anyways, because I haven't recieved the host process message all day. The only reason why I can think of is that I had downloaded Internet Explorer 9 Beta and had been using it for a couple weeks now. Just this morning I uninstalled it and went back to IE 8, now I have not had any problems! So I hope this was the problem and will not not come back, but I just wanted to thank ya'll for your help and suggestions! Greatly appreciated! =)
    • Marked as answer by chickaboo Wednesday, February 09, 2011 5:31 AM
    Wednesday, February 09, 2011 5:30 AM