Missing file <Windows root>\system32\ntoskrnl.exe


  • Hey,
    I have an acer aspire one and whenever I try to start it up, i'm told that there is  missing or corrupt file: <windows root>\system32\ntoskrnl.exe
    I don't have a windows xp reboot cd.

    Is there any way I can get my computer to work without my harddrive being erased?
    Monday, November 02, 2009 11:27 PM


All replies

  • try last known good configuration and see if that works
    Monday, November 02, 2009 11:30 PM
  • i tried that, but it still doesn't work
    Monday, November 02, 2009 11:36 PM
  • without an installation disk to use the recovery console from, you dont have a lot of options, you can use a boot cd or a rescue cd to use the copy of ntoskrnl.exe thats in the "Windows\ServicePackFiles\i386" folder to replace it with
    Tuesday, November 03, 2009 12:14 AM
  • You can download the XP Recovery Console ISO then burn the Image to CD and boot from it
    When you get to the Recovery Console command prompt, type in Chkdsk /r (note: one space after "Chkdsk ")
    See if that fixes the fault
    Tuesday, November 03, 2009 10:39 AM
  • I have this issue and a recovery cd but cannot get a keyboard to be recognized.  I have tried 4 diff keyboards.  2 usb and 2 p/s2.  Please help!  All the keyboards were known to be working.  tested on other computer.
    • Proposed as answer by BratnCute Sunday, December 13, 2009 2:03 PM
    Thursday, December 10, 2009 4:11 AM
  • I hate to tell you this but your harddrive have finally crashed, toast, done. I had the same thing happen to me back in March of this year. <windows root>\system32\ntoskrnl.exe is a particular file that sits in a particular place on your harddrive and is suppose to remain in the same spot everytime your system boots up.
    When that file moves its because your hard drive has failed.  TheXP reboot disc may help but it will only be temporay because it will only take a matter of hours or may a day before you get the same error message and your back to square one.  I know I've been there. If I recall  try pressing key F2  to get the boot screen but do this before your computers shows any thing on the screen when you reboot. If you do get to this screen you should see a list of some of your system hard ware like CDrom etc. Its not a big list as a mater of fact the first word on the list is the word
    1. Normal  Look down the list and you should see 7.  Drive Diagnostic or something like that click on it and your hard drive's name should appear. It may take serveral minutes after that for the results to appear. It'll seem like nothing is happening but just be patient its working. When the diagnostic has finished betcha its going tell you that the drive failed.
    I couldn't figure out what was wrong when this happened. I tried everything to the point that even my keyboard stopped working. Nothing would type. This of course had something to do with my systems bios which apparently was related to the failure of my harddrive.

    I don't know much about computers but when something goes wrong with it I take note of it and and find out  everything my little female brain can take in.

    I'm a single mom so money's tight and I had to wait several months before I could afford to get another hard drive. I had someone replace my dead 40G with an 80G and started from scratch.THAT SUCKS TOO!! Now i backup my stuff and burn what I want to save on to CD -R's and CD-RW disc.

    Trust me there's nothing you can do except replace the hard drive

    Hope this info helps you and others in the future

    Sunday, December 13, 2009 1:51 PM
  • The system bios related to your keyboards function is out of wack because your hard drive has failed.
    Sunday, December 13, 2009 2:07 PM
  • ive tried that and it still brings me back to file is missing or corrupt <windows root>\system32\ntoskrnl.exe how do i re-install the file?
    Saturday, May 15, 2010 7:11 PM
  • Hiiiiiiiiii i got your problem of missing NTOSKRNL.Exe file...and it's not letting you to use windows. Try some basic steps for this Try this article Thanks Ujjawal
    Tuesday, April 26, 2011 2:38 PM
  • I am aware this discussion is a few years old, but it is still relevant and someone may come across it while trying to troubleshoot their computer, hence why I would like to point out that this answer is wrong.

    It is very possible for the hard drive holding the operating system to have failed, and this could be why the file is missing or corrupt, and consequently why the error is coming up. It is also very possible for the user to have a perfectly working hard drive and something else happen to the file.

    If you hear strange noises, particularly clicking, clunking or squealing, those are signs of a failed hard drive. It is possible for a drive to fail without physical symptom.

    If you have had no other issues or hear no strange sounds, try to repair Windows using the installation disc, as mentioned in other responses. If you do not have an installation disc, you may need to take the machine to a repair shop where they will be able to replace the file and further diagnose any issues with the computer.

    I would also like to mention that the advice on backing up files from BratnCute is important. If your hard drive does fail, or you lose the data on your computer for some other reason, having a backup of the data on your computer is vital. Backup your invaluable files, like pictures to CDs and DVDs or external hard drives, and if you have the space, try to do entire computer backups as well.

    Thursday, February 28, 2013 5:34 PM
  • I have tried boot disk, last working, tried RC.iso, still getting file missing message. No weird noises, hard drive seems fine. The XP version on this Toshiba laptop is XP Home. I have an XP Pro disc, can I use it? I tried it once before but got missing file message. If the XP Pro should work, please provide step instruction.

    Many Thanks, wedo43

    Saturday, November 23, 2013 1:31 AM
  • Hi arnavsharma,

    I downloaded XP Recoverty Console ISO and burned to DVD. Set to boot from disc. It began running through the setup but ended up with a bluescreen page that said 

    STOP: 0x0000007E (0x0000005, 0xF748E0BF, 0XF78DA208, 0xF78D9F08)

    As such I was unable to run Chdsk /r

    any suggestions??


    Sunday, November 24, 2013 3:19 AM