HomeGroup Issues/Strange Behavior


  • I have my HomeGroup pretty messed up currently, and can't seem to fix it.  I have a Desktop 7100 64 wired to a 2Wire HG1701(DSL modem/wireless router) and a Laptop 7100 32 connected over air to my HomeGroup.  This HomeGroup survived the upgrade from the 7000 build some months ago on both machines.  I just did the desktop pc format and then connected to the laptop who still had the password.  Then just formatted the laptop and connected to the same password.  Worked pretty nicely as it saved most of my settings from the previous build this way.

    My 2Wire modem/hub died a few weeks ago, got a new one, set it up, and now my HomeGroup is funky.  I thought I would just dissolve the HomeGroup and reset it up to solve issues.  So, I left the HomeGroup with the laptop no problem.  Went to my desktop to do the same thing and set it up again and this is where things are going goofy.

    In HomeGroup Settings:

    The top of the Homegroup window says "This computer belongs to a homegroup."

    Attempting to display the password for the HomeGroup produces and audio cue and nothing else.  Just a little ding.

    Attempting to change the password brings up the dialog, changing the password brings up a balloon stating "Windows cannot set up a HomeGroup on this Computer."

    Attempting to Leave the HomeGroup brings up the dialog, clicking Leave brings the "X" at the bottom of the dialog stating "Windows couldn't remove your computer from the Homegroup."

    Both computers can see each other in Network in the file manager, and I can explore some of my shares, but I would rather have my homegroup back again because of all the time I spent setting up Libraries.  I could set all this up the 'old' way, but I would rather have my homegroup back.

    The Homegroup Troubleshooter reports 1 issue found:

    Either the Peer Name Resolution Protocol services (PNRPsvc) or the Peer Networking Identity Manager services (p2pimsvc) is not running

    The Peer Networking Grouping service (p2psvc) depends on both these services in order to function properly.

    I played around with services a bit, but I really don't know what I am doing, so I didn't try.  Can anyone help me disentangle my homegroup?

    Thanks in Advance!

    Sunday, September 13, 2009 6:32 PM

All replies




    PNRP is one of core Technologies for HomeGroup. If the relevant service is stopped, we may not verify HomeGroup settings.


    After doing further research, let's verify the following services and check the result again.


    a. Click "Start", go to run, type "services.msc" (without quotation marks) in the open box and press Enter.


    Note: If you are prompted for an administrator password or confirmation, type your password, or click Continue.


    b. Right click the "Peer Networking Identity Manager" service and choose Properties.

    c. On General tab click Start.

    d. Choose Automatic next to Startup type.

    e. Click OK.

    f. Please repeat the above steps to start the following services: Peer Name Resolution Protocol; Peer Networking Grouping; PNRP Machine Name Publication Service.


    If the issue persists, please capture the screenshot of the error message and upload to SkyDrive ( ), and then let me know the link.




    • Marked as answer by Novak Wu Monday, September 28, 2009 1:13 AM
    • Unmarked as answer by Brimstone67 Monday, September 28, 2009 2:42 PM
    Monday, September 14, 2009 6:45 AM
  • Thanks Novak for the info.

    I did like you said and received errors, except for Peer Networking Identity Manager.  It was on Manual, and I changed it to Automatic and started it.

    Here is the link to the screenshots.

    Thanks again for helping me out.  Btw, I have set up all my shares the old way and everything works fine, just not 'HomeGroup'
    Tuesday, September 15, 2009 11:39 PM
  • I'm sorry that the link could not be accessed. Could you share a new link of the screenshots?

    Please also verify the following services for a test:

    HomeGroup Listener
    HomeGroup Provider

    If the issue persists, I suggest we perform a Clean Boot and then leave the HomeGroup again.


    • Marked as answer by Novak Wu Wednesday, September 23, 2009 8:11 AM
    • Unmarked as answer by Brimstone67 Wednesday, September 23, 2009 2:42 PM
    Friday, September 18, 2009 7:03 AM
  • Doh! Guess I should have just used the image hosters that I knew. Those pictures were put in my public folder on skywhatever. Trying to use that link now says that Live is down. Double - DOH! Anyway, I will try your suggestions and will see if I can rework that link. Thanks again.
    • Marked as answer by Novak Wu Wednesday, September 23, 2009 8:11 AM
    • Unmarked as answer by Brimstone67 Wednesday, September 23, 2009 2:42 PM
    Friday, September 18, 2009 2:46 PM
  • Hi,

    Please take your time to upload the picture and I will be glad to assist you to analysis it.

    • Marked as answer by Novak Wu Wednesday, September 23, 2009 8:11 AM
    • Unmarked as answer by Brimstone67 Wednesday, September 23, 2009 2:42 PM
    • Unmarked as answer by Brimstone67 Wednesday, September 23, 2009 2:42 PM
    Tuesday, September 22, 2009 6:23 AM

    I tried the 'clean boot' instructions but made no difference.

    Thanks again for the help.

    Wednesday, September 23, 2009 11:17 PM
  • Based on the screenshots, we can find that the "Peer Name Resolution Protocol" service failed to be started. It can occur if the service is corrupted. To fix the issue, you can perform the following steps.

    1. Please download the correct Network Connection registry file from the link below:

    2. There will be the PRNP.txt file. Please right click it and rename it to PRNP.reg file.
    3. Double click the PRNP.reg file and click Yes to import the file.

    Note: To avoid unexpected situation, please back up the computer registry before importing the registry file.

    4. Then, please verify the Peer Name Resolution Protocol service and other failure service again.

    What's the result?

    If the issue persists, you may need perform a Inplace Upgrade to repair the system or reinstall the Windows 7 system to resolve the issue.

    Thursday, September 24, 2009 2:44 AM
  • Downloaded, renamed, and imported.  Then restarted.  The problem remains.

    Dunno how it became corrupted when all I did was change routers.  Anyway, all shares work fine, so I won't really miss homegroup.  It's a pain to reinstall, not the windows part, but the ton of software I run and getting everything tweeked just so.  Anyway, thanks for your help.
    Thursday, September 24, 2009 3:49 AM
  • Please understand that Inplace Upgrade will not remove any software and data. It only repair some critical system files. After performing Inplace Upgrade, we will not reinstall any software.

    If you like, we can refer to the following steps to do Inplace Upgrade.

    In-Place upgrade (Repair install)
    1. Start the computer by using the current Operating System.
    2. Insert the Windows 7 DVD in the computer's DVD drive.
    3. Use one of the following procedures, as appropriate:
    If Windows automatically detects the DVD, the Install now screen appears. Click Install now.
    If Windows does not automatically detect the DVD, follow these steps:
    a. Click the Start Button, type Drive:\setup.exe in the start search box and then click OK.
    Note: Drive is the drive letter of the computer's DVD drive.

    b. Click Install now.
    4. When you reach the "Which type of installation do you want?" screen, click Upgrade to upgrade the current operating system to Windows 7.


    • Marked as answer by Novak Wu Monday, September 28, 2009 1:14 AM
    • Unmarked as answer by Brimstone67 Monday, September 28, 2009 2:42 PM
    Thursday, September 24, 2009 7:49 AM
  • I did the inplace Upgrade with the 7100 64 disc. I was a bit suprised on how long it took, way more than an hour on C2D 4gb & a raptor.  You are right, it did not mess with any of my settings or programs, but it DID NOT solve the homegroup issue.  During the upgrade, after it was finished, it asked me which network.  I used the Home Network option and it looked like it got stuck in discovery.  After about 20 minutes, I just hard rebooted and it finished normally after I choose Public Network.  After it was all said and done, I tried out Homegroup in the control panel.  All of the errors with homegroup remained.

    I guess a full format/reinstall is my only hope.  I'm not really going to bother with it right now, even if I would like homegroup to work again.  My shares work the old way with no issues, so I will just wait until the Family Pack is released and format with the final build.

    I unmarked all replies as answers because they did not work.
    Monday, September 28, 2009 2:51 PM
  • Just been reading along, I have the same error, did you ever find a fix?


    Thursday, April 08, 2010 11:02 PM
  • Refer to this link for a possible solution.  It worked for me:


    Thursday, June 10, 2010 1:28 PM
  • Hello,

    PNIM start / automatic went well.

    But i got error Can't start PNRP on local computer. Error "0x80630801:0x80630801"

    Any Idea

    Thanks in advance

    Friday, May 30, 2014 11:39 PM