none
"Remote Desktop can't find the computer " error

    Question

  • I encountered this error when I was trying to remote desktop to my office PC from a windows 7 home premium 64bit laptop at home through our copmany's VPN. I used IP address. Under VPN, I can ping that IP address, I can browse company's internal web site, but remote desktop can't find that IP address. Strangely, another laptop with same OS but different brand, can do VPN and Remote Desktop no problem. Can someone tell me how to diagnose the problem, like log file or something? Thanks.

    Tuesday, August 10, 2010 3:00 PM

Answers

  • Clear the MRU registry, and reboot did magic. It works now. Thanks so much.

    But what was the cause if you don't mind to share.

    • Marked as answer by Yaoming Duan Tuesday, August 17, 2010 1:27 AM
    Tuesday, August 17, 2010 1:27 AM

All replies

  • What is the model of the problematic computer?

    On the problematic computer please try:

    1. Re-create the Remote Desktop connection.
    2. Temporary disable antivirus and firewall.
    3. Update the network adapter driver.
    4. Boot in Clean Boot Mode.

    Perform a clean startup to determine whether background programs are interfering with your game or program


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Thursday, August 12, 2010 8:34 AM
    Moderator
  • The model is L505-ES5036. I found on internet that some people had similar problem caused by video card driver interfering RDM, I wonder if mine had similar cause. I did installed Skype briefly, then removed it. Don't know if that matters. Also another thing I noticed is that on the Sony vaio laptop that works, if I don't start VPN, and try to remote desktop my office PC, it gives a different error message dialog than the Toshiba does.  Where can I see detail log info, event log? 

    I'll try your suggestions. Thanks.

    Thursday, August 12, 2010 2:59 PM
  • If you would like check related logs, I recommend that you install Network Monitor and capture the network traces.

    Download details Microsoft Network Monitor 3.4

    Using the New Microsoft Network Monitor (netmon) 3.3 with Network Experts 

    Important Note: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Friday, August 13, 2010 2:39 AM
    Moderator
  • Hi,

    Sometime this will happen with remote desktop connection not with VPN or Network connection. As Arthur told first re-create the remote desktop connection. Check the IP address are in the same series. Otherwise you have to mention "Gateway IP".

    Before try with remote desktop, log off the remote PC, that is must.

    Disable the Firewall.

    -AJ

    Friday, August 13, 2010 6:32 AM
  • As I mentioned before, I have 2 laptops, one Sony one Toshiba. Everything works on the Sony one (VPN, Remote Desktop), So I compared mstsc.exe (Remote Desktop client), they are the same (size, version number, timestamp). Plus, VNC works on the Toshiba one, so network doesn't seem to be the problem. It most likely something installed by Toshiba is interfering with Remote Desktop, but I don't know how to diagnose which software is causing it. Any suggestions?

     

    Friday, August 13, 2010 6:40 PM
  • Windows 7 doesn't even allow me to uninstall Remote Desktop through Control Panel/Remove Program.
    Friday, August 13, 2010 6:41 PM
  • Hi,

    Clear the remote desktop connection, means you may delete the connection that was saved for the particular remote computer but not delete the mstsc.exe from computer or Remote Desktop from anywhere.

    If you have not saved the connection, you may follow the steps below to clear the Remote Desktop credential cache.

    1. Delete the MRU entries from the following registry:

    HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Default

    2.Enter gpedit.msc in Start Search box.
    3. Navigate to

    User Configuration/Administrative templates/Windows components/Remote Desktop Services/ Remote Desktop Connection Client.

    4. In the right pane double-click on "Do not allow passwords to be saved" set to enabled.

    Then please restart. After re-log on, enable this policy again.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Proposed as answer by HaydnWVN Friday, March 14, 2014 11:10 AM
    Monday, August 16, 2010 4:02 AM
    Moderator
  • Clear the MRU registry, and reboot did magic. It works now. Thanks so much.

    But what was the cause if you don't mind to share.

    • Marked as answer by Yaoming Duan Tuesday, August 17, 2010 1:27 AM
    Tuesday, August 17, 2010 1:27 AM
  • In Windows 7  

    HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Default was found in the registry

    however, there were no entries called MRU to be found. Only (default) REG_SZ (value not set)

    so I'm unable to do this.

    Next running gpedit.msc gives an error message of MMC could not create the snap-in.

    So this solution won't work for me.

    Saturday, July 30, 2011 10:35 PM
  • You'll need to be an Administrator to see the Group Policy settings.

    Friday, March 14, 2014 11:37 AM