none
Vista Home Premium- no option to connect to cable modem -Please help

    Question

  • I have just got Vista- anyone know why home permium only gives me the options for dialup or broadband pppoe. I can't connect to the internet and when trying to make connection the only options are dialup or broadband PPPOE. I tried loading the OS as Home and Work and same options on both. Am I missing something here. Thanks
    Thursday, February 01, 2007 1:24 PM

All replies

  • If you are on cable, the configuration is done through the cable modems interface. In IE type the address of your cable modem (after you have connected it to the Vista computer).  The address should be in the instructions manual from either the modem or your ISP, something like 192.168.0.1
    Tuesday, February 06, 2007 8:12 AM
  • Ok well the above link is a link to an advertisment. Not helpful. And if Im not mistaken the 192.168.0.1 is for routers not modems as a sub-IP address. Most cable companies use a modem and don't have a user interface. I have the same problem with attempting to access the internet. My modem is recognized by the OS through a USB port. My drivers for the motherboards ethernet are not loading or are not recognized by the Vista upgrade I installed on my Gateway GT5056, so Im using the USB. The device manager lists the Motorola Surfboard on the list in network adaptors. The OS is showing a connection but for local access only. I've tried changing the settings, removing the device, drivers, rebooting the modem, renewing the IP via command. I still can't access the internet. Very frustrating. Please help.

     

    Saturday, June 07, 2008 9:10 PM
  • Well, sorry. That was a change on their end. I don't know why they would redirect a link like that, but oh well.

    Other than the usual, disable firewall...etc solutions that might or might not work, I had an interesting fix for a non-internet USB connection problem.

    You can try going into device manager - Universal Serial Bus Devices - Composite Root Hub. Uninstall it, then reboot and let windows re-install it. That might work.

    Saturday, June 07, 2008 11:34 PM
  •  

    There's no config option, because none is needed - cable networks are, basically, plug-and-play.
    The network does not require username authentication (a PPP or PPPoE feature), and supplies IP addresses from  a DHCP server.

    Do this:  pull the power from the modem, and shut down the PC; remove the LAN cable.  Wait 30 minutes.  Plug the modem in and allow it to start up & get a line sync; wait 5 minutes.  Connect LAN cable.  Boot PC.  Once Windows comes up, it should automatically recognize the new network connection and pull an address.
    When Windows asks what kind of network you're connected to, tell it that it's a Public network (because it is.)

    If, however, you're using a USB connection to the modem, you'll need to install the drivers for the modem.  (LAN cable is easier.)

     

    ((smacks head)) and, then cup notices the date on the first post.  Thank you, ghostinthemachine, for dredging up a 16 month old thread....

    Sunday, June 08, 2008 3:53 AM
  • Ghostinthemachine, I am having the exact same problem. Did you, or anyone for that matter, figure out how to fix this? I've been trying everything for days: plugging, unplugging, restarting, installing drivers, diagnostics, sitting on the phone with my ISP for two hours, messing around with command prompt, voo doo. I've stopped short at human sacrifice, but who knows how long this is going to go on. I'm going crazy.

     

    Friday, June 13, 2008 6:10 PM
  • Call you cable company and give them the MAC address of the modem. They need that to recognize the modem on their network.
    Sunday, July 20, 2008 1:58 AM
  • I have the same kind of issue.  My issue is that I'm trying to install Windows Server 2008 R2 X64 RC.  The install went fine, but I can't get the server connected to the internet.  Now I know all the usual comments on plug and play and resetting everything, and I've done all that.  Problem is this... I replaced the hard drive with a new hard drive for this install so that it would be a clean install.  The old hard drive has Windows Server 2003 R2 X64 on it and it connects to the internet just fine and runs just fine.  When I shut down the server and replace the 2003 drive back in and boot, then it works and gets internet.  When I swap back to 2008, it doesn't work again.  It's something in the fancy security settings Microsoft is shoving upon us with Vista, Windows 7 and Windows Server 2008.  I don't know what, but would surely appreciate any insight anyone might have. 

    Thanks
    C

    Sunday, July 19, 2009 2:06 PM
  • I have the same kind of issue.  My issue is that I'm trying to install Windows Server 2008 R2 X64 RC.  The install went fine, but I can't get the server connected to the internet.  Now I know all the usual comments on plug and play and resetting everything, and I've done all that.  Problem is this... I replaced the hard drive with a new hard drive for this install so that it would be a clean install.  The old hard drive has Windows Server 2003 R2 X64 on it and it connects to the internet just fine and runs just fine.  When I shut down the server and replace the 2003 drive back in and boot, then it works and gets internet.  When I swap back to 2008, it doesn't work again.  It's something in the fancy security settings Microsoft is shoving upon us with Vista, Windows 7 and Windows Server 2008.  I don't know what, but would surely appreciate any insight anyone might have. 

    Thanks
    C


    You should post your question in the Windows Server forum.
    [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Sunday, July 19, 2009 6:03 PM
  • If a minimum of 35 minutes connection time is plug 'n play, I'd sure hate to see the alternative. Hence the problem with Vista, jack of all trades and master of none!
    Sunday, August 09, 2009 4:34 PM
  • If a minimum of 35 minutes connection time is plug 'n play, I'd sure hate to see the alternative. Hence the problem with Vista, jack of all trades and master of none!

    It's not a "Vista Problem."  It's just how cable networks work.

    Please don't troll....  :)

    And, now, back to out regularly scheduled programming.
    [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Sunday, August 09, 2009 5:54 PM
  • Check that you have the proper drivers installed for your network cards.  In my case, the OS recognized the network cards, but it still didn't work right.  If you have drivers for the cards, install them for sure!  Then network config should happen pretty much automatically.

    Thanks
    C

    Monday, September 14, 2009 8:36 PM
  • same thing is happening to me. its not the isp, i know because my xp computer and my mac can use this modem to connect.  for me i think it has something to do with att. let me tell you why..... this modem worked fine on my computer until i installed dsl. ive been using dsl on this computer for a while. well ive decided to switch the dsl to my mac and put the cable modem back on the pc and now and its not working. ive been trying for days to get the pc to work with the cable modem again....... ive turned it off, reset it tons and tons of times. i have reset the dhcp and ip and everything else. im about to just turn my computer back to factry default but ill lose tons of program settings and i really dont want to do that, it would mess up my livlihood because i use my computer to make money.  i need tha cable modem on the pc, i can't put dsl back on the pc for personal reasons i can not say. but ya,  this is ridiculous my cable modem wont connect. please i hope someone can help me. i need this computer back online. att made me download something when i put dsl on it, so maybe thats what is messing it up.  please help me.
    Friday, October 30, 2009 1:26 AM
  • Hey Sad Gurl,

    In your case, you may be connecting directly to the cable modem.  If you cable modem is from Comcast (others may do this too, but I know Comcast does), then what it is, is that the server has tied to your MAC address.  The MAC address is the unique address of your network card.  Since you used the cable modem with the Mac, it tied to the Mac's MAC address and will refuse to tie to the PC.  You will need to call your cable modem carrier and ask them to reset the MAC address so the PC can match up.  Alternatively, you can get a Router like the WRT54GL that has the option to "Clone this PC's MAC" which essentially masks all traffic going through it as coming from the MAC of the computer you're logged on with at the time.
    Anyway, I think a call to support will solve your problem.

    Later
    C

    Tuesday, November 03, 2009 1:29 AM