Windows Update to SP1 error: 800B0100


  • Hi,

    The computer is running windows 7 x86 build 5600.

    It has been failing to update service pack 1 for a while now KB976932.

    It says it needs to install 42Mb out of the 533Mb.

    I've tried disabling all antivirus and firewall software,

    I've tried typing this into an elevated cmd prompt regsvr32 Wintrust.dll /s.

    I've tried installing the standalone manual update from the windows site 533MBs for windows 7 32 bit.

    After installing the standalone update to sp1 it comes up with this error message after the installation: DS_S_SUCCESS (0x0)

    I check the dxdiag for the build and it hasn't updated sp1.

    I'm not sure what else to do, can someone please post some ideas?


    Kind regards


    Monday, June 27, 2011 11:52 AM


All replies

  • Hi,

    Please access the following link.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Thursday, June 30, 2011 7:09 AM
  • Fixed.

    After many solution attempts I renamed the Software Distribution folder and it downloaded and installed SP1 successfully

    Thursday, June 30, 2011 10:09 AM
  • This is really a very valuable information after struggling for a few on applying all those "solutions" from Microsoft which didn't help at all.

    Simply rename the "SoftwareDistribution" folder, it just booms, verything just goes fine....


    Wednesday, October 05, 2011 7:01 AM
  • This MS solution does not work for error 800B0100 as it applies to Windows Update WIN7 SP1 upgrade. It is disappointing MS did not publish a solution that works (At least not the ones that I could find) for the SP1 related error. From what I could see online there were many users who experienced this error but got no help from MS support. Fortunately, I came across the solution here and that was simply renaming the SoftwareDistribution folder. After renaming the folder I started the update again and it ran and completed smoothly.

    Many thanks to the user that published the solution. I am very grateful.

    Saturday, June 30, 2012 10:54 PM
  • This worked for me as well. Renamed the folder, reran the update, and it completed with no problems. Thank you.
    Saturday, June 30, 2012 10:57 PM
  • Hi,

    I too, am experiancing all of the above problems for quite some time. Could you or anyone advise me on Where  or How, I can find my SoftwareDistribution folder? Any tips on what to rename it? I would greatly appreciate any advice on how to go about trying this solution.

    Many Thanks,


    Tuesday, April 01, 2014 8:06 AM
  • I also was experiencing these problems, thanks in advance for any help!
    Tuesday, April 01, 2014 8:37 PM