none
Internet explorer messing up my internet

    Question

  • Hey guys and girls.

    Every time i start windows 8 professional, I can't connect to internet without first starting an internet explorer window.

    First things first, let me tell you how I think I ended up with the problem.

    I downloaded a freeware program that would help me with my work, and the damned thing stealthily installed the Babylon toolbar stupid thing in all my browsers without warning me.

    After a painstaking process of removing the thing from my computer (uninstalling it from programs apparently did nothing), I tried reinstalling firefox from scratch to get rid of it.

    It did work, however, IE wouldn't let firefox become the default browser anymore. Firefox always saw itself as default, but it was IE doing all the actions, and there was really nothing I could do about it.

    So i decided to disable internet explorer completely.

    And all was fine.

    Until yesterday, when i realized by favorite stream news channel won't work in firefox after the latest update, so i re-enable IE.

    Since then, my internet won't work untill i open an internet explorer window.

    Just figured that if I don't keep the IE open the internet stops working. Could this be the work of a virus?

    Sooo, any ideas on how to fix this?


    • Edited by mcosmin Sunday, September 16, 2012 9:38 AM
    Sunday, September 16, 2012 9:37 AM

Answers

  • Temporarily disable antivirus and check if it works properly.

    Do you need to manually dail-up to your ISP and then connect to Internet? If you connect via a router, properly configure the router and it will dail-up for you.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    • Marked as answer by mcosmin Monday, September 17, 2012 10:09 AM
    Monday, September 17, 2012 3:33 AM
    Moderator

All replies

  • Temporarily disable antivirus and check if it works properly.

    Do you need to manually dail-up to your ISP and then connect to Internet? If you connect via a router, properly configure the router and it will dail-up for you.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    • Marked as answer by mcosmin Monday, September 17, 2012 10:09 AM
    Monday, September 17, 2012 3:33 AM
    Moderator
  • Eh, my idea would be not to use I.E

    yet..Any way. ITS A MESS!

    Monday, September 17, 2012 10:01 AM
  • Everything seems to work fine after the latest update for Windows Defender.

    Monday, September 17, 2012 10:09 AM