Windows update fails with error 0x80070001 RRS feed

  • Question

  • I recently installed the creators update and now Windows update fails with code. 0x80070001. I tried to run WindowsUpdateDiagnostic.diagcab and it told me the problem was fixed, but I still get the error.

    Tuesday, December 5, 2017 6:39 PM

All replies

  • I installed KB3213641 and that seemed to work, but I still get (almost) the same errors in Windows Update after the install.

    Wednesday, December 6, 2017 3:40 AM
  • Hi,

    I suggest you run the following commands:

    sfc /scannow
    Dism /Online /Cleanup-Image /RestoreHealth

    If the issue persists, manually reset the Windows Update Components:

    How do I reset Windows Update components?

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact

    Wednesday, December 6, 2017 7:25 AM
  • The two commands sfc and Dism completed successfully. Still the same problem.

    I then tried to reset Windows Update components, but the two dirs CatRoot and SoftwareDistribution were locked. I used a tool that could rename them after a reboot. However, I still get the Windows update errors and the error seems to be related to any update, not just word 2007.

    • Proposed as answer by kherkendaal Monday, August 13, 2018 7:27 AM
    • Unproposed as answer by kherkendaal Monday, August 13, 2018 7:31 AM
    Thursday, December 7, 2017 2:42 PM
  • This is what I get when I search on the catalog page

    We did not find any results for "kb4041994"

    Friday, December 8, 2017 4:48 AM
  • I have several pictures, it's on the last picture above. Marked with red
    • Edited by RTL-coder Friday, December 8, 2017 5:11 AM
    Friday, December 8, 2017 5:11 AM
  • Please indicate whether you were or were not able to fix error 0x80070001.

    If you were able to fix it please indicate the troubleshooting steps that you made.

    If you were not able to fix it please let us know so that we can provide help.

    • Proposed as answer by kherkendaal Monday, August 13, 2018 7:26 AM
    • Unproposed as answer by kherkendaal Monday, August 13, 2018 7:31 AM
    Tuesday, December 26, 2017 12:04 AM
  • I had exactly the same issue with my PC with the 0x80070001 error regardless of troubleshooting attempts. Everything would load if I did it manually. The problem in the end turned out to be a program I was running called VFD21. It was providing me with virtual floppy drives that I was using for client software retention. It created a Drive B floppy for me and after that all of the automatic updates caused the error. Once I turned the utility back on and deleted the Drive B virtual floppy everything returned to normal and my updates worked fine. Hope this helps.
    Monday, August 13, 2018 7:31 AM
  • I found out the problem some time ago, I just forgot to update this thread. I am running ImDisk since I want to limit the amount of writes to my flash drive. I have the temp directories set to this ram disk.

    Installing ImDisk causes windows update to stop working:

    However, I regard using a RAM disk is as more important than windows updates so for now I have no updates.

    Thanks for posting.

    • Proposed as answer by Keränen Monday, September 24, 2018 5:34 AM
    Monday, August 13, 2018 4:44 PM
  • Thank you RTL-coder! You just made my day. I have been looking for solution to my update problem for some time now, and nothing helped.

    I just needed to uninstall ImDisk and update started to work. But i'm missing my RAM disk already.

    Monday, September 24, 2018 5:39 AM
  • Thanks. It helped me.

    In my case , I had "A" drive which was created by mounting a floppy disk image using ImDisk. But that drive wasn't accessible. After un-mounting "A" drive, the update worked!

    I think, you can reproduce this as follows ( I didn't tried though):

    1. mount an image to any drive using ImDisk

    2. reboot without unmounting the drive

    3. try update

    • Edited by James S. Chi Wednesday, February 20, 2019 1:22 AM
    Wednesday, February 20, 2019 1:13 AM
  • I had the same problem. But after uninstalling ImDisk I was able to install the updates.

    I found the solution here:

    Wednesday, February 27, 2019 7:42 AM
  • I have been having this Windows update problem for several months. I am glad I at last found this page. Looking at the current ImDisk issues, I also found the following

    So after switching the RAM disk drive letter to Z: (i.e., neither A: nor B:) the issue is gone. That means Windows Update no longer fails and I can keep using ImDisk.

    • Edited by cbroult Monday, March 4, 2019 1:09 PM
    Monday, March 4, 2019 11:41 AM
  • This last post has solved a mystery I have been having for months.

    I am not using ImDisk but I am using FreeOTFE (similar to TrueCrypt and VeraCrypt) and one of my volume files is mounted as drive letter B:

    I read this post, dismounted the Drive B: and now I no longer get this error and Windows Update proceeds correctly for the first time in many months.

    Thanks so much. Had no idea drive letter B: was not up for grabs and should be left free for the Windows system. I will change it.

    • Edited by Max105 Sunday, July 21, 2019 9:38 AM
    Sunday, July 21, 2019 9:38 AM
  • This is what I get when I search on the catalog page

    We did not find any results for "kb4041994"


    Someone do this


    Sunday, July 21, 2019 2:52 PM
  • Thank you!!! I've been struggling with this for so long! I even reinstalled windows and it still wouldn't work. It's hard to believe that IMDisk would cause this, but yes, that's it.

    Metro or whatever they call it now is half-baked garbage which broke a perfectly good OS.

    I found that it works if you just dismount the drive. You can dismount the RAMDisk, update or install whatever you need and then remount the RAMDisk.
    • Edited by navmed Sunday, December 15, 2019 12:26 AM
    Sunday, December 15, 2019 12:25 AM
  • I was so pissed at microsoft, and tired of trying to install updates manually from time to time. I had imdisk running a virtual drive a for some old software that uses a floppy for licensing on my work and home computer. I just unmounted, and use as needed now. So glad I found this post, thank you. 
    • Edited by jtalb5322 Monday, January 6, 2020 7:06 AM
    Monday, January 6, 2020 7:06 AM