locked
Handwriting recognition missing RRS feed

  • Question

  • If I go to Control Panel, Language and tap the Options button to the right of English United States, it shows a heading Handwriting and I can tap Personalize Handwriting recognition.  Also in OneNote 2016 handwriting recognition works.

    But if I go to Language and tap the second language, English New Zealand and tap Options, it says under Windows Display Language, A language pack isn't available. Also there is not heading Handwriting.  No surprise, in OneNote 2016 handwriting recognition fails.

    One a different laptop, when I tap options next to English New Zealand, it all works as expected, and Handwriting is available and it works.  Also when I tap Options, there is an option to Uninstall Language Pack.

    These are both Windows 10 builds.  How do I get handwriting working for English New Zealand?  We have 45 laptops to fix...

    Thanks, Neal 

    Friday, October 13, 2017 1:25 AM

Answers

  • Hi Neal,

    DISM command line tool is used to apply, capture and delete an image. 

    Please navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate in registry.

    There are two String value named "WUServer" and "WUStatusServer"

    Please delete them and check if you could load your language again.

    If the issue persists, please upload Windowsupdate.log(C:\Windows) to OneDrive and paste the link here.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by HotAir3.1 Thursday, October 19, 2017 7:32 PM
    Wednesday, October 18, 2017 11:08 AM
  • Solved.

    After rebooting, start, settings, region and language, Options then an Add button appeared.  Installed, rebooted and all done.

    Thanks for the help!

    • Marked as answer by HotAir3.1 Tuesday, October 24, 2017 1:23 AM
    Thursday, October 19, 2017 7:31 PM

All replies

  • Hi,

    What’s the device model?

    What’s the exact version of Windows 10 (1511, 1607, or 1703)?

    There is no handwriting function when you changed your display language to English New Zealand, right?

    Update Windows to the latest through Windows Update feature to check the symptom again.

    Try to check if you could use handwriting through Settings\Time&Language\region&language\Related settings “Additional date, time & regional settings”\Close, language and Region\Language\Change input methods\click “next” behind English (New Zealand)\Handwriting ”personalize handwriting recognition”\Teach the recognizer your handwriting style\Sentences\next.

    If the issue persists, we could download Windows 10 Features on Demand which contains Hand writing feature, then deploy this feature through Group Policy/logon script.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Joy-Qiao Friday, October 13, 2017 7:08 AM
    • Edited by Joy-Qiao Friday, October 13, 2017 7:09 AM
    Friday, October 13, 2017 7:08 AM
  • Device is HP EliteBook x360 1030 G2

    Windows build is 1703 (build 15063.0)

    Right. No handwriting.

    Windows update, all up to date, no fix.

    When I follow the path you suggest, I get to English New Zealand and that is where it fails.  Instead of Handwriting, Personalize etc, there no handwriting options.  It just says under the heading Windows Display Language, "A language pack isn't available.

    I would love to fix this, so how do I get the Windows 10 Features on Demand to work?


    Thanks, Neal 

    Monday, October 16, 2017 1:18 AM
  • Looks like the answer is here...

    https://docs.microsoft.com/en-us/windows-hardware/manufacture/desktop/add-language-packs-to-windows

    In this article I read this: 

    Where do I download the language packs?

    OEMs and system builders can get the packages and features from dedicated download centers for OEMs and System Builders.

    That doesn't help me at all!

    But if I do manage to get the packages and features, it looks like I need this command to add the OCR and the handwriting recognition:

    Dism /Add-Package /Image:"C:\mount\windows"
         /PackagePath="C:\Languages\Microsoft-Windows-Client-Language-Pack_x64_en-nz.cab"
         /PackagePath="C:\Languages\Microsoft-Windows-LanguageFeatures-Basic-en-nz-Package.cab"
         /PackagePath="C:\Languages\Microsoft-Windows-LanguageFeatures-OCR-en-nz-Package.cab"
         /PackagePath="C:\Languages\Microsoft-Windows-LanguageFeatures-Handwriting-en-nz-Package.cab"

    Does that look correct?

    Thanks, Neal 

    Tuesday, October 17, 2017 8:44 PM
  • Hi Neal,

    DISM command line tool is used to apply, capture and delete an image. 

    Please navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate in registry.

    There are two String value named "WUServer" and "WUStatusServer"

    Please delete them and check if you could load your language again.

    If the issue persists, please upload Windowsupdate.log(C:\Windows) to OneDrive and paste the link here.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by HotAir3.1 Thursday, October 19, 2017 7:32 PM
    Wednesday, October 18, 2017 11:08 AM
  • Thanks again for your help.  

    I tried removing the registry keys, but still didn't work.  Finally I made the laptop a workgroup member (no longer a domain computer) and tried again.  This time it found the pack and installed - and I got the KB number!

    From that I can only conclude that there was something in our (complex) Group Policy that was stopping it from working.  And now I am wondering if the language pack was in our Windows Updates Server, it might have worked - something for me to check later, as that would make rolling out the extra language features easier.

    OK, I couldn't wait, went and looked and it was there but NOT APPROVED FOR INSTALL!  I have just corrected, now I'll run off and see if the clients can pick it up.

    Thanks again!

    Thursday, October 19, 2017 2:48 AM
  • Hmmm, well, it's progress but... rebooting, I discover that the language is now 'Enabled' but there is still no handwriting options.

    The question now is, how do I add or enable handwriting?

    Thanks, Neal 

    Thursday, October 19, 2017 3:04 AM
  • Solved.

    After rebooting, start, settings, region and language, Options then an Add button appeared.  Installed, rebooted and all done.

    Thanks for the help!

    • Marked as answer by HotAir3.1 Tuesday, October 24, 2017 1:23 AM
    Thursday, October 19, 2017 7:31 PM
  • Hi,

    Thank you for your feedback. I think the experience, feedback and the result would be very useful for other customers.

    Bests,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, October 20, 2017 1:33 AM