none
Deleted

All replies

  • Hi Ali Belali,

    According to your description, you could perform a Clean Boot and disable the security software temporarily to check.

    Then try to reset Windsock with the command below.

    netsh int ip reset 

    "@Netcfgx.dll,-50003" always means that allows other computers to access resources on your computer using a Microsoft network."

    You check if the system has enable the IPV6 and firewall settings.

    If you have update the network driver to the latest version, you could roll back it to check

    Hope it will be helpful to you


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, August 8, 2017 9:24 AM
    Moderator
  • Deleted
    Tuesday, August 8, 2017 5:20 PM
  • Deleted
    Wednesday, August 9, 2017 7:10 PM
  • Hi Ali Belali,

    Thank you for your update.

    As I understand it, copy and paste the following into a text file, then save the file with .bat as the extension.

    Enable file sharing:

    echo off

    netsh advfirewall firewall set rule group="File and Printer Sharing" new enable=Yes 

    Disable file sharing:

    echo off

    netsh advfirewall firewall set rule group="File and Printer Sharing" new enable=No

    Then you could put the short cut into StartUp folder.

    https://www.computerhope.com/issues/ch000322.htm

    Please Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Hope it will be helpful to you


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, August 10, 2017 11:11 AM
    Moderator
  • Deleted
    Saturday, August 12, 2017 3:40 PM
  • thanks for answering

    The CMD did not have same result as disabling and enabling "File and Printer Sharing for Microsoft Network" for each network adaptor and did not help

    Hello everyone
    I decided to go to windows 10 Creator update 1703 within my company
    Installation from scrath windows 10 1703 problem with file and sharing on localhost (system error 53)
    I realized my image correctly, but I encounter a major worry, the same as you :-(

    The file and sharing print is active on the network cards, but im possible to access the resources
    Net view \\ localhost == error 53
    Net view \\ server ==> ok the client smb works fine
    Net view / all ===> ok too

    The solution is at every start

    Right click active network adapter -> properties -> uncheck "File and Printer Sharing for Microsoft Networks" ->

    And retry few second net view \\ localhost ==> ok

    I noticed the problem when deploying the image (junction has a domain ok = because smb client works
    The same problem occurs during the first sysprep in audit mode, or when hyper-v i switch from a network card to a legacy network card, the problem appears.

    Since Windows 1607 == no worries known in my park.




    • Edited by ChrisStyle Thursday, August 24, 2017 6:33 AM
    Tuesday, August 22, 2017 9:10 PM
  • upvoted -- having the same issue
    Friday, January 26, 2018 10:42 PM
  • yup, same symptom here...
    Tuesday, February 6, 2018 4:58 PM
  • Upvoted - same issue here too. Windows 10 v1709

    Monday, February 19, 2018 9:06 PM
  • Same issue since 1709 for me.  After every reboot.

    Right click active network adapter -> properties -> uncheck "File and Printer Sharing for Microsoft Networks" -> Save > properties again > enable check > works OK.  Check firewall rules file and printer sharing after doing this for allow access on your private/public network.
    • Edited by scanovic Friday, February 23, 2018 8:32 PM
    • Proposed as answer by Squash01 Friday, September 21, 2018 1:27 AM
    Wednesday, February 21, 2018 9:51 PM
  • I am experiencing the same Issue since i replaced my PCI Express  Network Card last week from a

    TP-Link TG-3468  PCIe (1000/100/10 Mbit/s)

    Model TG-3468

    to a 

    UGREEN PCI Express PCIe Gigabit Ethernet Lan Card 10/100/1000 Mbps Low Profile

    Model 30771

    Today then i had enough of this extreme annoying behavior and replaced my new Ugreen Network Card with my previous TPLink Card and sametime i did that my SMB Shares work like a charm again. And i can reboot my PC alltime and the SMB SHares are stable working.

    I can also reproduce this behavior.

    Both Cards use a Realtek Chipset. The Drivers from the TPLink which works perfect are now from 2011 7.50.1123.2011.

    Driver: tpg64win7.sys

    which is the Version my System automatical installs as best current available for my Network Card.

    Signature Realtek Semiconductor Corp

    while the Ugreen are from 2016.

    I tried then to reverse all drivers for the Ugreen Card back to 2015 and all failed after a reboot.

    I also tried to install updated Drivers for the TP Link which i first place thought is the better working card in this Issue and had to realize that the same Issue appeared as with the 2nd card once i updated with "any" new Network Card Drivers no matter what it was.

    I had to reverse with a system recovery point i made a day before my tests and now my shares are back.  

    Why is out of my knowledge. I have no idea what is in my System before and afterwards i just updated the Realtek Drivers in 1709 Windows.

    And that a reinstall with the old Drivers wasnt working either is quite confusing.  

    My System is Windows 10 Home 64 Bit 1709








    • Edited by LVNDSCAPE Saturday, February 24, 2018 8:32 AM
    Thursday, February 22, 2018 4:45 PM
  • Just adding my "me too" comment. Every time I reboot a particular Windows 10 computer, I can no longer see my shared folders. The fix is to go into the network adapter and uninstall "File and Printer Sharing" and then immediately install it.  

    I have to do this after every reboot. This started after the Creators update. 

    Tuesday, February 27, 2018 6:49 PM
  • Please all affected Users try this Workaround

    partnersupport.microsoft.com/en-us/par_clientsol/forum/par_win/windows10-1703-file-and-sharing-printer-net-view/9569d27f-d979-4c5a-9a01-98cd9c99c4f2?page=2


    from

    VESATI


    Potential workaround/solution

    (Working as of 12/2/2017 on Windows 10 Pro, version 1709, build 16299.98)

    It is working on my side if i add the Sheduled Task as being run at "Logon" but not at system Start.


    Only thing i wasnt really clear of first place was the handling of the Task Scheduler to get the "highest privileges"

    which was then easy to klick "Settings" at the right Side > Selected Element or Selection Menu > Settings

    There you can set the Batch Files "highest privileges" .

    Hope it helps till Microsoft will fix this annoying Issue.

    And please reply if it helped.






    • Edited by LVNDSCAPE Saturday, March 3, 2018 7:21 PM
    • Proposed as answer by HasITBeenDone Tuesday, March 13, 2018 8:41 PM
    Saturday, March 3, 2018 5:06 PM
  • This workaround works for me, thanks for the link. Using task scheduler to run a bat file at logon with elevated privileges using the netcfg command in your link allows file sharing to work after reboot & logon.
    Thursday, March 8, 2018 3:03 AM
  • Just had the same problem with Windows 10 Version 1803. Nothing helped, except disabling and re-enabling file sharing on network adapter. Installed a workaround as suggested here by automating that procedure on startup. But hey, what an annoying problem! File sharing and computer discovery in windows is severely broken for a long time now. Time to act, Microsoft!

    Tuesday, May 15, 2018 11:57 PM
  • Another me too. HOURS lost to this.

    From all the reading, it seems to have something to do with ghost pieces of adding a new NIC then removing an older one. Ive tried everything, full network resets, drivers... everything listed here. Only thing that fixes it is to manually go in to the GUI every time, uncheck, ok, then recheck File and Network Sharing in the NIC props.I

    I cant believe this is years old and Microsoft just keeps ignoring it.


    "Programming is an art form that fights back"

    Cosmos - C# Open Source Managed Operating System
    http://Cosmos.CodePlex.com

    Wednesday, July 25, 2018 7:54 PM
  • I am also seeing this with my Windows 10 1803 build. I am configuring this build in audit mode and can confirm that while still in audit mode I can access \\hostname\C$ shares.

    Once I sysprep the image I then have the issue which can be resolved with the file sharing re-enable script.

    On the same laptop I disabled the network adapter and used a USB wifi - this also had the same issue.

    i wiped the image and installed Win 10 1803 without audit mode and sysprep and the image was fine - I could map \\hostname\C$

    It seems to be an issue with sysprep - anyone else seeing this ?

    Wednesday, August 1, 2018 9:31 AM
  • I have this issue with an entire office (~20 computers) that I sysprep'd before deploying an image.  Wasted a call to Microsoft ($300 we'll never see again) and almost 40 hours of labor.  End suggestion from Microsoft: "Re-image".  Serendipitously I found that unbinding and re-binding File and Print Sharing from the adapter did the trick.  Still no fix from Microsoft.  However, I too wrote a script to execute the following powershell commands:

    Disable-NetAdapterBinding -Name "Wi-Fi" -ComponentID ms_server
    Enable-NetAdapterBinding -Name "Wi-Fi" -ComponentID ms_server

    That seems to do the trick.

    • Proposed as answer by roberti Wednesday, November 28, 2018 2:39 PM
    Monday, August 20, 2018 4:23 PM
  • Deleted
    Tuesday, August 21, 2018 3:07 PM
  • Same here too. Super annoying problem.
    Thursday, September 13, 2018 1:02 PM
  • This worked for me after latest update for 1803

    I suspect this enabled a service but am unsure which one

    Thanks @scanovic

    Friday, September 21, 2018 1:30 AM
  • I can confirm that this issue still exists in 1809...

    Come on Microsoft! Fix this!

    The problem seems to be that port 445 is not "Listening"

    C:\temp>netstat -a

    Active Connections

      Proto  Local Address          Foreign Address        State
      TCP    0.0.0.0:135            DESKTOP-E8ILBM0:0      LISTENING
      TCP    0.0.0.0:2179           DESKTOP-E8ILBM0:0      LISTENING
      TCP    0.0.0.0:5040           DESKTOP-E8ILBM0:0      LISTENING

    If I disable/enable "File and Printer Sharing for Microsoft Networks" and then rerun the command I get

    C:\temp>netstat -a

    Active Connections

      Proto  Local Address          Foreign Address        State
      TCP    0.0.0.0:135            DESKTOP-E8ILBM0:0      LISTENING
      TCP    0.0.0.0:445            DESKTOP-E8ILBM0:0      LISTENING
      TCP    0.0.0.0:2179           DESKTOP-E8ILBM0:0      LISTENING
      TCP    0.0.0.0:5040           DESKTOP-E8ILBM0:0      LISTENING


    • Edited by richardgnz Wednesday, November 28, 2018 9:48 PM
    Wednesday, November 28, 2018 8:48 PM
  • I have encountered this issue multiple times now on both 1803 and 1809. When I am deploying a build I boot into audit mode / apply customisation / then sysprep. I always end up with a build that has the port 445 not listening problem. Resolved by disabling and re-enabling "File and Printer Sharing for Microsoft Networks"

    I have spent many hours testing why this was happening and what I found was if I connected to a network at the start of my build process it would result in the bug. At some point during customisation and windows updates the bug would appear after sysprep.

    In my testing I stepped through every individual change that I would make to an image and ran sysprep after each and every one (Without ever connecting to a network). None of my customisations resulted in the bug after sysprep.

    I also tested audit mode with no customisation and ran a full windows updates - then performed sysprep. This image was fine and the bug was not present.

    My final test I booted into audit mode - I DID NOT CONNECT TO ANY NETWORK - performed all my customisation. Once I was ready to run sysprep I first connected to a network and ran windows update. All Updates installed and the system was restarted. I then ran sysprep and my resulting image did not have the bug.

    Hope this helps someone....

    Tuesday, December 4, 2018 1:00 AM
  • I have same problem. My work is often to configure scan to file to a shared folder from a MFP. I will test the script walk around. Thanks
    Thursday, December 13, 2018 7:05 AM
  • This solved this problem for me:

    https://superuser.com/questions/1240213/cannot-connect-to-windows-share-via-local-network-ip-address-but-can-by-localho

    • Proposed as answer by worst bull Tuesday, January 1, 2019 4:59 AM
    Friday, December 28, 2018 9:03 PM
  • This tool did the trick for me: https://github.com/filippobottega/ShareFix (it automatically performs the fixes from bob92's link).
    Tuesday, January 1, 2019 4:59 AM
  • The link you gave is dead - could you please say what the workaround is?

    Friday, January 11, 2019 12:37 PM
  • This script helped me:

    https://www.tenforums.com/network-sharing/90318-broken-file-printer-sharing-microsoft-networks-2.html#post1417208

    Note that this is a work-around rather than a fix.

    Friday, January 11, 2019 6:05 PM
  • I have had the same problem ever since i bought a new laptop - asus FX53v .  My workaround was to go into adapter settings properties and uncheck ipv6, and exit,  then without rebooting, simply recheck IPV6.  then magically i was able to use and see the shared folders.  I just tried your powershell commands to disable and re-enable file and print sharing, and that worked also!  I think it is important to realize that it probably has nothing to do with either file sharing or ipv6, it has something to do with whatever happens after you disable/ re-enable stuff.  maybe unchecking/rechecking ipv4 would also work.
    Monday, February 18, 2019 3:15 AM
  • this worked for me!  it is not a workaround, you only need to run it once! thanks!
    Monday, February 18, 2019 3:25 AM