Virtual PC XP mode isn't communicating using my com1 port


  • I've searched, found some good advise but none that seemed to fix my issues.

    I upgraded from XP to Windows 7 this winter.
    I have a Roland Camm-1 CM-24 vinyl cutter.  This uses com1 port to get it's information from the computer.  They don't have any up to date drivers that work with windows 7.  I installed Virtual PC XP mode, installed the drivers and software on that, they run fine, but it still doesn't communicate with the cutter.

    I have made sure to match up the virtual port to the real com1 port, and I did also make sure the com1 port is labeled/numbered correctly.  It doesn't appear anything is using this port either.

    When I send the job to the cutter, it doesn't send, but doesn't throw any errors up either.
    I have tried a USB to serial adapter, but that didn't work either.  When I installed the software for that, it labeled that usb port/device as com5, but virtual PC won't go that high with com ports.

    Any advice?  I hope I've given enough info to hopefully make some sense of my issues.
    Thanks a bunch for reading!

    Friday, April 06, 2012 3:35 AM


  • Hi,

    I suggest contacting to Roland Support asking for releasing the latest driver.

    Please Note: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

    Meanwhile, you can verify the configuration of the COM port for a virtual machine by referencing the link below:

    Best Regards,

    Kim Zhou

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Tuesday, April 10, 2012 8:46 AM