Windows 7 unable to access the DFS having Multiple IPs


  • Windows 7 users are unable to access the DFS shares sometimes, however they are able to access the same with IP.

    I have almost 400 users with Windows XP and Windows 7 in two different sites. Initially we were on windows 2003 domain when the DFS configured but we have migrated on Windows 2008 Domain and now we are in the transition phase of windows 7.

    Windows XP users never complaint the issue.

    I am accessing the DFS share with my domain name

    \\ (Unfortunately the Public and local domain name is same)

    Multiple DNS entries for according the subnets and sites, as the old entries of old IP scheme is also exist.

    When i tried to nslookup it shows like following


    On windows 7 when I ping the it ping the IP of however the IP of windows 7 is belonging to the different subnet and has configured.

    Sometime it pings and sometime it pings 

    After ipconfig/flushdns it pick different IP but not the required one.

    After restarting the problem machine it works fine for sometime. 

    Kindly advise how can I trace and resolve the issue.

    Monday, November 19, 2012 7:44 PM

All replies

  • You need check your dns server.

    Your DNS probably has two "a" records associated with two different ips.

    Delete the "a" record with the wrong IP.

    Also make sure that Windows XP computers and Windows 7 are getting the correct DNS name assignment through DHCP. (run ipconfig /all and compare the DNS ip)

    Maybe your W7 is pointed to the external DNS server while the XP to internal.

    Monday, November 19, 2012 10:31 PM
  • Thanks for the response, 

    Both Windows XP and Windows 7 has same DNS server. 

    Let me further explain the scenario here

    Windows 7 has the IP

    Windows XP has the IP

    However the domain name shows the IP mention earlier

    Addresses:,,,,,,,,,,, has multiple IP as we have different DC's in our environment to provide authentication to users according to their subnet. 

    Windows XP always access the IP of same subnet like,,, but on windows 7 it mostly access the IP which are not from the same subnet, while i tried to ping the from windows 7, it sometime tries to ping sometimes it tries to ping and some times

    DNS server has the Round Robin enabled, but as per my understanding the system should pick the IPs from same subnet instead to access the IPs which or on different network.

    Tuesday, November 20, 2012 2:47 PM