none
Webdav

    General discussion

  • I'm using Windows 7 x64.

    And I can't connect to a webdav location. Windows gives me a notification that it can't access...

    Any ideas how to do this?
    Wednesday, January 14, 2009 5:51 PM

All replies

  •  

    I've been able to connect to WebDAV (explorer view in SharePoint server) but it's working very, very slowly for me. In Vista, when I click to open a WebDAV folder it opens immediately. In Windows 7, there's a delay of 30-60 seconds.

    So, there's obviously something going on with Windows 7 and WebDAV. Anybody at Microsoft have any ideas?
    Wednesday, January 14, 2009 7:03 PM
  • I am experiencing the same issues with SharePoint.  Any file access (Opening documents in Office, Open in Windows Explorer, etc.)  are very, very slow.

    Any ideas from anyone?

    Thanks.
    -Steven Perry
    Tuesday, February 03, 2009 6:05 PM
  • I've now confirmed that the issue is not resolved by reinstalling Win 7 on the same machine, nor on the other Win 7 machine I've built. In short, this problem seems to be a part of Win 7, and it makes it impossible for me to use at work. I'm assuming the issue is known (I've reported it, and I'm assuming others have as well) and will be resolved.

    If anyone's using a more recent build and can comment on whether or not the issue is resolved, an update would be much appreciated.
    Sunday, February 15, 2009 1:37 AM
  • Just wanted to confirm that we are also seeing very very slow access to SharePoint WebDAV folder views under Windows 7 Beta Build 7000.
    Thursday, February 19, 2009 3:24 PM
  • We have WebDAV shares through APACHE on a non-Windows machine.  The WebDAV shares work perfectly from VISTA and XP.  They do not work at all under Windows 7.

    No error messages are ever returned.

    We have tried to create the shares through the wizard via the Windows Computer application.

    The shares can be browsed using IE8.
    Wednesday, May 20, 2009 3:50 PM
  • I was experiencing the same slowness with our build 7000 and our SharePoint server.  But, with the RC (7100), I've see SIGNIFICANT improvement in Webdav performance on our MOSS2007 system...

    Wednesday, May 20, 2009 4:43 PM
  • I was experiencing the improved performance under the RC as well, until the last week or so. It's now reverted back to its poor performance, and I'm not aware of anything that's changed on the machine or the network.
    Thursday, May 28, 2009 12:04 AM
  • We are still unable to use WebDAV shares.  When we attempt to create them using the wizard, we end up with multiple shares, none of which work.

    As stated previously, the WebDAV connections work well from XP and VISTA.
    Friday, May 29, 2009 7:37 PM
  • The RC version was working fine until late last week. Now everything is back to taking 10-15 seconds to open. I can't think of anything that has changed on the PC or the server.
    Tuesday, June 09, 2009 1:41 PM
  • The correct way to set up and use WebDAV in Windows 7 takes some steps. After you have figured it out, it works fast and even better than in Windows XP (at least for me it does).

    Follow these steps:

    1. Start -> Run -> Services.msc
    2. Start your Webclient service. Set the properties so it will start automatically next time you boot Windows 7

    For shortcuts to your folders or files:

    1. Rightclick anywhere on your desktop and choose 'new shortcut'
    2. Use this format for WebDAV folders: \\your_webdav_server_domain@SLL\rootwebdavfolder\path\to\folder. For example, mine looks like this: \\livelink.mydomain.nl@SLL\livelinkdav\nodes\1758347

    Your shortcurt will be created and you wuill have direct access to your webdav folder using Windows 7. If you don't know the correct path, browse to your webdav folder using Windows XP and look at the address and use this in your above shortcut.

    Now for the fun part

    You can actually map networkdrives to webdav locations. To do so use this:

    1. Open Windows Explorer
    2. Rightclick on 'Computer'
    3. Go to 'map network drive'
    4. Choose station/drive letter
    5. Use this link to your WebDAV location: \\your_webdav_server_domain@SLL\rootwebdavfolder\path\to\folder
    6. Press OK and your set.

    The nice part of mapping your networkdrive is that you can use it for synchronisation (online/offline files).

    I have skipped Windows Vista so I don't know if this would have worked under Vista. Also I use the Dutch version of Windows 7 so the terms I used above may be slightly different in English.


    If this solves your problems I would appreciate a vote :)

    Tuesday, June 16, 2009 1:15 PM
  • Everyone,

    I experienced the same issue with Win7 RC (7100) x64.  WebDAV worked fine initially after the install, then a few weeks later it began a gradual slowdown when accessing SharePoint.  Restarting WebClient service or the whole computer had no effect.

    I was able to fix it by restoring IE8 to factory defaults.  Close IE8, go to Control Panel, Internet Options.  On the Advanced tab, click Reset button; I didn't need to tick the check-box to delete personal settings.  Afterwards, WebDAV shares were opening rapidly again when using Explorer View from SharePoint or a mapped drive letter. 

    It seems like a caching problem, though just deleting the browsing history didn't fix it.  If the issue reappears, reset IE8 again.

    --Mancer, MCITP-EA
    Tuesday, June 16, 2009 6:14 PM
  • Hi,
    I am able to connect to a webdav ressource, but not the supposed way.
    The weird problem is, that using the webdav ressource deletes file contents when saving (so experienced with OpenOffice 3.1 Text). This behaviour is reproducable.
    Without secure webdav support win7 would be useless for production purpose for me. I regret because the overall experience actually is much more fun than was vista for me. I read many people havinbg issues with webdav in win 7, but in vista too.
    Wednesday, June 17, 2009 4:02 PM
  • W7 7100

    "
    1. Rightclick anywhere on your desktop and choose 'new shortcut'
    2. Use this format for WebDAV folders: \\your_webdav_server_domain@SLL\rootwebdavfolder\path\to\folder. For example, mine looks like this:\\livelink.mydomain.nl@SLL\livelinkdav\nodes\1758347
    "

    This creates an Internet-shortcut and the webdav is opened with the default internet browser. From a web browser i have no write-access

    "
    1. Open Windows Explorer
    2. Rightclick on 'Computer'
    3. Go to 'map network drive'
    4. Choose station/drive letter
    5. Use this link to your WebDAV location: \\your_webdav_server_domain@SLL\rootwebdavfolder\path\to\folder
    6. Press OK and your set.
    "

    This did not work for me.
    I want to acces an https:// webdav of my university. The only solution i have found so far is this java-applet http://www.anyclient.com/

    It would be nice to do it from the windows explorer like in winXP
    Thursday, June 18, 2009 9:37 AM
  • I'm using Windows 7 RC 1 and SharePoint Online, and also have an extremely slow experience with WebDav. It seems to work perfectly with the integrated Virtual XP though. 

    The only "workaround" I found that allows me to browse and upload files quickly is by using the integrated file browser of SharePoint Designer 2007.  It is alot faster as it uses the FPRPC protocol instead of WebDav.

    The trick is to drag and drop files from your desktop inside the tiny file browser of SP Designer. Unfortunately it doesn't work the other way around (downloading files to the desktop), unless you edit your files directly inside SP Designer.
    Thursday, June 18, 2009 7:23 PM
  • The fix described by Daniel CD in this post directly solved my slow transfer problem on Windows 7 RC1.

    Cheers, 

    David D.

    Thursday, June 25, 2009 8:39 PM
  • This worked for me, so THANKS!!!  I also wish I could access my university webdav, but nothing has worked for me except this AnyClient applet. Not as good as using Windows Explorer, true.  But easier (at least for me) than installing and trying to configure a ShrewSoft client! Then I would still have to install a Novell client.
    Monday, February 15, 2010 7:33 PM
  • WebDAV under all versions prior to Windows 7 worked by default. Windows 7 needs some finessing, but it will work too.

    Steps I took to make my machine map a network drive to a SharePoint URL:

    * Set WebClient to Automatic
    * Could not start service - "access is denied" error.
    * Checked event log and saw in Security log that the Local Service account was trying to create/inspect files inside C:\Windows\ServiceProfiles\LocalService\AppData\Local (lastalive#.dat)
    * Added ACE to C:\Windows\ServiceProfiles\LocalService - Local Service:Modify
    * WebClient service started
    * URL drive mapping worked, but slowly
    * Within Internet Explorer, unchecked "Automatically detect settings"
    * Performance improved

    If not fixed by Microsoft, we will need to include these settings in our base build when we start rolling out Windows 7.
    Wednesday, February 17, 2010 5:46 PM
  • I tried this and it almost worked, except that I got an error message saying "A device attached to the system is not functioning."  Any ideas on what that means?
    Saturday, February 20, 2010 9:44 PM
  • Not sure if you were replying to me or not.

    But if you were trying the procedure I outlined, I'm not sure why that error message would present itself.  My first thought is that the ACL was not applied correctly to the folder (and/or replicated to subfolders), and this induced a different error.

    Thursday, February 25, 2010 4:15 PM
  • Hey, Richard, 

    Back in June you posted a comment about webDAV on Windows 7. in the format of webDAV folders you had "@SLL" at the end of your domain name in that link. Is that something needed for the webDAV config or is that something you always include as part of your domain name. 

    For instance, in WinXP my webDAV link is https://secure.cnchost.com/webdav.gihn.org/. I can't for the life of me get there from here! (That's an obscure American idiom for being lost, as in "You can't get there from here."

    So, would my Win7 syntax be \\secure.cnchost.com@sll\webdav.gihn.org or \\www.gihn.org@SLL\files\? or something else?

    Thanks,

    Clarke
    Tuesday, March 02, 2010 1:14 PM
  • EUREKA!!! I've got it working under Windows 7 64 Bit connecting to a Linux / Apache based webdav server. 

    Originally I was getting the "does not appear to be valid" error when trying to map a drive or resource.
    Long story short you need to configure webdav to use Auth type Digest. Windows 7 WILL NOT connect to a webdav user using Basic Authentication.

    There's a bit more to it than that but I've got all the steps on my blog at http://shon.org.

    It was a pain in the ____ but it does work.

    In summary:

    * make sure the server is using digest authentication
    * make sure WebClient Service is running in services
    * Add a network location in my computer using normal syntax (i didn't need to use port numbers or @anything)
    * Then you can net use or map drives, etc.

    More info and detailed steps at my blog.

    Hope this helps!

    -Shon

    Thursday, March 04, 2010 9:34 PM
  • EUREKA!!! I've got it working under Windows 7 64 Bit connecting to a Linux / Apache based webdav server. 

    Originally I was getting the "does not appear to be valid" error when trying to map a drive or resource.
    Long story short you need to configure webdav to use Auth type Digest. Windows 7 WILL NOT connect to a webdav user using Basic Authentication.

    There's a bit more to it than that but I've got all the steps on my blog at http://shon.org.

    It was a pain in the ____ but it does work.

    In summary:

    * make sure the server is using digest authentication
    * make sure WebClient Service is running in services
    * Add a network location in my computer using normal syntax (i didn't need to use port numbers or @anything)
    * Then you can net use or map drives, etc.

    More info and detailed steps at my blog .

    Hope this helps!

    -Shon


    Shon,
    I would love to see your httpd.conf file, or at least the bits that are relevant to WebDAV. I have the same setup as you, except I'm using CentOS 5.4.

    It's still not working for me.

    However, I DID get it to a point where I tried to map a drive letter and it asked for a username and password, but it wouldn't take my SVN name and password.
    Friday, March 05, 2010 6:12 AM
  • OK Duck,

    I updated my page with the Apache Conf I'm using. See http://shon.org/blog/2010/03/04/howto-fix-windows-7-64bit-webdav/

    BTW, try using a trailing "/" on your webdav url when connecting from Windows. That tripped me up for a sec on mine.

    Cheers,

    -Shon
    Monday, March 15, 2010 9:32 PM
  • Not had chance to test this yet (don't do clients for customer, just the WebDAV):


    http://www.webdavsystem.com/server/documentation/authentication/basic_auth_vista

     

    I'm pretty sure this might fix the problem we've been seeing - XP lets you do "Basic Auth" over non-SSL links, Vista/Win7 doesn't, but changing the value of HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters\BasicAuthLevel to "2" will let you do Basic Auth over non-SSL connections.

    YMMV, and all that.. ;)

    Tuesday, June 08, 2010 2:42 PM
  • 1.5 years after this bug was identified, and it still goes unaddressed. How did this get fixed in Vista and the fix dropped in Windows 7?

    Here is the MS fix for Vista: KB907306

    Could someone please tell us when you expect this bug to get fixed?

    Monday, June 28, 2010 8:59 PM
  • Although this post was very helpful, I believe RichardvI is incorrect.  You are not able to use the webDAV share for synchronization / offline files.  If you can, this has escaped me.

     

     

     

     

    Wednesday, August 18, 2010 12:01 PM
  • I have a problem accessing a WebDAV server using Windows 7 File Explorer apparently because the WebDAV server I want to access is not running in port 80 (the default) and I don't have a way to change it at the server. I have no problems accessing it using Windows XP using the Add Network Place wizard, entering http://ipaddress:port# which then prompts me for an ID and Password and viola!... I have a little folder under My Network Places that allows me to access the shared files in the WebADV server via Window File Explorer.

     I'm able to connect to the shares on this server from Windows 7 using AnyClient via its WebADV option, but I'm not allow to install any other app in the computers that need to access the WebDAV server.

    What do I need to do to make this work with Windows 7 File Explorer? Is there a patch for Windows 7 that will allow me to use other ports?

     

     

    Tuesday, September 21, 2010 3:07 PM
  • I've found that when trying to map a network drive to resources on an apache DAV share Windows has no problem with shares that have typical http://mylinuxserver/davshare URLs. In cases where a PHP handler is present, http://my.server.ip.address/LAMPApplication/webdav.php/home/MyUsername/ aren't considered valid. Internet Explorer can list directory contents and has no problem with authentication, but Explorer just won't have it. This also seems to be true in MS Office programs as well. Ubuntu, kubuntu, and Solaris connect with no problem.

     

    Any ideas?

    Friday, October 15, 2010 11:09 PM
  • Another year without resolving.

    NetDrive now works in 64bit

    But installing something instead something built-in that doesn't work. It's something - I say!

    Saturday, January 22, 2011 6:00 PM
  • I did not have any issues with WebDAV, and I didn't have to do any goofy tricks to make it work.  I have a 64-bit Windows & PC.  

    Start > Computer > Map Network Drive 

    There is a link at the bottom that says "Connect to a Web site that you can use to store your documents and pictures"

    Click it, add in the WebDAV info like always...

    ex: your.site.com/dav

    Enter your credentials and voila!

     

     

    Monday, April 18, 2011 10:49 PM
  • What worked for me is to disable automatic proxy detection in Internet Settings. - Once disabled, things work a lot faster and smoother.
    Thursday, May 12, 2011 4:34 PM
  •  

    MSFT is protecting its Sharepoint revenue. No solution anytime soon for webdav and Windows 7.

    Monday, May 23, 2011 2:26 PM
  • Hi,

     

    We are having similar issues with an installation of 'Filerun' running on Linux. We can connect to it using Applle hardware, both iPhone (with the right app) and a Macbook but neither XP or Windows 7 will connect via the built in WebDav client.

     

    Interestingly I can connect to my iPhone with WebDav.

    Thursday, August 11, 2011 4:26 PM
  • Hi,

     

    I was able to create the share on Windows 7. The share wont stick and I have to click on the share to browse files to keep the share alive.

     

    Could some share insight into how to keep the share alive?

     

    Thanks.

     

    George
    George
    Thursday, August 18, 2011 6:51 PM
  • Hi guys

     

    I've just find a soltuion for the SLOW acces to Webdav on windows 7 (might be the same on Vista)

    • Control Panel
    • Internet Options
    • Connections tab, and then LAN Settings
    • De-selectAutomatically detect settings

    and then you've got a FAST access to your webdav over the explorer

     

    Hope this will help

    Wednesday, August 31, 2011 8:21 AM
  • Hi,

    webdav works on windows 7 but with following limitations as far as i know:

    • No support for HTTPS, i.e. no support for secure connections.
    • Your WebDAV server must be using port 80, the default port.
    • Typically fails when transfering larger files.
    • Gets confused if the user does not have access to read and/or write to a file or directory.

    Too much limitations for me (i want to use HTTPS, custom port, no transfer fails or confused system), so decided to use a third party tool: netdrive (free for personal use): http://www.netdrive.net/
    This works perfect like in old xp days, however xp was able to handle it without third party tools :)

     

    Tuesday, September 27, 2011 8:45 PM
  • This worked for me, essentially:

    BasicAuthLevel 0 - no Basic Auth - get folder not valid, Digest Auth works

    BasicAuthLevel 1 - Basic Auth works in SSL, Digest Auth works , Basic Auth fails without SSL

    BasicAuthLevel 2 - Basic Auth works

    I note some odd behaviour, like if you try Basic Auth and it fails, then the whole server is cached as bad and nothing works (e.g. folders on the same server not needing authentication). There is a timeout value in the same registry folder that may affect it. Also, you cannot login twice as the same user to the same server with different credentials. Merely browsing away from the DAV folder may not be good enough - "net use" at the command prompt shows a connection, which may be removed with "net use * /delete". These behaviours together made Windows DAV seem very strange indeed, not behaving in the same way to what seemed to be identical operations.

    I believe that Windows 7 does SSL certificate checking, but does not support SNI in the DAV client. That means that virtual hosts on the same ip address with separate certificates will fail unless there is also a default certificate with a domain wildcard.

    One can also map network drives from the command line, e.g.

    net use * https://dav.example.com

    which will throw up errors documented at http://msdn.microsoft.com/en-us/library/ms681381%28VS.85%29.aspx

    Also, in Windows 7, the SSL certificate path needs to be valid. So you may need to import the server certificate root authority into IE as a trusted root authority (IE tools/internet options/content/publishers), otherwise you can get an error 1790 (network logon failed - trust failure)


    A.Daviel
    • Edited by adaviel Thursday, October 13, 2011 2:29 AM
    Thursday, October 13, 2011 1:54 AM
  • Oh man what a fu__ing pain in the ass . I finally got it working on mine . I know it's an older thread but couldn't find anything useful out  there. My setup:

     

    Win 7 x64 against Win 2008 R2 x64 IIS 7.5 .

    Webdav doesn't work for sh_it. I've tried all the registry fixes and all the settings , nothing worked for me. I could not access it with IE , it would give a 403 unauthorized.

    The way I got it to work on mine is this:

    1. Set the webclient service to automatic .

    2. Open my computer---- map drive and in the address I put \\myserver.com\webdav_share_that_doesn't_work .The 445 and 139 are filtered on the server because that's a shared folder address in my book , so I thought I had the 139 and the other not filtered .

     

    Amazingly enough it worked on mine , it asked me for my password twice , you have to put it in domain\user format and bum , I'm in . Tested on two machines so far , the x64 and a 32 bit . It's is mapped to Y .

    It reports the size of the drive incorrect and as a FAT fs , but who cares :) . I might've change the basicauth key in the registry for the webclient service so I don't know exactly if it will work exactly as said for everyone but the \\server.com\share did work for me.

    It's going to be really slow at first but uncheck the box in IE settings for automagically detect setings in the LAN setup .

     

    Thursday, October 27, 2011 12:02 AM
  • I had same problem and it was solved...

    1- Set BasicAuthLevel's value to "2"  by expand HKEY_LOCAL_MACHINE >> SYSTEM>>CurrentControlSet>>Services>>webClient>>Parameters

    2- Restart your computer.


    3- Right click "Computer" and click "Map network drive..."
        
    To Letter Field: Set a free drive letter.
        
    To Folder Field: Assume that your webDav address is http://abc.com:50000/irj/go/km/docs/ change it to \\abc.com:50000\irj\go\km\docs\

    4- Enter your ID an Password


    thats all...

    Note: The mapping is as follows:
     0 - Basic authentication disabled
     1 - Basic authentication enabled for SSL shares only
     2 or greater - Basic authentication enabled for SSL shares and for non-SSL shares

    Tuesday, January 03, 2012 11:24 AM
  • On the IE, click "Tools" and "Internet Options". Then click "Connections" tab. On "Local Area Setting" click on "LAN Settings". Check the combo box of "Automatic detect settings" is active..
    Tuesday, January 03, 2012 11:30 AM
  • I had same problem and it was solved...

    1- Set BasicAuthLevel's value to "2"  by expand HKEY_LOCAL_MACHINE >> SYSTEM>>CurrentControlSet>>Services>>webClient>>Parameters

    2- Restart your computer.


    3- Right click "Computer" and click "Map network drive..."
        
    To Letter Field: Set a free drive letter.
        
    To Folder Field: Assume that your webDav address is http://abc.com:50000/irj/go/km/docs/ change it to \\abc.com:50000\irj\go\km\docs\

    4- Enter your ID an Password


    thats all...

    Note: The mapping is as follows:
     0 - Basic authentication disabled
     1 - Basic authentication enabled for SSL shares only
     2 or greater - Basic authentication enabled for SSL shares and for non-SSL shares

    This works as a charm. Thanks for this. I needed to connect through WebDAV to a Synology NAS server. Finally a working solution without third party solutions.
    • Edited by IT Street Sunday, January 15, 2012 4:25 AM
    Sunday, January 15, 2012 4:21 AM
  • Only for others that are still searching for this, go to map net drive and use for secure \\server@SSL@port\share It shoud work on 7. If you are using a apache share (linux) it needs to accept the share without the last "/" as windows will not use it even if you write \\server@SSL@port\share\  (can be done with 301 Redirect from "share" to "share/" )

    PS: For me it worked with @SSL and not @SLL as posted

    • Edited by Bijos Tuesday, July 17, 2012 5:57 PM
    Tuesday, July 17, 2012 5:46 PM
  • Hi,

    webdav works on windows 7 but with following limitations as far as i know:

    • No support for HTTPS, i.e. no support for secure connections.
    • Your WebDAV server must be using port 80, the default port.
    • Typically fails when transfering larger files.
    • Gets confused if the user does not have access to read and/or write to a file or directory.

    Too much limitations for me (i want to use HTTPS, custom port, no transfer fails or confused system), so decided to use a third party tool: netdrive (free for personal use): http://www.netdrive.net/
    This works perfect like in old xp days, however xp was able to handle it without third party tools :)


    Sorry for the thread resurrection, but I've been trying to get my SharePoint list with 15,000 items working all morning and this referral to NetDrive works like a charm!  Beautiful tool!!
    Monday, July 23, 2012 5:40 PM
  • Hi,

    Trying to access my D-link DNS-325 using webdav and dyndns in explorer running win7 ultimate x64. After mapping network map I get prompted for certificate but none of the available works. How do I import the needed certificate? Or rather, where do I find the certificate that I need? Importing it shoukd´nt be a problem.

    By the way, the unchecking of the box "auto detect setting" in internet option really made another webdav I use, to run a lot faster

    //Jens

    Wednesday, August 15, 2012 9:34 PM
  • Do you use your own webdav server? I found lots of people report webdav problems. You might want to use a hosted webdav service like drivehq 

    http://www.drivehq.com/mapdrive

    Thursday, August 16, 2012 10:33 AM
  • I tried the things you have described. At first it looked it will work until I entered the user credentials. After that appeared the same lame message "Windows cannot access....". 
    Wednesday, November 13, 2013 12:07 PM