remote desktop sessions connecting but no desktop is displayed after 1803 update RRS feed

  • Question

  • My desktop, after upgrade to 1803 earlier this week, is no longer working correctly when accessed via RDP. All was working fine before 1803. Connections authenticate (or fail with bad password) but a desktop is never displayed. A blank, black, screen with a mouse cursor is displayed and/or the connection disconnects after ten seconds or so. The "establishing secure connection" phase seems to take a lot longer than I'm used to.

    I have tried using the WUP and "classic" Remote Desktop desktop clients from my laptop, another Windows 1803 machine, as well as ChromeRDP from a Chromebook, and Microsoft Remote Desktop from a Mac. I have tried with the desktop on Ethernet or WiFi. (On Ethernet the connection drops out after ten seconds or so. With the desktop on WiFi, it just sat there, black screen, mouse cursor, nothing else, for minutes.) I've verified the firewall is set to pass Remote Desktop and have tried it with the desktop firewall disabled. I have confirmed that the desktop's Remote* services are manual or automatic and none are disabled. The desktop can RDP into the laptop just fine.

    Any other thoughts how to isolate/troubleshoot/resolve this?
    Thursday, May 3, 2018 4:58 PM

All replies

  • Hi,

    Please update your graphic card driver in Device Manager.

    Please check if you could maximize the remote desktop session screen when it occur blank, black, screen with a mouse cursor.

    If yes, please press Ctrl+Shift+Esc to see if it could open task manager.

    If yes, please try to run a new task as following screenshot to see if it can work.

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact

    Friday, May 4, 2018 9:47 AM
  • It had latest graphics driver per Device Manager, Windows Update, and Intel support page for the platform. There was a newer driver on Intel Graphics.

    It didn't make a difference. The window starts maximized. Ctrl+Shift+Esc does nothing. Several seconds later the connection closes.

    If I RDP into the machine immediately after booting it, it works fine. Can't say what happens from then until "later" when the failure in this thread happens. But I'm also getting intermittent 0x0000009f bug checks for "power state failure" or something like that. And shadow volume copy also works fresh after a boot and fails "later".

    Sunday, May 6, 2018 1:30 AM
  • Hi,

    Please try to use clean boot to boot PC into a clean environment to see it the issue still occur.

    Here is a link for your reference.

    How to perform a clean boot in Windows:

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact

    Thursday, May 10, 2018 3:26 AM
  • I still need some more test cases to be sure, but it *appears* that the 05/18 cumulative update to 1803 resolved this issue.
    Thursday, May 10, 2018 5:57 AM
  • I have the issue

    I have to entire reboot the PC to "wake up" the RDP otherwise : black screen and cursur

    Video Drivers are fully updated

    Thursday, May 17, 2018 6:14 PM
  •  black screen and cursur

    Have you tried using Narrator to find out if it "sees" anything then?  Another good reason to try to get Narrator running is that it would be a second task to have running which you could see with Alt-Tab.  Narrator describes that too, in case things are not being rendered or appearing on another display.  FWIW I may have seen something similar with a VM on the first boot after updating to 17134.48.  Then I thought that there was some weird scaling happening; e.g. although I first saw the black screen I was able to scroll it around (one of the advantages of it being in a VM Connect window) and see that there were some more expected elements elsewhere.

    Robert Aldwinckle

    Friday, May 18, 2018 4:21 AM