none
Windows 10 cannot see APC USB battery backup RRS feed

  • Question

  • I installed a USB connected UPC battery backup on a clean install of Windows 10 about two weeks ago. The computer saw that UPS just fine, but the on-battery time was only a few minutes, so I swapped it out with a different APC unit. The computer did not see that one. I tried plugging it into different USB ports and even swapping the USB cable. Still could not see the device. I put the original UPS back on the system and it could no longer see that one either. I also tried a different UPS monitoring program: apcupsd versus PowerChute. Nada.

    When plugging and unplugging the UPS into the computer, it get the "dinging" sound indicating the computer does recognize that something was plugged in or removed.

    In Device Manager > Human Interface Devices, I should see "American Power Conversion USB UPS" as a listed device, but I do not.

    When I boot this computer as Linux it does see the device as, "Back-UPS ES 650G1 FW:906.W1 .D USB FW:W1" (and more info).

    I am concluding that something is wrong with Windows 10's ability to see this device. It could see it several days ago, does not seem related to computer or UPS hardware, and the device is visible on this same computer via USB when booted with a different OS.

    Any ideas on how I can get this Windows 10 to see this device?

    Sunday, November 3, 2019 7:57 PM

All replies

  • Hi, 

    Please check if the USB battery could be seen on other Windows 10 computers. 

    Also, please update the existing system through Settings\Update&Security\Windows Update to make sure you use the latest system version. 

    Try to uninstall the existing APC device driver and download a new one from manufacturer website to check. 

    Bests, 


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, November 4, 2019 6:04 AM
    Moderator
  • Joy-Qiao - thanks for your reply. I did all of those things. Yes, this UPS can be seen on other Windows and Linux computers. I have uninstalled and re-downloaded the APC software several times. I've also tried a different program, apcupsd. It does not see the unit either. I do not see "American Power Conversion USB UPS" in device manager whereas I did before. I've changed USB ports and cables, and I've tried a completely different APC backup device on this computer (which can also be seen on other Windows 7, 10 and Linux computers). Nothing. In fact, I have this different unit connected to this computer now.

    When I first installed Window 10 on this computer it could do all of the above and see "American Power Conversion USB UPS" in device manger. Both APC's PowerChute and apcupsd programs could see the device.

    If I boot this computer to Linux, it does see the unit. Given all that, it does not appear to be an issue with the computer hardware, the battery backup unit, the USB port or the USB cable. It appears to specifically be related to WIndows 10 which, as I said, could see this device once upon a time, but cannot any longer.

    Tuesday, November 12, 2019 3:36 PM
  • Still looking for some advice on this problem. Ideas to try?
    Saturday, November 23, 2019 2:45 AM
  • Hi, 

    Please go to Properties page by right click the USB device driver in Device Manager console. Then click on the Power Management tab and uncheck the Allow the computer to turn off this device to save power box.

    I would recommend to reset PC through Settings\Update&Security\Recovery\reset this PC. We could choose to keep personal data during reset process. 

    If you have created a system restore point, roll back to previous system point would be a convenient way. 

    Bests, 


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, November 27, 2019 8:23 AM
    Moderator