Netflix and Silverlight - Installed but not recognized as installed


  • When attempting to access online Netflix movies on my Win 7 laptop I'm being asked to install Silverlight which is already installed.  It results in a message that the installation failed and message id 1514 which then never allows me to access the movies through IE8.  I can access movies just fine through Firefox.   I know that this is an easy fix because it got resolved one time but then was undone when I had to do a system restore from prior to the fix provided.

    Monday, November 16, 2009 5:17 PM


All replies

  • Have you tried uninstalling then reinstalling Silverlight?

    Also similar problems here and Webshots turned out to be the problem:
    Monday, November 16, 2009 7:39 PM
  • Hi,


    This issue may occur if previous installed Silverlight is broken.


    I suggest removing and reinstalling Silverlight as below:


    1. Refer to the following article to clear the Silverlight completely:



    2. Clear Temp folder


    Clear files in the temp folder


    1. Click the Start Button, type C:\Windows\Temp and press Enter.

    2. Press Ctrl and A at the same time.

    3. Press Shift and Delete at the same time.

    4. Click Yes to confirm.


    3. Enter Clean Boot mode.


    4. Install Silverlight 3 from the link below:


    Vivian Xing - MSFT
    • Marked as answer by Vivian Xing Monday, November 23, 2009 2:44 AM
    Tuesday, November 17, 2009 10:05 AM
  •  I'm running vista 32 bit with IE8, did all of the above and SL installs successfully but is still not recognized. I just keeps prompting me to install and then fails saying it's already installed.

    Saturday, November 28, 2009 7:12 AM
  • Hi,


    It seems that some setting about Netflix is not correctly.


    Please try the following steps next:


    Configure the security settings


    1. Click the Start Button, type "inetcpl.cpl" (without quotation marks) in the Start Search box, and then press Enter.

    2. On the Security tab, click Restricted Sites icon, click Custom level button.

    3. Make sure the High is selected in the "Reset to" drop down list, click OK.

    4. Uncheck the Enable Protected Mode check box.

    5. Click Sites button, please check if is listed, if so, please click and Remove it.

    6. Click Trusted Sites icon, click Sites button, type * in the black box and click Add


    Please also add


    7. Click the Advanced tab.

    8. In the Settings box, scroll down and check "Enable third party extension" and "SSL 2.0".

    9. Click Apply and click OK.


    Restart IE by right click on IE icon and choose Run as administrator and check if Netflix works.


    If the issue persists, please follow steps on the following link to configure Application Storage:


    Using Application Storage:


    Hope it helps.

    Vivian Xing - MSFT
    Monday, November 30, 2009 3:21 AM
  • Hi Vivian Xing and chuck az: I too have the same problem as chuck with silverlight. I install silverlight when Netflix streaming asks me. I was showing no results so I followed the microsoft advice to unistall through the control panel and programs and then to reinstall. I unistalled, hit reinstall key and it installed.  Nothing plays and it shows the 1502 error code if i hit reinstall again. I had Netflix well over a year or two ago and did fine. Now I just reupped w/ them and can't even use product because of silverlight. I hate that.  I saw where microsoft suggested clearing the registry or delete registry key by regetit. It says be careful or u can really mess up your computer.  I don't know which scenario to try after uninstalling through programs, then reinstalling w/ Netflix prompt button and then it doesn't work. If i hit install again it says a newer version is already installed. I have a Windows xp 3-pk. I am on a Hewlett P. Compac Computer.  Can the 2 of u or anyone else help? Please help me use my Netflix as my $$$$$ are wasting aWAY AS I CAN NOT PLAY ANYTHING! I agree with several others who share there complete frustration w/ Netflix who does nothing but refer u to microsoft and they want big bucks? fed up w/ both. Maybe we should all drop Netflix 1st, huh? u know there are other alternatives now.  I used to be satisfied w/ them but have not liked there replies and total lack of interest after they get your bank card #. Greatful for u guys in the forum, I just found this and u are more knowledgeable and helpful so far than anything I have tried. Thanks Guys!

    Monday, January 30, 2012 10:13 PM
  • If you are using IE Browser, try this. It worked for me.

    1. Run regedit (start->run->regedit)
    2. Navigate to HKEY_CLASSES_ROOT\AgControl.AgControl (if you get a message that says "AgControl.AgControl cannot be opened. An error is preventing this key from being opened. Details: Access is denied." proceed to the "Taking ownership

    of the key" section)
    3. Right click and choose "Permissions"
    4. Click "Add"
    5. Either add your windows username or your network username in the the "Enter the object names to select" and click "Check Names". Your name should take the proper format. If it does not try clicking "Advanced" and searching for your

    username. My windows username was the one I used.
    6. Click OK
    7. Select your new username in the top pane and in the lower pane (Permissions for <username>) check the Allow box next to Read.
    8. Click OK

    Check Silverlight installation in IE by going to

    Taking ownership of the key (If you're getting access denied errors while trying to set permissions)

    You can download the following tool from microsoft to open an
    instance of regedit as system:

    The following command line will open a "system" regedit:

    psexec -s -i regedit

    (Note: You have to execute this command line from an "administrator" command
    prompt [right-click command prompt and click run as administrator])

    Return to step 3 above

    • Edited by jmoore965 Tuesday, March 20, 2012 1:51 PM
    • Proposed as answer by BeckeyB Monday, May 07, 2012 11:03 PM
    • Unproposed as answer by BeckeyB Monday, May 07, 2012 11:03 PM
    Tuesday, March 20, 2012 1:48 PM
  • I had this problem.

    Go to IE Settings

    Click on "Manage Add-ons"

    Look for Microsoft Silverlight - make certain it is "enabled"

    (mine was disabled and therefore would not allow netflix to play)

    Close and reopen browser.  Netflix should now work.

    • Proposed as answer by Bigness66 Wednesday, May 14, 2014 3:00 AM
    Monday, May 07, 2012 11:06 PM
  • TY Beckey I had been having this issue since the begining of time and now it's fixed you get a big Kiss from me XoXo
    Thursday, July 05, 2012 8:46 PM
  • This worked for me, Thanks to BeckyB
    Tuesday, June 25, 2013 2:24 AM
  • TY - please tell the people at netflix and microsoft!!!
    Saturday, July 27, 2013 8:45 PM
  • perfect! solved the problem after many uninstalls/reinstalls.... thank you!!!!!!

    Friday, January 17, 2014 3:57 AM
  • YES!!  Worked for me with same problem in Firefox.  Clicked Tools>  Add-ons> Plugins> select "always activate" next to Silverlight ("Never activate" was selected.)

    Thank you BeckyB!

    Wednesday, May 14, 2014 3:03 AM
  • BeckyB - Hello

    How simple, It's like not checking the power cord to your computer before breaking your system down to the PS!!!!

    This for me anyway was the correct solution!



    Friday, August 01, 2014 2:53 AM