Centronics Printer Connected Via USB Adapter Cable Doesn't Print - Remedy?


  • I've connected my old OKI OL810ex printer to my new computer using a USB <> Centronix adapter cable. While both, the adapter cable and my OKI printer have been recognized and flawlessly installed by Windows 7 (64 bit), I can't print:

    Most of the time just nothing happens. The print job stays in the queue window virtually forever (see below) with status "printing" but nothing is sent to my printer. I can monitor this at my printer: The cooling fan doesn't start-up and the "receiving data" LED doesn't blink. Both would happen with the first byte received.

    Yet sometimes, a couple of bytes seem to be sent to my printer. The printer fan starts and the display shows "DATA"... However, the print job again stays in the queue window virtually forever with status "printing" again and nothing more happens.

    Well, these print jobs don't actually keep their "printing" status forever. Eventually (probably after five minutes) the print job state changes from "printing" to "error".

    When I try to delete such "hanging" print job, the status message changes to "deleting" but even this operation takes two or three minutes to complete.

    I don't believe this is a hardware problem. The printer works flawlessly with my old machine (using the standard Centronix cable) and the USB cable appears to be flawless as well.

    Can someone please enlighten me on what to do here?
    Tuesday, October 27, 2009 11:13 PM

All replies

  • Hi,


    Regarding the OKI OL810ex printer, I have checked on OKI site and found there is no Windows 7 driver for this printer.


    In our Compatibility Center, I could not found it either.

    Windows 7 Compatibility Center


    I suspect this printer may not compatible with Windows 7, since it also has not Windows 7 driver, it may not work properly.


    As a workaround, please install the latest version of the driver for it and install it with Compatibility Mode to see how it works.


    If the issue persists, it is recommended that you contact OKI for help.

    Note: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.



    Nicholas Li - MSFT
    Thursday, October 29, 2009 6:36 AM
  • In fact, there is a driver available for Windows 7. I don't know how to find it at installation, but after installation...

    • open "Devices and Printers"
    • right-click the printer and select "printer settings"
    • select Advanced tab
    • click [new driver ...] button
    • select "Oki" as manufacturer
    • select "Oki OL-810ex"

    (sorry for probably misleading translation I did from German to English).

    So Windows 7 actually comes with an Oki OK-810ex driver.

    However, still I've got that problem. Most of the problem is that the printer doesn't receive any data at all. So I don't believe it's a driver problem.

    This is the second Centronics adapter cable I've bought, so I don't think it's a hardware problem, too.

    When disabling the Spooler and trying to print the Windows test page, Windows hangs. No data is sent to the printer.

    I suspect an error in the Microsoft USB Printer Support USB driver.

    Any other suggestion is highly appreciated!

    (PS: I didn't get an e-mail about your reply although I've activated "alert me". For other threads it works. Strange...)
    Friday, October 30, 2009 6:31 PM
  • I have the same issue with a HP Laserjet 6P and also believe it is Microsoft as it was working with Vista64, now not with Win7 and it had my printer drivers.. I cannot get it to work..
    Monday, December 14, 2009 10:19 PM
  • Actually, my OKI OL-810ex does work now.

    The drivers actually don't seem to be the problem with the current Windows 7 version (not RC, not RTM).

    After buying and trying three different USB-Centronics adapter cables (using Windows 7 RC, RTM throughout my test phase) I've now bought one that really does the job. From what I have learned, the important part seems to be that the adapter cable must provide bidirectional parallel communication.

    From its software the OKI OL-810ex is a HP4 derivative. At Amazon many people complain about their HP4 not working with Centronics-USB adapter cables, because this printer appears to require bidirectional communication. So after all I was striving for a cable providing that feature... and voilà, it finally works now...

    Perhaps this information may help you find an appropriate solution to your problem?
    Tuesday, December 15, 2009 1:38 AM
  • Is there a US based place to purchase this cable, the link you provided was in German..  the Cables to Go instructions specifically state to disable bi-directional support.

     So if required makes sense..I am on my second cable..0 for 2.. I cannot believe more folks are not having this issue..

    Tuesday, December 15, 2009 2:29 PM
  • Have you tried searching at US providers using the search term "usb centronics cable bidirectional"? Here I found a result to my query ...even though I don't know whether I spelled bidirectional correctly ;)
    Tuesday, December 15, 2009 3:38 PM
  • Working with Cables to Go, manufacturer of one of the "Bidirectional" cables per the last google search performed and the second one I purchased they state the following:

    Unfortunately, not all Parallel printers will allow for the conversion to USB. This adapter is compatible with most Parallel printers. The basic rules of thumb for compatibility is that the printer must not have any special features or functions, and must use a driver that is built in to the operating system. I have attached a document for adjustments that can be made to the printer properties that give it a better chance of working with the adapter. As long as these adjustments have been made and the adapter is being recognized properly in Device Manager, then the printer should work. The printer should appear as USB Printing support under Universal Serial Bus controllers in Device Manager. If the adjustments have been made and the adapter is being recognized properly, but the printer will not print, then the printer is incompatible with the adapter.

    Of course I followed their setup procedures to the tee, still struck out.. Now I can continue to buy cables but feel they'll all have the same issue.. I am thinking about moving the printer to another PC that has a serial port and printing as a remote! The first usb/parallel cable Cables Unlimited installed worked on Vista, just had to disable Digital Signature on boot up, now with Windows 7 ...Who's Idea was that!  There must be a solution out there...

    Tuesday, December 15, 2009 4:34 PM
  • I had exactly the same problem, printer installed, but recieving no data, I had done a lot of searching and I found solution, what is working for me. Maybe it can help someone else.

       Instructions for Installing the USB to Parallel Adapter 

    Windows ME, 2000, XP, Vista

    1) Plug the cable into the USB port on your computer.

    2) A prompt that says "Found New Hardware" will appear. Windows will then install the USB printing support driver. You do not need to install the driver from the CD.

    3) Plug the cable into the printer.

    4) If your printer is already installed, click on Start, then Printers & Faxes. Right click on the printer you are connecting to and click on Properties. Click on the Ports tab and check the ‘Virtual printer port for USB’ port. Click OK.

    5) You should now be able to print

    (information from )

    Selecting Virtual printer port for USB as a printer port for your printer is the magic, I had LPT1 selected (drivers configuration showed me that my Centronics converter act as LPT1), but it was wrong, it has nothing to do with my LPT1 port (maybe this is only for port replicator...) so this is why printer can not receive any data. Now my EPSON LQ-570 prints like a charm.

    Thursday, April 01, 2010 5:42 PM
  • Had an identical problem with a Cheapo cable.

    Bought a Cables Unlimited USb IEEE 1284 Printer cable from Tiger Direct .

    It had win 7 64 bit option for drivers. Installed them.

    Installed printer & left on LPT1.


    Works like a charm. 

    Wednesday, January 12, 2011 3:30 AM
  • Did all this on my Brother 5150D & it still didn't work.
    Then I noticed that when I connected the UBS-to-Centronics cable the autoconfigure had installed an additional copy of the printer driver.
    Switched the port back to 'Virtual Printer Port for USB', selected 'Brother HL-5150D Series (Copy 1)' and it worked.

    • Edited by Neferu-re Sunday, April 15, 2012 9:05 AM Incomplete
    Sunday, April 15, 2012 8:50 AM
  • Did all this on my Brother 5150D & it still didn't work.
    Then I noticed that when I connected the UBS-to-Centronics cable the autoconfigure had installed an additional copy of the printer driver.
    Switched the port back to 'Virtual Printer Port for USB', selected 'Brother HL-5150D Series (Copy 1)' and it worked.

    I try to avoid zombie threads, but...

    Why are you using an adapter with an HL-5150D? I have that printer, and have always used the USB connection that is built in to it. (The printer has a parallel port as well, but I have never used it.)

    Sunday, April 15, 2012 8:47 PM