"The selected task "0" no longer exists" & Catastrophic Failure RRS feed

  • Question

  • Install win7 x64 (ultimate) runs fine. After about a week, this error appears in when starting task scheduler.
    I know something is wrong because of scheduled task will not run, so I check task scheduler and get this error.
    So, I check the registry entries for scheduled tasks and make them match the %systemroot%\system32\tasks folder.

    The error goes away.... BUT  and this is what no one else checks, go ahead and click "display all running tasks".
    Good luck!  "Task Scheduler cannot access Task Scheduler"...  ie. media center will no longer wake up and record shows..defrag will not run.. nothing scheduled.  In some test installs, the machine will no longer go to sleep!!.
    (and yes.. I tried uninstall MCE and Reinstalling it along with any other apps)

    Task scheduler is still broken and will not function.  You can add a new task, but the normal required system tasks no longer exist. So Win7 is broke!!   Just becaues the Task {0} error is gone doesn't prove anything!

    After dealing with this for about 2 months straight I'm about to send Balmer screen shots of the damn error messages and ask why there are no answers for this or why is task scheduler locked out to to the local admin. Why are there not verbose debugging tools available so I can try and find out exactly what it happening?

    You see, I'm 99% sure something in windows is doing this and corrupting itself. It's not a external program.
    How do I know?? because in many of my tests, I reinstall win7 x64, apply M$ updates, setup media center so I can record
    shows... and NOTHING ELSE.  Guess what happens 3-4 days???

    i'd reinstall, restore from images..etc..etc...and like clock work.. 3- 4 days later.... BAM!. Same error.
    Going to the Technet help site is useless. Go ahead and click the link to "help" from the event error messages....
    Good luck with that!  In fact i've reinstalled so many times now, my activation code will not work unless I phone in
    and say.. "Please..Please...can I run the software I purchased??"

    So now after, about approx. 60 reinstalls (no I'm not exageratting) , I'm going to try the 32bit version and see if it reproduces.
    If so.. I'm going back to vista.  Yeah. It's got problems but at least the damn thing ran!

    If anyone has any suggestions I would love to hear them and give them a go.
    But like I said. It's like the registry security at certain tree branches are being changed or corrupted in some way.
    And since a lot of system functions run off the task scheduler.. things break.

    Please anyone.......


    Sunday, February 21, 2010 9:59 PM

All replies

  • Hello,

    Check the suggestions posted in this thread:

    Error messege: the selected task "{0}" no longer exists. to see the current task, click refresh:

    Monday, February 22, 2010 8:43 AM

  • Been through all that as well. (it doesn't work as outlined in my original post..)

    thank you for your suggestion....

    Been running the 32bit version since Sunday..... so far.... ok.
    I'm still holding my breath....


    Wednesday, February 24, 2010 12:12 AM
  • ok, so, Defrag folder was the culprit. rename from C:\Windows\System32\Tasks\Microsoft\Windows\ to --Defrag--. Now problem's gone. try to import same task in new folder - fails again.

    i created a folder defragS, imported same from --defrag-- just add .xml - works, no err.

    -can't reboot right now so it'll wait

    -can't say if it'll reoccur for now - wait

    win7 x64


    schedule altered to do once in 6 months

    added to defrag command  -h -v


    good luck!

    • Proposed as answer by Caldwelldb Thursday, December 27, 2012 4:55 AM
    • Unproposed as answer by Caldwelldb Thursday, December 27, 2012 5:02 AM
    Thursday, August 12, 2010 4:00 AM
  • I did what you suggested with one exception. Instead of renaming the folder I went into the folder and deleted the One thing inside it that was not syncing with the task scheduler.....worked like a charm.

    Steps I took:

    Inside the task scheduler I:

    1. Open the Task Scheduler Library.

    2. Open Microsoft

    3. Open Windows

    4. Click on every folder until you get the code. (in my case it was the Defrag folder)

    5. Open up "My Computer" and in address bar type (or copy and paste) C:\Windows\System32\Tasks\Microsoft\Windows\

    6. Click on the folder that gave the error in the Task Scheduler

    7. Delete what is INSIDE the folder....NOT the folder its self.

    8. Go back to Task Scheduler and enjoy no error!

    • Proposed as answer by Caldwelldb Thursday, December 27, 2012 5:02 AM
    Saturday, November 6, 2010 8:34 PM
  • I take it the 32-bit version fixed your problem?


    I've experienced the same problem with the 64-bit version of Windows (including SP1) on at least two different machines. After following all of the other suggestions (cleaning out "out of sync" task entries, and there's a lot of them), the task scheduler no longer runs scheduled tasks.

    Sunday, September 18, 2011 1:58 PM
  • Hi Brett,
    I get same behavior : when opening task scheduler, either it freeze, either it displays the (im)famus message "
    The selected task "0" no longer exists".

    I think that deleting the tasks is NOT a good idea.The ignoramuses which try do that, are going to degrade their system. No more degfrag, and so on...

    I think it is "just" a problem of relationship between the console MMC and the scheduler service...
    Nevertheless, you shoud use console SCHTASKS.EXE and verify (like me) that jobs are well scheduled...

    All I can say, is in spite of the "error message", the jobs seems to be scheduled correctly. I create a new job and it was launched. I could verify all task as described below :

    Sorry for my english (I'm french, with 32bits version of seven of a friend)
    Monday, October 24, 2011 9:13 AM
  • Hey thanks... Weird how the defrag folder is the suspect for mine as well.
    Thursday, December 27, 2012 5:02 AM
  • I believe I figured this out and it is stupidly simple. Yet it is a Microsoft Flaw. To to Start > All Programs> Accessories> System Tools and then start your Disk Defragmenter. Once the window comes up see if you have ENABLED the scheduled maintenence. Turn off the Scheduled Maintenence. Close. Then try to start Task Scheduler again. I did this and my problems with the "(0)" error are gone. Now I just have to fixed everything else :)
    Thursday, May 2, 2013 4:25 AM
  • Thanks.. Its really helpful...:)
    Tuesday, March 21, 2017 4:13 PM