none
Can't see other Windows 10 computers in my home workgroup Version_10.0.16299 Build 16299 RRS feed

  • Question

  • Several days ago, I could see the other two computers in my workgroup (not homegroup) from my desktop computer. My network only shows shared resources (printers, scanners, etc). I can't see the other computers.  I can map a network drive easily, but can't see the icons when I click "Network" either from my desktop shortcut or from File Explorer.

    However, I see all three computers from my laptop (same build).  Network settings on both computers are identical.

    I note that others have experienced the same problem and have tried a number of their recommendations (most recent ones) to no avail.  Is there a patch in the works.

    Friday, March 2, 2018 4:08 PM

All replies

  • ipconfig /all

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : page-pc
       Primary Dns Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No
       DNS Suffix Search List. . . . . . : lan

    Ethernet adapter Local Area Connection:

       Connection-specific DNS Suffix  . : lan
       Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
       Physical Address. . . . . . . . . : 34-17-EB-BA-50-AF
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::dcdd:d172:3eea:7441%8(Preferred)
       IPv4 Address. . . . . . . . . . . : 172.16.7.2(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.0.0
       Lease Obtained. . . . . . . . . . : Saturday, March 3, 2018 7:27:07 AM
       Lease Expires . . . . . . . . . . : Saturday, March 3, 2018 8:27:07 AM
       Default Gateway . . . . . . . . . : 172.16.0.1
       DHCP Server . . . . . . . . . . . : 172.16.0.1
       DHCPv6 IAID . . . . . . . . . . . : 238295019
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1B-69-6A-53-34-17-EB-BA-50-AF
       DNS Servers . . . . . . . . . . . : 172.16.0.1
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Wireless LAN adapter Wireless Network Connection:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . : lan
       Description . . . . . . . . . . . : Dell Wireless 1703 802.11b/g/n (2.4GHz)
       Physical Address. . . . . . . . . : 9C-AD-97-00-2E-0B
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes

    Wireless LAN adapter Local Area Connection* 3:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft Hosted Network Virtual Adapter
       Physical Address. . . . . . . . . : 5E-AD-97-00-2E-0B
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes

    Wireless LAN adapter Local Area Connection* 4:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter
       Physical Address. . . . . . . . . : 1E-AD-97-00-2E-0B
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes

    Ethernet adapter Bluetooth Network Connection:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network)
       Physical Address. . . . . . . . . : 9C-AD-97-00-2E-0C
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Teredo Tunneling Pseudo-Interface:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e76:246f:2758:53ef:f8fd(Preferred)
       Link-local IPv6 Address . . . . . : fe80::246f:2758:53ef:f8fd%6(Preferred)
       Default Gateway . . . . . . . . . : ::
       DHCPv6 IAID . . . . . . . . . . . : 436207616
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1B-69-6A-53-34-17-EB-BA-50-AF
       NetBIOS over Tcpip. . . . . . . . : Disabled

    Saturday, March 3, 2018 1:47 PM
  • I have this same problem. What is the solution, please? I can ping the other PCs, but cannot see them in Windows File Explorer. And Homegroup cannot see other computers, either.

    Mike Ernst

    Monday, March 26, 2018 7:55 PM
  • I had SMB1 installed. Did not work.

    I have three computers - two can see only themselves, third one sees all three computers. The one which is working has only the first box checked (SMB 1.0/CIFS File Sharing Support) The three below it are not checked.

    I tried changing the other two computers to match these settings, but nothing changed.

    Other suggestions??

    Tuesday, March 27, 2018 3:26 PM
  • Did what you suggested. No change. Except, after you remove the network devices you can't do ipconfig /release or ipconfig /renew. It tells you there is no device with an ip assigned. 
    Tuesday, March 27, 2018 10:36 PM
  • Change Windows 10 login from a PIN to password and then test. :)

    If using any other antivirus, then please disable it and check. 

    • Edited by Raj Gera Tuesday, March 27, 2018 11:07 PM
    Tuesday, March 27, 2018 11:02 PM
  • I am not using a PIN - I already have a password. And I have already disabled the antivirus - which is Windows Defender.
    Wednesday, March 28, 2018 3:42 PM
  • Can you try the command netcfg -d and then reboot.

    Is that computer prompting for windows update? or can you update manually.

    Can you also check if there are updated network drivers available?

    Please do a clean boot on that machine. 

    Can you see the same computer on workgroup?

    Have you checked for windows firewall? Try to turn it off or add exceptions.

    Thanks, 

    Raj

    Wednesday, March 28, 2018 4:35 PM
  • I have already run netcfg -d and rebooted. No fix.

    I tired manual update. It says it is up to date. I went to Realtek site and found a newer driver. installed, rebooted, no fix.

    What do you mean by "CLEAN BOOT"? I have done many restarts, always after I try to make changes.

    I can not see any computer on the Network in File Explorer except the one I am on. This is common problem on two different computers. (And they have different network card manufacturers with different drivers.)

    Windows Firewall is turned off on all computers right now.

    Wednesday, March 28, 2018 5:05 PM
  • on Search - type msconfig - go to the services tab- Check the box for hide all msconfig - Disable the third party services. Apply the changes - Do not reboot. 

    Open task manager and to go startup tab. Highlight each third party items and select disable. You may have to for a few. 

    Restart the system. 

    Moreover are you able to share shares on PC: \\ipaddress\sharename and computername\sharename. 

    As a test can we disable ipv6 on the NIC and then reboot and test. You can combine this with the msconfig. 

    Wednesday, March 28, 2018 8:09 PM
  • Interesting results.

    Step 1: I disabled all the third party apps and did a restart. In File Explorer I could still see only the computer I was currently one.

    Step 2: I turned off IPV6 and restarted. Now I see nothing in File Explorer, not even the PC I am on.

    Step 3: I turned IPV6 back on and restarted. I can still see nothing, not even the PC I am on.

    Step 4: In File Explorer, if I type in the computer name of another computer, it shows all of the shared drives from that computer in the right hand pane, but nothing is shown in the left hand side. So I started poking around on the Icon bar, and on the Navigation Pane dropdown menu I checked the "Expand to open folder" selection and the name of the other computer appeared. Anther interesting tidbit - I am certain I assigned the computer names in ALL CAPS. But the name is showing in all lower case.

    Step 5: I went to the second computer, and checked the "Expand to open folder" box, and instantly the names of this computer and its own name showed up under Networks on that second computer.

    Step 6: I came back to this computer and closed File Explorer and reopened it. The "Expand to open folder" box was still checked but there is nothing showing. I am not sure what to try next, but it seems perhaps there is a bug in Windows somewhere??

    Friday, March 30, 2018 2:41 PM
  • All done. Nothing changed.
    Friday, March 30, 2018 4:08 PM
  • This change will be required on all the machines in the same network. They should have the same Default Gateway or same range of Ip. 

    Good catch Momominta. 

    Monday, April 2, 2018 4:39 PM
  • I've been having the same issue for well over a year. It's only started happening since I've been on Win 10. Only one computer on my network can see all computers, the others typically only see themselves. If I shut them all down, then the first one I reboot will be the one that sees the others. Mapped network drives remain visible... but I've got so many drives across the network that trying to map them all to all four computers would be a nightmare.

    Seeing other computers in a workgroup shouldn't be so painful

    Friday, April 6, 2018 6:35 AM
  • Wanted to check if the issue is resolved? If not can we check if NetBIOS over TCPIP is enabled??  Go to properties on netwok card.. select TCPIP v4 and then properties. Click on Advanced tab and select Wins. Select Enable NetBIOS over TCPIp. Apply the changes. Reboot and check. Check on other computers too
    Tuesday, April 10, 2018 12:19 AM
  • I would still give it a shot as when I did ipconfig on my machine it shows NetBIOS over TCP/Ip enabled, however when I check the setting on NIC, its set to default and not on enable NetBIOS over TCPIP. May be you can check too and update. 
    Tuesday, April 10, 2018 12:28 AM
  • Totally frustrated here!  On my main desktop I cannot see any other computer on the network (husband's desktop, and two surface laptops, all of which run Windows 10 Pro).  I have tried all of the suggestions above, rebooting between each change.  On my desktop I have set NetBIOS over tcpip to default and also tried On.  NetBIOS still shows off when I examine the status of Ethernet.  The active network shows Public network ATT2VtS82Z.  Connection-specific DNS shows attlocal.net (as does my laptop, neither of which can see the other).  Laptop shows NetBIOS over tcpip as On.  

    Husband's desktop shows same DNS domain name and network name as mine. His computer sees all computers on the network as well as the NAS in his Computer list in File Explorer, which is how all this got started--I really need to be able to get to the NAS from my computer.  

    Just to add a bit more to the mix (although trouble began before), I have a new Uverse modem replacing the previous one because of intermittent signal drops (Pace 5268AC--same as previous).  All settings appear to be the same other than the network name which was automatically changed on all computers.  Both laptops and my desktop had latest Win update (1803).  Long session with MS tech on this problem--she rolled them both back to update 1703 to see if that helped (no change), so she scheduled me for escalated tech appointment (earliest available was 2 pm two weeks hence).  The rollback also reinstated Homegroup, but homegroup won't let me join, either on my desktop or laptop. Husband's computer is running 1803 update.   
    Monday, May 21, 2018 4:19 PM
  • Thank you!
    Monday, May 21, 2018 8:19 PM
  • Hi Pop Page,

    Nothing to say about your result. Now, open windows services (winlogo + X >Run type services.msc) on each of your win 10 computers take a look if these services below are starting if not start them and put the first one on automatic and the second one on manual

    Function Discovery Discovery Resource Publication  (Running) (automatic)

    UPnP Device Host service  (Running) ( manual)

    Computer Browser (Running) (Manual)


    Momominta



    Thanks Momominta, that fixed a long-running problem for me :-)

    Brian Abbott

    • Proposed as answer by the wookie Friday, June 14, 2019 4:43 PM
    Tuesday, June 5, 2018 6:48 AM
  • My network is fixed, thanks to MS tech.  I spent several hours with a Microsoft tech hooked up to my computers and he couldn't get it working, so he gave me an appointment two weeks later for escalated help.  3 hours and two sessions later, my network is happy.  The last tech was the nicest, most patient and knowledgeable tech I have ever run into in my many years of needing tech help, so Kudos to Microsoft!  No kudos, however, for the problem in the first place when all I did was install the updates.
    Tuesday, June 5, 2018 11:35 AM
  • Now, don't keep us in suspense, tell us what he did to fix it...
    Wednesday, June 6, 2018 3:05 PM
  • Hi Pop Page,

    Nothing to say about your result. Now, open windows services (winlogo + X >Run type services.msc) on each of your win 10 computers take a look if these services below are starting if not start them and put the first one on automatic and the second one on manual

    Function Discovery Discovery Resource Publication  (Running) (automatic)

    UPnP Device Host service  (Running) ( manual)

    Computer Browser (Running) (Manual)


    Momominta



    This one worked for me, thanks
    Wednesday, June 6, 2018 3:38 PM
  • I have no idea what she did--wished after it was all over that I had been videoing it.  She was connected to all four computers and was so fast I couldn't keep up--I would be watching one screen and would realize she had opened another setting and was changing something on the computer across the room.  I am sorry I am no help to you.  I will tell you that she spent more than 3 hours getting me up and running.

    Wednesday, June 6, 2018 5:34 PM
  • Thanks.. They must have sent you a closing email for the incident which may have the resolution. If not you can always ask Microsoft of what steps were performed to fix the issue. That will be really beneficial for us to know. 
    Tuesday, June 12, 2018 11:43 PM
  • THANK YOU THANK YOU THANK YOUUUUU!  I have been working on this for several days after work now!   I can finally transfer my files from my desktop to my 'server' box!  As soon as I enabled the services, I could see the 'server' box and then I enable the server box's services, I could see them both.  What does the SMB1 do?  

    If you have time, and feel like it, would you please briefly explain why my services would be turned off?  I certainly did not get into all the services and turn them off, and I live alone, so no one was messing with my machines.  

    Again, thank you so very much for your time.  I can go to bed on time tonight and not yell at my computers! :)

    • Proposed as answer by Bushey55 Thursday, June 14, 2018 7:15 PM
    Wednesday, June 13, 2018 2:40 AM
  • This worked for me too!  Thank God.  After the last update I had one computer that could still see the others in the network and made shortcuts that allowed I could then place on each computers desktop to access the network folders on each computer.  But nice to have it all back to the way it ought to be.

    Have to admit, I assumed Microsoft turned off workgroup visiblity in the last update to force people onto their cloud services - did raise the old "Evil Empire" feeling in me.  

    Thursday, June 14, 2018 7:18 PM
  • After an update I was having the same issue not being able to see other computers on my network.  I did the item above:

    Function Discovery Discovery Resource Publication  (Running) (automatic)

    This simple setting totally fixed my problem!  Thank you Momominta and Brian Abbot!!
    Sunday, June 24, 2018 5:59 AM
  • After days, same here!!!!

    Function Discovery was not running.
    • Edited by vidwiz12 Thursday, June 28, 2018 4:37 AM
    Thursday, June 28, 2018 4:36 AM
  • this was such the answer, thanks so much man
    Thursday, July 5, 2018 5:50 PM
  • I have a similar problem (except that it is my wife's computer that's working and mine that can't see any other computers on the network).  I may get desperate enough to call MS and if I do, I was wondering if they gave you a case number for your problem?  I'm thinking that I could give it to them and it might let the next tech fix my system in less than 3 hours.  If you're concerned that the case number may reveal private information, please don't post it.  If all else fails, I can do a complete reinstall of windows and reload my apps [but I'd rather have a root canal :-(].  TIA!
    Thursday, July 12, 2018 1:59 AM
  • THANK YOU!  THANK YOU!  That fixed my problem.  Now the computers can see each other.  the FUNCTION DISCOVERY RESOURCE PUBLICATION wasn't running.  Once I started it, all is well.

     
    Saturday, July 14, 2018 4:26 PM
  • This worked for me.  Thank you so much.

    I just can't cope with the fact that Windows 10 update broke my network.  How would a non technical person sort this out MS!!!

    Thanks again

    R


    • Edited by Cyberyob Tuesday, July 17, 2018 11:58 AM Typo
    Tuesday, July 17, 2018 11:57 AM
  • I don't know if it was an update at fault, my incident happened in the same nature, but as soon as I changed from a telstra router to a TPG - TPLINK Archer VR1600v one, it was intermittent, allowing me to view computers on my network at certain times, but mostly not, also sometimes some computers and not all, and one extremely strange fact was that I was able to print via the network, while the printer was not even listed on the Wireless clients page at all. Im still having problems, I can ping the devices listed on the routers client pages, but can not see them in any of my 3 windows computers or can any device including android tv boxes and a linux NAS, see eachother. TPLINK replied with an extremely weak response, after I gave information including screenshots and told them that I scanned for malware on all 3 computers using Malwarebytes, came up clean, and I don't use 3rd party antivirus software or firewalls at all, and that Windows firewalls are enabled on all machines, but at default, all networks are set to Private, not public, and file and printer sharing are set to on, and network discovery is enabled on all. He replied, sounds like a malware problem or a firewall one, and that he will not help further. I don't know what else to try other than ordering a less preferred HUAWEI one, I've reset the factory defaults on the first TPLINK router issued, and on the second replacement one sent, still the same problem
    Friday, July 20, 2018 4:56 AM
  • I am completely perplexed by this issue which clearly is of Microsoft's making.

    There must be a heap of people who have been slugged by this problem.

    Microsoft should behave responsibly and put out comprehensive fix instructions rather than leave it to us to bash our heads trying to fix this mess. 

    I have a computer that cannot see other computers on my local network.

    I have checked that all the services mention in this thread are running but to no avail.


    Saturday, July 21, 2018 4:06 AM
  • Thank you very much i have been trying to fix my network problem for week.Your solution was to the point and worked instantly. Hats off to you. for the longest while my pc could only see the Laptop if i created a shortcut,that worked but wasn't what i wanted.I wanted them both to show up in explorer under Network....Thanks again
    Wednesday, July 25, 2018 6:03 PM
  • I have this same problem. What is the solution, please? I can ping the other PCs, but cannot see them in Windows File Explorer. And Homegroup cannot see other computers, either.

    Mike Ernst

    Hi,

    For you  if all the services below are started 

    Function Discovery Discovery Resource Publication  (Running) (automatic)

    This worked immediately for me.

    Thank you, Momominta! :)

    Sunday, July 29, 2018 6:15 AM
  • Thanks Momominta, that fixed this issue for me.
    btw, here was the status for (1) desktop and (2) laptop before applying the fix:
    (1)
    Function Discovery Discovery Resource Publication  (Stopped) (manual)
    UPnP Device Host service  (Stopped) ( manual)
    Computer Browser (Running) (Manual)
    (2)
    Function Discovery Discovery Resource Publication  (Stopped) (manual)
    UPnP Device Host service  (Running) ( manual)
    Computer Browser (Running) (Manual)
    Friday, August 3, 2018 6:02 AM
  • Spoke too soon... (1) can now only see itself after just closing and opening File Explorer :(
    Friday, August 3, 2018 6:12 AM
  • ... checked SMB...  was missing SMB Client, reboot and now ok...     
    Friday, August 3, 2018 6:35 AM
  • Hello,

    This solution worked for 5 of my 6 computers. I can map drives to the computer I can't see in the Network list. Perhaps I am missing something. Any other suggestions?

    -- T

    Thursday, August 9, 2018 5:49 PM
  • Thanks for this, worked like a charm.
    Friday, August 10, 2018 4:27 AM
  • Thank you, Momominta.   I was having the exact same problem and the above fix resolved my issue as well.

    Appreciate the help everyone.


    • Proposed as answer by Mike Liscio Sunday, August 12, 2018 1:03 AM
    • Edited by Mike Liscio Sunday, August 12, 2018 1:04 AM
    Sunday, August 12, 2018 1:03 AM
  • Thank you, Momominta.   I was having the exact same problem and the above fix resolved my issue as well.

    Appreciate the help everyone.


    Hello,

    I turned on the Discovery in services. However, I cannot see my Windows XP latop (ethernet connected to the same network). I was able to see this before Windows 10. Netbios is enabled. My Windows XP computer can see the Windows10 computer, but not the other way around. I have followed the solutions to most of the above. Any help will be great

    Monday, August 13, 2018 1:06 AM
  • Thank for that information,

    I've been serching for days the internet for a solution to why couldnt see my share files in my network. 

    I set the following service to automatic and it solves my problem.. 

    Function Discovery Discovery Resource Publication  (Running) (automatic)

    Thank you very much.

    regards.

    Wednesday, August 15, 2018 1:27 PM
  • I've been trying to sort this out for a while.

    I set the following service to automatic on both machines and it has solved my problem.. 

    Function Discovery Discovery Resource Publication  (Running) (automatic)

    Thank you very much.

    Wednesday, August 15, 2018 9:17 PM
  • You are a genius! 

    I have been trying to solve this for so long. How cam Microsoft not figure this out!!!!! ?

    Thursday, August 30, 2018 12:59 AM
  • The Function Discovery not running was the issue for me.  Thank you so much for posting this!
    Saturday, September 1, 2018 1:40 AM
  • This is the solution as far as I can tell. I have 8 computers on a Pier to Pier Network and none of them saw one another prior and all see all after. Fix worked for me.
    Monday, September 3, 2018 5:53 PM
  • SMB 1.0?  Good way to open your network up to Wannacry type malware.
    Sunday, September 9, 2018 8:45 PM
  • SMB 1.0 is the original network file sharing protocol Windows used, and it is VERY exploitable. Any modern PC should not have it enabled. (Google up on WannaCry)
    Sunday, September 9, 2018 8:48 PM
  • This was the solution for me! Particularly the first service "Function Discovery Resource Publication" was the key. When I enabled this service, other devices became visible. Now that the service is enabled on my three computers, they can all see each other! (I also enabled the other services, but I saw the change as soon as I enabled this service)

    Note for anyone else following this advice: Make sure you start the service and in the "properties" menu, switch it to automatic start. You don't want the computer to un-fix itself the next time you restart!

    Monday, September 10, 2018 5:46 AM
  • Thank you Momominta! Enabling all SMB features did the trick. Now, all network computers are available and visible within Network > Computers. I am also able to map a network drive and successfully save credentials, which was not working (saving credentials). And it subsequently corrected a back issue with my itunes library which could not discover the file path for my entire music library. Wish I would have discovered this post two hours ago. 
    Wednesday, September 12, 2018 2:23 AM
  • Hi POp Page,

    Sorry, it was my mistake this message is for you not for MlErnst,

    I have checked your IPCONFIG /ALL result then take a look at below:

    IPv4 Address. . . . . . . . . . . : 172.16.7.2(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.0.0

    Default Gateway . . . . . . . . . : 172.16.0.1
       DHCP Server . . . . . . . . . . . : 172.16.0.1

    Do you see the difference between your IPv4 IP address and your Gateway?

    If your IPv4 is 172.16.7.2 your Gateway should be 172.16.7.1

    If your Gateway is 172.16.0.1 your IPv4 should be 172.16.0.2  

    Do you understand what I mean? There is something wrong, can you correct it?


    Momominta


    The IP and GW are valid for his/her network. The subnet mask define 16bit for address space. He/She is on network 172.16.0.0/16 (16 means mask: 255.255.0.0) that mean the network valid address range is from 172.16.0.1 to 172.16.255.254 (and 172.16.255.255 for broadcast).


    • Edited by przemekow Friday, September 14, 2018 9:13 AM add more info
    Friday, September 14, 2018 9:12 AM
  • >Function Discovery Discovery Resource Publication  (Running) (automatic)

    Fixed my problem, too. Thanks Momominta!

    • Edited by fneils Tuesday, September 18, 2018 12:10 PM
    Tuesday, September 18, 2018 12:09 PM
  • The Function Discovery not running was the problem for me too.  Thank you very much for posting this!
    Wednesday, September 19, 2018 1:02 PM
  • Finally!! The SMB 1.0 worked for my machines. Have been looking for a fix for a very long time. YOU ARE THE MAN, OR LADY!! Thank you.
    Sunday, September 23, 2018 2:31 PM
  • you, Momominta have saved my day! On my Win10 refresh I could see no other machines...and then you showed me that little tick box above for SMB Client. I ticked it and it restarted and all is well now. Thank you
    Tuesday, September 25, 2018 5:28 AM
  • Maybe a little late, but this is the only thing that worked for me:

    (answer found on the Windows Club Network; not my own)

    Check Function Discovery Resource Publication Service

    Press Win+R to open the Run window and type the command services.msc. Press Enter to open the Windows Services window.

    Locate the Function Discovery Resource Publication Service, right-click on the Service and select Properties.

    Here, ensure that the Startup type of Function Discovery Resource Publication service is Automatic and that it is Started.

    Wednesday, September 26, 2018 9:39 PM
  • This solution worked for me after trying several different solutions provided by others.

    Great


    • Edited by DerekJBurt Thursday, September 27, 2018 8:58 AM
    Thursday, September 27, 2018 8:58 AM
  • Thank you very much!  I needed all of the proposed steps and they worked perfectly!

    Function Discovery Discovery Resource Publication  (Running) (automatic)

    UPnP Device Host service  (Running) ( manual)

    Computer Browser (Running) (Manual)

    ...and Turn Windows features on...all check boxes for [ ]SMB

    I believe a recent Windows 10 Update turned off these network sharing settings because everything has been fine until the update applied a few days ago.  I've been shaking my head because I'd already done all I would normally have done and everything looked fine.  Window's own "Diagnose" completely failed to identify this!

    I cannot repost the image nor quote the full resolution in my Reply since I don't have a verified account. 

    Just want to say "Thank You!" to Momominta / LarryWal82.

    Thursday, September 27, 2018 5:37 PM
  • After changing the windows service settings and checking all other settings with nothing working I found that when I changed all my computers to Private network and rebooting they connected just fine.
    Wednesday, October 17, 2018 10:55 PM
  • You rock bud! That worked for me as well!!!! Days later :)
    Sunday, October 21, 2018 9:26 PM
  • "Function Discovery Discovery Resource Publication  (Running) (automatic)"

    worked AWESOME!!!

    Monday, October 22, 2018 11:55 PM
  • Yes, Yes, Yes..... Thank You. I had been struggling with this for 7 months. Hours wasted. Now I'm camping happily.
    • Proposed as answer by Steven Brates Monday, November 5, 2018 6:15 PM
    Monday, October 29, 2018 2:58 PM
  • All of the above solutions worked for me as well , but only once I turned off my firewall from AVG. I know there is a way to fix the firewall issue, but thought I would point this out on this thread, that many firewalls will block network traffic unless promoted to allow traffic through.
    Monday, November 5, 2018 6:18 PM
  • The Functions seemed to fix my problems.  4 lan and 1 wifi laptop.  All could see new laptop but laptop couldn't see lan machines.  Laptop now sees 3 of 4 machines.  Nice to be able to transfer stuff around the 90tb network and of course view content. 

    Fun Fact:  Myu Galaxy 9 phone with ES file explorer could pop onto the network faster than any windows machine and look at all shared resources on all the machines.  Guess they have a way to find machines.  It seriously found 5 computers in less than 30 seconds.  Both wifi and lan based off the same router.  Took almost 2 days to sort this workgroup crap out thanks to this thread.  Otherwise it would have taken who knows how long.  When that homegroup crap came out it reminded me of when windows was naming everything with long names as a default. On the small screens it was hard to see more than a couple of directories deep.

    I see that microsoft thought that this was serious enough of a problem that they updated a billion machines to get rid of homegroup.  YEAH.  I noticed that Elon fired a few people that used to be at microsoft.  They were taking too much time to get things right..  

    Kudos to everyone that contributed on this post.  My thoughts are the fog is being lifted on this network maze.  I had 14 computers on network in 1981 using some apple 2's and a 5 mb drive.  It was easier to setup that network than windows 10.  If MS doesn't get their act together, that android could do some serious damage to win 10.  With everything networked now, taking 2 days for me to get workgroups working to some extent and my phone doing a better job without even flinching in 30 seconds makes me think what could happen if google decided to get serious about operating systems.  


    • Edited by AustinRick Monday, November 12, 2018 5:20 AM
    Monday, November 12, 2018 5:16 AM
  • Thanks! Enabled those services and installed smb1 on all my windows 10 computers worked. Now they see each other on the network and shared drives work. 

    Issue started after updating windows 10 home laptop to 1803. 


    • Edited by cuyey Monday, November 12, 2018 8:43 AM
    Monday, November 12, 2018 8:43 AM
  • Hi - this was it! Solved my discovery problem with my new PC, thank you!
    Saturday, November 24, 2018 9:45 AM
  • Thank you Momominta from Calgary. This solved the problem for me. Hours and hours of browsing the Internet for a solution before finding your advice. Regards, NJR
    Thursday, January 17, 2019 8:53 PM
  • [Solved] I had the same problem and Microsoft Support gave me an EasyFix that fix it.

    You can try to reset TCP/IP if you have Internet connection issues. This article describes two ways to reset TCP/IP. To have us reset TCP/IP for you, go to the "Here's an easy fix" section. If you prefer to reset TCP/IP manually

    Using the EasyFix Link

    https://support.microsoft.com/en-us/help/299357/how-to-reset-tcp-ip-by-using-the-netshell-utility 

    Manually reset TCP/IP 

    To manually reset TCP/IP, follow these steps:

    Windows 8 - 8.1 -10

    1. On the Start screen, type CMD. In the search results, right-click Command Prompt, and then select Run as administrator.
    2. At the command prompt, enter the following command, and then press Enter:
      netsh int ip reset c:\resetlog.txt 
      Note If you don't want to specify a directory path for the log file, run the following command instead:
      netsh int ip reset  
    3. Restart the computer.

    Windows 7 and Vista

    1. To open a command prompt, select Start and then type cmd in the Search programs and files box.
    2. Under Programs, right-click the CMD.exe icon, and then select Run as administrator.
    3. When the User Account Control box appears, select Yes.
    4. At the command prompt, enter the following command, and then press Enter:
      netsh int ip reset c:\resetlog.txt 
      Note If you don't want to specify a directory path for the log file, run the following command instead:
      netsh int ip reset resetlog.txt 
    5. Restart the computer.

    Thursday, February 14, 2019 6:50 PM
  • Excellent, fixed my fault!

    Friday, February 15, 2019 2:42 PM
  • Thanks for this! been trying to connect a newly reformatted windows 10 PC to my network. I was using the same build for all of my PC's but I only had problem with the last PC that I did. I was not able to connect it to the other computers in the network. With this solution, lo and behold all the PC's just appeared when i restarted after doing the steps above! many thanks momointa! 
    Tuesday, February 19, 2019 4:49 AM
  • One issue is the $%^& Microsoft requirement to use a Microsoft account to log in. My Mac and Linux machines use my initials as a kid, and a different password. This makes networking across systems very difficult. Unless you can get a user id/pwd box to pop up, you cannot see the shares! I finally did this on another Windows machine by putting in

    \\machine_name

    in the file manager address bar. Then the login popped up. But this trick does not work on my Mac via "connect to?"

    And my main samba server is on my Linux machine.

    On the Mac, btw, you must use the Connect function in Finder and put in an address like:

    smb://machine_name

    Where machine_name is the WINS name

    • Edited by jamesrome Sunday, February 24, 2019 10:01 PM
    Sunday, February 24, 2019 9:52 PM
  • I'm in the same boat as you. I've spent HOURS doing every single obscure fix everybody insisted would work, including shutting down the firewalls and going into the config system, which no normal user should ever have to do for something as simple as this. Why should I have to totally rebuild every single thing in my computer systems in order for two computers on the same network to talk to each other? When is Microsoft going to admit they totally screwed up what should be a very simple, very obviously necessary function - two computers on the same network should be able to see each other without the user spending hours reconfiguring the machines.

    SERIOUSLY. Get with it, MS.

    Friday, March 8, 2019 2:33 PM
  • So the real problem is that microsoft requires you to be logged in to THEIR system before you can network your own #(&%*#&^$ machines?

    SERIOUSLY?

    Friday, March 8, 2019 2:34 PM
  • Your guide has solved my problem. Thank you, Momominta.
    Friday, March 8, 2019 9:28 PM
  • The Turn On SMB inside Windows Feature worked for me!  Oddly, my SMB 1.0/CIFS Client was not checked.  Once I checked it, I can see all the computers on my network again.  Before this, I was only able to see some.
    Friday, April 12, 2019 1:11 AM
  • Using these 3 steps, I was able to get my systems talking with each other once again! Thanks a million!!!
    Monday, April 22, 2019 2:51 PM
  • I also tried all the recommended solutions with no results. I the tried another fix where I did a network reset under the network sharing option when clicking on the network icon in the lower right of the task bar. This performed some process to reset the network and forced a reboot of the computer. After the start-up, there is a question asking if you want other computers to see your system I answered yes and then I could see this computer from my other system.
    Monday, April 29, 2019 4:24 AM
  • Thanks Mominta and Brian Abbott.  It worked!
    Thursday, June 6, 2019 1:24 PM
  • this fixed it for me

    Thanks

    Friday, June 14, 2019 4:44 PM
  • I have pressed Windows + X (Same as menu Windows!)
    Clicked on 'Run'
    Typed; 'services.msc' [return]
    This opened the Services window.
    Can only find 'Function Discovery Resource Publication' not 'Function Discovery Discovery Resource Publication'!
    Double clicked on 'Function Discovery Resource Publication'
    Do I click on General, Log On, Recovery or Dependences tab.
    In the General tab, Startup type = Manual
    Explain Computer Browser Running = Manual, as there is no option in Windows 10 1903

    I lost local network when upgrading from Windows 10 1809 to Windows 10 1903.
    I can read/write Windows 10 1903 from Windows 7 and Linux distros.

    So problem is on Windows 10 PCs only.

    Sunday, June 16, 2019 3:09 PM
  • Like countless others, I have been frustrated by the inconsistency of File Explorer's display of other computers in the network.  No rhyme or reason to it, sometimes it does and sometimes it doesn't.  You've done all the checks, all computers are connected but sometimes they just don't seem to see each other.  I use a simple workaround - just choose a folder on 'the other' computer and, next time you make contact with it, add it to Quick Access on the computer where you are working.  When next you have an 'invisibility' problem, just click on that item in Quick Access and connection is established.  You don't need to use the 'Network' part of File Explorer at all.  If you make the right choice of folder, it's also quicker.  Just be careful with naming the folders differently on each computer otherwise you might pick the wrong one from the Quick Access list.
    Tuesday, June 18, 2019 9:04 AM
  • That worked for me!
    Sunday, July 7, 2019 7:58 PM