Problem Steps Recorder is not working.


  • I believe this is the correct thread to start this.  After doing a search this one had more questions on the PSR than others.

    I am running Windows 7 Ultimate RTM 64-bit.  It's been great. Going through the features.  I've been looking for the Problem Steps Recorder.

    It doesn't run.  I type problem steps in try to click on it.  Doesn't start (checked Task Manager).  I've tried to do and type psr.exe; this also doesn't start nothing happens (checked Task Manager).

    Nothing happens.  I tried to do a sfc.exe /scannow to check if the files have been corrupted but have gotten a report that says everything is fine.

    I'm very envious of all those blog and posts here I read of how well it works...and would love to have it working on my machine.

    What is my next step to try to get this most impressive feature working on my Windows 7 Ultimate 64 bit machine?   Please help me!


    • Moved by Carey FrischMVP, Moderator Monday, October 19, 2009 4:38 AM Moved to relevant forum category (From:Windows 7 Miscellaneous)
    Monday, October 19, 2009 1:38 AM


  • Please use regedit to rename hklm\software\policies\microsoft\windows\AppCompat - change AppCompat to AppCompat_HOLD .  Then try launching PSR again.  If it fails, please capture and submit another Procmon log file.
    • Marked as answer by ronald_wong Friday, October 23, 2009 4:06 PM
    Friday, October 23, 2009 10:10 AM

All replies

  • Hi Ronald,

    Are there any noteworthy or relevant events in the event logs?

    Can you download the 64-bit Dependency Walker (DW) from .  Then, extract the contents of the ZIP file and run depends.exe.  Open %systemroot%\system32\psr.exe (e.g. c:\windows\system32\psr.exe) and press F7.  Check all boxes and click OK.  Let output scroll by in the bottom pane of DW, and look for an entry like "Exited "C:\windows\system32\psr.exe" (process 0xhhhh) with code n (0xh) by thread 0xhhh. "  What is that line in your profile of psr.exe?
    Monday, October 19, 2009 9:26 AM
  • Thanks for this next step....  used the's the result.

    00:00:09.657: Exited "c:\windows\system32\PSR.EXE" (process 0x12BC) with code 2 (0x2) by thread 1.

    also as added info.  Before I checked all the boxes.  I automatically ran the dependency walker and it showed that IESHIMS.dll is a problem... I believe the two may be inter-related but not sure...thank you for the help

    Warning: At least one delay-load dependency module was not found.

    Warning: At least one module has an unresolved import due to a missing export function in a delay-load dependent module.

    Monday, October 19, 2009 1:20 PM
  • Anything in the event logs?

    The IEShims messages are not significant - I get them on my system as well, and I can run PSR with no problem.

    If you log in as a different user, can you run PSR successfully? What about if you boot into safe mode?

    Exit code 2 would tend to mean "The system cannot find the file specified."  Next suggestion would be to run Process Monitor . Set a filter for "Process Name is psr.exe then Include", and launch psr.exe.  When you see the Process Exit event for psr.exe, stop capturing, save the events into a native .PML format (File->Save), and then ZIP the .PML file.  Password-protect it, and upload it somewhere (e.g. Live SkyDrive).  Privately share the location and password with those you would have inspect the contents (my email address is in my profile).

    Tuesday, October 20, 2009 12:49 AM
  • Hi Ronald,


    Please go to “C:\Windows\System32”, right-click “psr.exe” and select “Run as Administrator” to see if it will run.


    If the issue persists, please perform a clean boot and see if it can run in this environment:


    How to troubleshoot a problem by performing a clean boot in Windows Vista or in Windows 7



    Nicholas Li - MSFT
    Tuesday, October 20, 2009 10:15 AM
  • Mr. Nicholas,

    Thanks for this suggestion, unfortunately I had forgot to mention that I had tried this before.  The problem does persist regardless of whether I do a clean boot or not.

    As suggested also by Mr. No. Compromise, I tried in safe mode and nothing is in the event logs.  I've not a a chance to run the process dependency idea yet.  Work is hectic.  But this seems to be the first encountered problem with this particular app.  That's awsome for MS; bad for me! :)

    thank you!

    edited later:  I forgot to mention as well that I enabled the administrator's account and tried to run it from there as well.  Both accounts on my computer still cannot make psr.exe operate.   I'm really stumped  thanks again! ~r.
    Tuesday, October 20, 2009 1:26 PM
  • One other suggestion that doesn't take much in the way of effort, providing that you can be without this particular system for a while (it tends to take a while to run) is to run chkdsk /r on all your drives - run chkdsk /r x: from an elevated CMD prompt (replace 'x' with the actual drive letter).
    Wednesday, October 21, 2009 9:55 AM
  • Hello again!
    I've tried doing the regular windows troubleshooting and also this last suggestion of the chkdsk /r x:
    the only chkdsk anomaly was:

    "96512 file SDs/SIDs processed. Cleaning up 37 unused index entries from index $SII of file 0x9.

    Cleaning up 37 unused index entries from index $SDH of file 0x9.

    Cleaning up 37 unused security descriptors.

    Security descriptor verification completed"

    I've had a chance to run the process monitor now too.  I've noticed that several registry entries where the name was not found

    I will try to get that logfile to you as soon as I find your e-mail. thanks for helping.
    I'm glad this seems to be a singularity for Windows 7,  this has been the only real problem beside my own hardware shortcomings.


    Thursday, October 22, 2009 1:38 PM
  • The chkdsk messages are normal and not indicative of any problems.

    The "name not found" results for events from Process Monitor are also not necessarily problematic.

    In response to your email - yes, if the .PML file (ZIPped or uncompressed) is small enough to attach to a message, certainly you may send it that way rather than uploading it somewhere.  Entirely up to you. :-)
    Friday, October 23, 2009 1:26 AM
  • Please use regedit to rename hklm\software\policies\microsoft\windows\AppCompat - change AppCompat to AppCompat_HOLD .  Then try launching PSR again.  If it fails, please capture and submit another Procmon log file.
    • Marked as answer by ronald_wong Friday, October 23, 2009 4:06 PM
    Friday, October 23, 2009 10:10 AM
  • This worked!  thank you very much.
    In the procmon log file is there something that specifically pointed out my problem?
    I would like to learn more about this...can you point out
    what particular area would have given me more clues?  programming....registry errors?
    this is one of the more fascinating problems for me that I just couldn' figure out!


    Ronald Wong ronaldwongten shifttwo gmaildotcom
    Friday, October 23, 2009 4:11 PM
  • Excellent news! Good to hear that it helped.

    I had the benefit of being able to compare the events in your PML, from a system where there was some problem, to the events in a PML I captured on my system, which did not have that problem.  At the point where the events diverged somewhat, I figured some key may be.  In this case, that point of divergence was the key you renamed.  So, something in that key appears to have been affecting PSR's behavior.  Do you recall setting any application compatibility settings for PSR?
    Saturday, October 24, 2009 1:15 PM
  • I don't remember doing anything but a default install.  I don't think I would have doen any application compatibility settings for the PSR at all.  I'm again puzzled at this unintentional setting in the registry.  I normally don't mess around with the registry very often at all.  thanks again!  Ronald
    Ronald Wong ronaldwongtenshift2gmaildotcom
    Saturday, October 24, 2009 3:47 PM
  • Then, it seems that how the setting got in place will be a mystery.  Perhaps some software that has been installed changed something?  Hard to tell...
    Saturday, October 24, 2009 4:48 PM
  • So "disabling" AppCompat by moving it elsewhere (AppCompat_HOLD) solves this issue. My inquisitive mind immediately asks: Why?

    Well... Here's why:

    You don't need to disable AppCompat. You only need to get rid of the DisableUAR registry key inside AppCompat. Help is available on this registry key / policy setting:


    "This policy controls the state of the Problem Steps Recorder feature in the system.

    Problem Steps Recorder enables capturing the steps taken by the user before encountering a problem. The output data generated by Problem Steps Recorder will be another type of data collection enabled through feedback scenarios such as Windows Error Reporting to help developers in understanding problems. The captured data will contain descriptions about the user actions involving information such as  user inputs on keyboard and mouse, meta data about the UI objects interacted along with screen shots.  Problem Steps Recorder provides specific options to turn on and off the data collection whenever required.
    By default, Problem Steps Recorder will be available for customers to turn on during a problem reporting scenario.
    If you enable this policy setting, then the Problem Steps Recorder feature will be disabled on this machine.
    If you disable or do not configure this policy setting, then Problem Steps Recorder will be available for customers."

    • Edited by 3ICE Sunday, October 6, 2013 8:25 PM
    Sunday, October 6, 2013 8:21 PM
  • Ronald,

    I am having the same problem with my Problem Steps Recorder and can not get it to work at all. I never new they had such a wonderful program and would also like to use it. Did you ever resolve the problem? If so please email me at

    bob112649  (at)

    Thank you,

    Saturday, August 6, 2016 11:34 AM
  • Genius
    Sunday, September 10, 2017 4:07 AM