flash.ocx causes crash internet explorer

    General discussion


    system: intel

    os: windows xp professional german sp3 b5508


    using /integrate switch on xp sp2 media.


    i have only installed system drivers.


    need upload workspace for sending the dmp file.


    at crash i run the drwtsn32.exe and select symboltable and full dump.


    here are some screenshots







    Wednesday, April 09, 2008 8:30 PM

All replies

  • here is the logfile:





    Code Snippet
    *** ERROR: Symbol file could not be found.  Defaulted to export symbols for G:\WINDOWS\system32\macromed\flash\flash.ocx -
    Funktion: flash
            1001cfb6 59               pop     ecx
            1001cfb7 0fbf461a         movsx   eax,word ptr [esi+0x1a]
            1001cfbb 89470c           mov     [edi+0xc],eax
            1001cfbe 8b4608           mov     eax,[esi+0x8]
            1001cfc1 89472c           mov     [edi+0x2c],eax
            1001cfc4 8b460c           mov     eax,[esi+0xc]
            1001cfc7 8b4f2c           mov     ecx,[edi+0x2c]
            1001cfca 894730           mov     [edi+0x30],eax
            1001cfcd 0fb6461d         movzx   eax,byte ptr [esi+0x1d]
            1001cfd1 8b09             mov     ecx,[ecx]
    FEHLER ->1001cfd3 8b494c           mov     ecx,[ecx+0x4c]    ds:0023:0004c2a9=????????
            1001cfd6 8b8481a4030000   mov     eax,[ecx+eax*4+0x3a4]
            1001cfdd 894738           mov     [edi+0x38],eax
            1001cfe0 0fbe461e         movsx   eax,byte ptr [esi+0x1e]
            1001cfe4 894734           mov     [edi+0x34],eax
            1001cfe7 5f               pop     edi
            1001cfe8 5e               pop     esi
            1001cfe9 c9               leave
            1001cfea c20c00           ret     0xc
            1001cfed 8b410c           mov     eax,[ecx+0xc]
            1001cff0 53               push    ebx



    Wednesday, April 09, 2008 11:50 PM
  • "Upgrading" to the latest version of Flash Player which is available on Adobe's web site resloves the issue, doesn't it?

    Thursday, April 10, 2008 2:59 AM
  • hi,


    i have already done this afterwards, but the first time i upgraded to the latest it also crashed.

    the flash logo "F" went from right to left continuesly. i waited about 10-15 seconds.

    it does not showing me the text "flash player already installed" or similar.

    i was suprised why the text not visible. then i clicked back and its hungapp.

    i have tried again and have at moment no problems.


    it can be difficult to reproduce the issue, i want to tell you about the crash i have.


    here is a log file from debugging tool (this tool installed after crash)


    Code Snippet

    Microsoft (R) Windows Debugger Version 6.8.0004.0 X86
    Copyright (c) Microsoft Corporation. All rights reserved.

    Loading Dump File [G:\Dokumente und Einstellungen\winxp_sp3\Desktop\log\user.dmp]
    User Mini Dump File with Full Memory: Only application data is available

    Comment: 'Dr. Watson generated MiniDump'
    Symbol search path is: *** Invalid ***
    * Symbol loading may be unreliable without a symbol search path.           *
    * Use .symfix to have the debugger choose a symbol path.                   *
    * After setting your symbol path, use .reload to refresh symbol locations. *
    Executable search path is:
    Windows XP Version 2600 (Service Pack 3) MP (2 procs) Free x86 compatible
    Product: WinNt, suite: SingleUserTS
    Debug session time: Wed Apr  9 21:16:03.000 2008 (GMT+2)
    System Uptime: 0 days 1:40:54.143
    Process Uptime: 0 days 1:39:01.000
    *** ERROR: Symbol file could not be found.  Defaulted to export symbols for ntdll.dll -
    This dump file has an exception of interest stored in it.
    The stored exception information can be accessed via .ecxr.
    (730.6f4): Access violation - code c0000005 (first/second chance not available)
    eax=00000001 ebx=02900068 ecx=0004c25d edx=026860a9 esi=029c1374 edi=02900068
    eip=1001cfd3 esp=00129f74 ebp=00129f8c iopl=0         nv up ei pl nz na po cy
    cs=001b  ss=0023  ds=0023  es=0023  fs=003b  gs=0000             efl=00000203
    *** ERROR: Symbol file could not be found.  Defaulted to export symbols for flash.ocx -
    1001cfd3 8b494c          mov     ecx,dword ptr [ecx+4Ch] ds:0023:0004c2a9=????????





    Thursday, April 10, 2008 9:22 AM
  • Despite from the error you've received it makes we wonder, if KB923789 (MS06-069) is contained in SP3 RC2 Refresh or not.
    KB923789 contains flash.ocx version while the error message you've posted is referring to flash.ocx

    Freu"Since you're able to understand German: -> Anmerkungen Smile"di
    Thursday, April 10, 2008 10:31 AM
  • hi,

    first, i know that sp3 gets RTM but,


    i have installed my xp home sp3 b5508 again and this issue happens always.


    i have tried to go this site 10 times but no luck.


    and always cause this issue. i dont know what i do.





    can you reproduce this issue.

    i'm waiting 5 sec. and this issue happens.




    which version had the flash.ocx ?


    edit: i have already a new dump file

    Wednesday, April 23, 2008 12:21 AM
  • Would it be possible to install the latest flash.ocx before installing SP3.

    That should avoid this issue.




    Wednesday, April 23, 2008 5:54 AM
  • hi shashank,


    install the lastest flash.ocx from adobe avoid this issue but

    the problem is, when you slipstream sp3 / burn / install from ground this issue is always there.


    i would install sp3 rtm one times over the current system.

    but next time i would prefer install xp with slipstreamed sp3.


    and there are many people waiting for install sp3 via slipstream Wink



    btw: thanks microsoft for supporting an old os !

    Wednesday, April 23, 2008 6:42 AM
  • Version might have been in RC2, but it looks like the RTM distribution still has  Here's my test:


    Build a plain-vanilla XPSP2 (from volume media with SP2 included), unpatched.  Searching for FL*.OCX yields one hit:

    FLASH.OCX  v6.0.79.0   dated 8/4/04 932,972 bytes. in C:\WINDOWS\SYSTEM32\MACROMED\FLASH


    Ran the Adobe uninstaller program for Flash; a search for FL.OCX yields no hits from anywhere on the disk.


    Ran the Adobe installer for the current version of Flash; it installed FLASH9F.OCX (version  This is where I want my users to be.


    Ran XPSP3 (English) as downloaded from MSDN on 23 April.  It reinstalled FLASH.OCX version - not only in the MACROMED\FLASH folder but also in %WINDIR%\ServicePackFiles\I386. The only difference is that the newly-reconstituted (and highly vulnerable) file is now dated 12/31/06.


    I verified that the SP installer was responsible for this by tearing apart the XPSP3 installer; the Flash.OC_ file is there, with the 12/31/06 datestamp.


    This is irritating my security patch compliance checkers (and my users, and my managers) since all versions of Flash other than the most recent have significant security vulnerabilities. Any suggestions for automating remediation in a way that requires minimal (preferably no) user interaction?


    Just to be certain as I write this that there's been no change I'm downloading a new copy of the ISO image from Technet ... nope, no change.  It compares binary-identical to the image I downloaded on 4/23. (OC-12 access to the Internet *is* convenient...) Incidentally, did anyone notice that the ISO being distributed by Microsoft has the XPSP2 FAQ file?


    I'm trying to avoid telling my users - some of whom are quite literally halfway around the world from me - that after they've previously complied with a requirement to update their Flash player they need to to it again because XPSP3 installed an obsolete, security-vulnerable file.


    And to get back to the OP's question, he urgently needs to replace the Flash player on his system with one that's had the security holes patched.  I have to suggest that it's possible that his system has been attacked through the Flash module.

    Wednesday, April 30, 2008 11:23 PM
  • Hi. Hope this helps I created and uncreated this problem several times on my computers using different codec packs.  My advice is to unload any codec pack media /dvd player you may have recently installed before the errors started occuring or may have updated themselves prior to occurance of first crash.  Then I used combined community codec pack to reinstall drivers and if it asks to disable it thinks are not good let it.  Mine fixed itself after as well as made viewing movies/audio better.  Hope this helps will check back perhaps a list of msconfig services that start up when your computer does would be helpful.
    -SpoonsAreFun (bet you can't play with just one)
    Sunday, December 21, 2008 8:15 AM
  • Upgrading the flash player to the last version did not help to resolve this error.
    Wednesday, June 16, 2010 2:35 AM
  • Do you have any other IE add-ons enabled? Like a mouse cursor gesture add-in? You may want to temporarily remove any 3rd party toolbars etc.

    You may also try to use Adobe's complete Flash removal tool, then reinstall from scratch.


    MCTS 70-620 Certified
    Thursday, June 17, 2010 12:58 PM
  • Hi,

    Check the following information..........


    Hope this helps you.



    Tuesday, April 19, 2011 4:44 AM