Error: QLocalSocket: ConnectToServer: Unknown Error 5. This pops up on other Admin and logins on Windows 7. Have a Belkin 750 Router.


  • Have a Gateway Windows 7 computer with a Belkin 750 Router. Multiple log ins to the Gateway, 2 admin, 3 kids, plus the Guest; and I get this error message on the other log ins, but not my admin account.  Even though this message comes up, all users still have access to internet, networked printer, and external hard drive. This error message is more of an annoyance since everything seems to be working fine. Error message advises to reload software, but when I do that, I get the same error on the log in that was previously fine.

    Wireless functions with external devices are all fine also.

    Saturday, December 31, 2011 5:03 PM


All replies

  • Tried a complete uninstall, re-install, and am getting the same messages.
    Monday, January 02, 2012 12:07 AM
  • Hi,


    Which software does it suggest you reinstall?


    It seems this is an issue related to permission, please run this software installation via administrator permission.

    Alex Zhao

    TechNet Community Support

    Monday, January 02, 2012 8:01 AM
  • The Belkin Software;

    Popup 1 is:   Please re-install the Belkin software from the Setup...   Error: QLocalSocket: ConnectToServer: Unknown Error 5.   Popup 2 is:  Belkin USB Print and Storage Center.  The Belkin USB Print and Storage Center is in use.  (I have HP printer and external hard drive connected to the Belkin)   I did re-install software from my admin login.

    Monday, January 02, 2012 2:40 PM
  • Hi,


    Do you mean that you are using Belkin N750 DB Dual Band N+ Wireless Router?


    I have checked that this router is compatible with Windows 7.


    Please visit your product specific support page to check for updated Windows 7-compatible software and firmware for your product:


    Belkin : Support : Routers : N750 DB Wireless Router : F9K1103 : v1000

    Please Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Alex Zhao

    TechNet Community Support

    Tuesday, January 03, 2012 1:39 AM
  • Tried Belkin, They suggested the same thing I've been doing.    Same results.    I hope a Windows Update, or Belkin Firmware fixes this.
    Friday, January 13, 2012 1:48 AM
  • I have exactly the same issue. Firmware is up to date but I'm getting the same two errors as Dave. Any new information?
    Sunday, October 21, 2012 3:46 PM