none
How can i disable "this folder is shared with other people" message?

    Question

  • Is there a way to disable it because it keep popping up every time i delete something from shared folders and partitions.

    Thanks in advance.

    Friday, June 18, 2010 9:49 AM

All replies

  • Which folders are you getting this message on?  How many computers to you have.  Is this a home network or a corporate network?
    Friday, June 18, 2010 12:14 PM
  • Pretty much on every share folder when i erase her and it's a home network and i have two computers.
    Friday, June 18, 2010 10:47 PM
  • you can use the rd (remove directory) command in a command window. you will not be prompted with the message you are complaining about.

    You can also stop sharing a folder first before deleting it, then you will not get that prompt.

    Saturday, June 19, 2010 5:28 AM
  • First of all RD only delete empty folder meaning i should either use deltree or before using RD enter the directory and delete everything with del *.* then go out of the folder and then use RD and of course i can first disable the sharing before deleting but the point of me wanting to disable this message is to do less actions not more i want that when i press shift delete i want have press yes just because it's a shared folder it sort of loose the effect of shift delete.:)
    Saturday, June 19, 2010 7:26 AM
  • This behavior is by design. No policies or methods to disable it.
    Arthur Xie - MSFT
    Monday, June 21, 2010 8:04 AM
    Moderator
  • Then that "feature" is imbecilic. It occurs randomly on random folders. If a folder is shared, some of its subfolders will exhibit this behavior, while others won't. Attempts to un-share a subfolder usually throws additional errors. Attempting to move a subfolder within a shared folder will also throw this error.

    The corollaries to this are other false errors saying that the action can't be completed because the file or folder is open in another application, even when that is not the case, and also the error saying that a particular action can't be completed because the user doesn't have permission, even when the user is logged in with the sole administrative account on the machine.

    If an object was once open in another window or application, the lock often doesn't get released when the window or application closes. Fortunately, I have "unlocker" software, but that shouldn't be necessary, and non-technical people don't have the knowledge to find and use it.

    I find it baffling that someone at Microsoft thought these were good ideas.

    Wednesday, June 30, 2010 8:21 PM
  • This behavior is by design. No policies or methods to disable it.
    Arthur Xie - MSFT

    But it's NOT being shared with other people.  There is no folder or file *sharing* explicitly enabled on those items.  The message has nothing to do with the objects being SHARED.  It has to do with account read permissions -- which don't correspond to real people.

    So the message is not only unwanted and annoying, but it is wrong in at least 2 ways -- it's not being 'shared' (a term used when you enabled "Sharing"), nor does it have to do with other people.

    So how do we fix this problem?

     

    Sunday, July 11, 2010 11:41 PM
  • I am having similar issues. Basically there is a folder named "shared" which is a share called "networkshared" for example. Any sub dirs beneath that dir that have customised group permissions cause this to be displayed. The folders are not directly shared, they are just sub folders which have custom ACL's. This cant be by design tbh....
    http://www.edugeek.net - The I.T. Professionals life line
    Friday, August 13, 2010 3:34 PM
  • I agree. We are seeing the exact same behavior on sub-folders underneath a shared folder. Unless we're moving the actual shared folder, this message should not be displayed.
    Friday, August 27, 2010 6:49 PM
  • Are there any plans to modify this behaviour? It is truly a pain to delete directories within a network share currently. It is a change for the worse for Windows 7.
    Wednesday, November 24, 2010 2:54 PM
  • Not to bring up a dead post, but the solution is rather simple. As a matter of fact Proton2 almost had it. Use RMDIR command in command prompt to delete both the folders and files (the folder does not need to be empty) without bring up the "this folder is shared with other people" every time. RMDIR has replaced the old DELTREE from pre-XP windows.

     

     

    • Proposed as answer by m.e.e Thursday, December 16, 2010 3:37 AM
    Thursday, December 16, 2010 3:37 AM
  • not so as if u just want to move...
    roys99
    Thursday, March 10, 2011 10:14 AM
  • C:\Users\mnemonic\Documents>rmdir alpha
    The directory is not empty.

     

    Sorry bud, but the dir has to be empty.

    Saturday, March 12, 2011 11:13 PM
  • Sorry bud, but the dir has to be empty.


    RD /S /Q alpha
    Sunday, March 13, 2011 12:24 AM
  • I'm getting real fed up with "This behavior is by design" as an answer. I've found a few things that have required a fix or workaround and whenever I search for a solution, the only answer I find is "This behavior is by design".

    MICROSOFT, PLEASE STOP DESIGNING THESE STUPID/DUMB BEHAVIOURS INTO WINDOWS!

    Some of the Windows Devs really should come work in the environment I work in (School) and maybe they'll actually see how silly some of these "Features" really are.

    Rant Over.

    Thursday, April 07, 2011 9:29 AM
  • I'm getting real fed up with "This behavior is by design" as an answer. I've found a few things that have required a fix or workaround and whenever I search for a solution, the only answer I find is "This behavior is by design".

    MICROSOFT, PLEASE STOP DESIGNING THESE STUPID/DUMB BEHAVIOURS INTO WINDOWS!

    Some of the Windows Devs really should come work in the environment I work in (School) and maybe they'll actually see how silly some of these "Features" really are.

    Rant Over.

    I agree 100%.

    The development teams are completly out of touch with reality.

    Thursday, April 07, 2011 8:59 PM
  • I'm getting real fed up with "This behavior is by design" as an answer. I've found a few things that have required a fix or workaround and whenever I search for a solution, the only answer I find is "This behavior is by design".

    MICROSOFT, PLEASE STOP DESIGNING THESE STUPID/DUMB BEHAVIOURS INTO WINDOWS!

    Some of the Windows Devs really should come work in the environment I work in (School) and maybe they'll actually see how silly some of these "Features" really are.

    Rant Over.

    I agree 100%.

    The development teams are completly out of touch with reality.

    The development teams are completely out of the country. (India, China, etc.)
    Friday, April 08, 2011 4:24 AM
  • Guys, I'm running into the same problem on Windows 7.  It's NOT a shared folder thing.  It's happening to my NON-SHARED folders.  I found a solution.  I simply CUT/PASTE the darn things straight into Recycle Bin.

    So simply do this:

    1) Find Recycle Bin (hopefully it's on your Windows desktop), and double-click on it to bring it up. 

    2) Right-click and CUT all your folders you don't want.  Hold down the CTRL key for multiple folders.

    3) Paste into Recycle Bin.

     

    Problem solved.


    • Proposed as answer by GeraldCough Sunday, July 03, 2011 6:51 PM
    Friday, June 24, 2011 9:59 PM
  • This indeed is an aggravating 'feature'.  I have one folder shared, and within it hundreds of other folders, but I am trying to move  agroup of files and subfolders out of the shared folder, and it tells me for almost (not all - which also is strange) every folder that the folder is shared and waits for me to click continue.  I think i've clicked continue now about 50 times....

    Microsoft, at LEAST put a checkbox that you can click to acknowledge that you really don't want to see this message anymore.

    Almost as silly as whoever in Windows 7 thought it would be a good idea to no longer show the little hand icon indicating a folder is shared. 

    Wednesday, June 29, 2011 3:40 PM
  • I found a solution.  I simply CUT/PASTE the darn things straight into Recycle Bin.

    That worked, Kaswyn. Thank you!

    To Microsoft:

    As others have stated, this "feature", if by design, is patently absurd. If I share the root of a drive, e.g., D:, and attempt to move or delete a subdirectory that contains thousands of other subdirectories, I should not have to click "OK" on thousands of annoying dialogs (which is the current behavior).

    Again, as others have stated, the behavior is inconsistent across drives. Not all shared drives exhibit this behavior. For example, I have three shared drives (none of which are system volumes) and only one of the drives shows every single subdirectory and file with "Shared" status at the bottom of the Explorer window. I have tried un-sharing and re-sharing the drive and the behavior persists.

    • Proposed as answer by GeraldCough Sunday, July 03, 2011 6:50 PM
    • Unproposed as answer by GeraldCough Sunday, July 03, 2011 6:50 PM
    Sunday, July 03, 2011 6:50 PM
  • SOLUTION:

    The security permissions of my folders were a big mess after I moved or copied them around the network or using USB thumb drives.  To clear it up, first create a New Folder at the top level and right click on its Properties -> Security.  Observe the "Group or user names" listed.  In my case, it listed these four entries:

     

    •   Authenticated Users
    •   SYSTEM
    •   Administrators (HOSTNAME\Administrators)
    •   Users (HOSTNAME\Users)

     

    Now find a top level folder whose sub-folders were giving you trouble.  Right click its Properties -> Security -> Advanced -> Permissions -> Change Permissions...  Go through the list and delete anything that's not one of the entries above.  When you're done, check the box for "Replace all child object permissions with inheritable permissions from this object", then click Apply.  Answer Yes to confirm.  It may take a while to complete if the folder contains a lot of files and sub-folders.






    • Proposed as answer by Mulvaney Wednesday, September 07, 2011 2:59 PM
    Saturday, August 06, 2011 8:50 AM
  • Is there a way to disable it because it keep popping up every time i delete something from shared folders and partitions.

    Thanks in advance.


    DOS command worked for me... quite distructive. :-)

    Basically searches for every directory in the current folder and carries out the rmdir command including sub files and folders without prompting.

    for /D %d in (*) do rmdir /S /Q "%d"

    Steve

    First post - hope someone finds it helpful.

    Thursday, August 25, 2011 4:07 PM
  • Is there a way to disable it because it keep popping up every time i delete something from shared folders and partitions.

    Thanks in advance.


    DOS command worked for me... quite distructive. :-)

    Basically searches for every directory in the current folder and carries out the rmdir command including sub files and folders without prompting.

    for /D %d in (*) do rmdir /S /Q "%d"

    Steve

    First post - hope someone finds it helpful.


    Been fighting with this PITA "feature" for a while as well... can't stand how the system randomly selects sub-folders which are definitely not shared.  Steve, That little DOS command is extremely helpful. Many thanks.
    • Proposed as answer by ITisCool Wednesday, October 05, 2011 8:57 AM
    • Unproposed as answer by ITisCool Wednesday, October 05, 2011 8:57 AM
    Wednesday, September 07, 2011 5:06 PM
  • You need to 'Take Ownership' of the folders / files.

    Then under advanced security settings, check the 'replace all child object permissions with permissions from this object' option.

    now you should be able to delete without seeing the message.

     

    Wednesday, October 05, 2011 9:10 AM
  • I encountered this problem whilst trying to move a folder onto an external partition. What worked for me was to stop the lanmanserver service. Simply type "net stop server" at the command prompt, or stop the Server service from the Services administrative tool (run services.msc).


    • Edited by kstarsmeare Friday, January 13, 2012 7:45 PM
    Friday, January 13, 2012 7:28 PM
  • I verify that the above works, however,  if you are running from Explorer, opening a shell or going into services to stop a that service before deleting a file, is hardly a practical work-around -- not to mention, I got this when I opened my console and tried to stop things:

    > net stop lanmanserver
    These workstations have sessions on this server:

    192.168.3.1
    Do you want to continue this operation? (Y/N) [Y]: y
    The following services are dependent on the Server service.
    Stopping the Server service will also stop these services.

       Computer Browser

    Do you want to continue this operation? (Y/N) [N]: y
    The Computer Browser service is stopping.
    The Computer Browser service was stopped successfully.

    The Server service is stopping.
    The Server service was stopped successfully.

    ---

    The above DID lead me down an interesting path that will work around this problem, but I don't know what the performance impact might be.

    While playing with this some more, I noted that if I accessed my documents through C:\users\Astara\Documents, and created a folder, then tried to delete it.. I got the "this is shared" message.

    But due to having had problems with my Documents link in C:\users\Astara before, I had a short-cut on my Quicklaunch bar in Windows 7 to my Documents on the server they are located on => \\Bliss\Documents..

    I found that when I accessed it through the server link, I did NOT get the message.  So ... I wondered, what if I export 'localhost' to all 'authenticated users' (giving them r/w access, to the share, which means they get normal file mod abilities -- can export full access to administrators, too, but I was trying to do this as a 'normal user'.  ).

    Then I accessed it via \\localhost\c\users\astara\Documents...

    -- I didn't get the 'folder is share message!" 

    I think it would be 'fine' for MOST people, they wouldn't notice any minor hit going through the localhost , as it is generally called the "loopback" interface,  -- because it simply loops back to the host...(i.e. it's in software).

    So, mount \\localhost\c\ on drive 'd', and access all your documents through drive D.

    Now you could take this idea to the limit and remap your boot drive to drive 'Z', and mount the network drive at drive C, so everything would "look" normal, but that would involve alot of work to get around this MS bug that they don't care about and could fix with more simply than forcing all users to mount their local drives as network drives to get around this bug. 

    Note -- if you mount your local drive as a net work drive -- be sure in 'internet options', to put 'localhost' in your trusted zone -- so all your files won't get tagged as coming from a foreign computer. 

    I *don't think think I will normally use that method -- though I do in practice, since I normally access my Documents folder through the shortcut on my quick-launch bar. 

    What I wouldn't be sure about for the average user *if* there is a performance hit, going through the local loopback (software) interface... it might be for average PC's with 100MB/s HD's tops, no hit would be noticed, but for users getting 600+ or with raids, then the overhead might become more significant...

    So there is a 'lame' workaround if you want to go to the trouble....

     

    • Edited by Astara__ Saturday, January 14, 2012 2:06 AM
    • Proposed as answer by Astara__ Saturday, February 16, 2013 1:34 PM
    Saturday, January 14, 2012 2:02 AM
  • http://support.microsoft.com/kb/2493924

    As a workaround, the following registry key can be deleted:

    WARNING: Using Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk.

    HKEY_CLASSES_ROOT\Directory\shellex\CopyHookHandlers\Sharing

    Deleting this registry key causes the share enumeration in Explorer to be ignored while creating or renaming a folder.

    Deleting this registry key has three caveats to be aware of:

    a) The warning popup/confirmation dialog when deleting a shared folder is NO longer displayed when a shared folder is deleted.

    b) When a folder is moved, it will no longer be automatically unshared (Depending on the configuration, this might result also in an ACL change of the moved folder)

    c) Automatic Unpublish of items will no longer occur. This feature is primarily relevant only when the system is joined to a “HomeGroup” and not in an enterprise environment.

    • Proposed as answer by Astara__ Tuesday, April 24, 2012 12:04 AM
    • Unproposed as answer by Astara__ Tuesday, April 24, 2012 12:06 AM
    • Proposed as answer by John Ranger Saturday, February 16, 2013 10:44 AM
    Sunday, April 22, 2012 4:24 AM
  • I voted your reply as helpful since it is a another workaround.

    But I was wondering if you new -- does using the method I described -- of accessing the

    file/directory through \\localhost\c\users\Astara\Documents have the same

    "downsides" as you mentioned?

    I.e. -- if I move a folder C:\users\astara\documents\myprivatestuff that I realize I don't want to be shared -- and move it to C:\users\astara\unshared\myprivatestuff, are you saying it would still be shared?

    How about if I do the same moving it from (3 choices here):

    1) \\localhost\c\users\astara\documents\myprivatestuff => \\localhost\c\users\astara\unshared\myprivatestuff  (I would guess likely yes, since maybe simply ANY sharing, will trigger the problem 0-- and even if I am only sharing with 'localhost', that would still trigger the message?)

    2) \\localhost\c\users\astara\documents\myprivatestuff => C:\users\astara\unshared\myprivatestuff -- this one I am guessing wouldn't carry  the 'share' information, as it's going from a shared drive to a local directory (which presumably one has made sure isn't 'shared').

    3) and a weird one thrown into the mix .. C:\users\astara\unshared\myprivatestuff => \\localhost\c\users\astara\unshared\myprivatestuff.   This I dunno... cuz it depends on same factors of 1, that is, if you can share a directory -- ONLY with yourself, will explorer give the bogus error?  (because logged-in Administrators will always have access to the administrative share if sharing is turned on at all? -- or is that type of 'sharing' not counted by explorer?' (seems like it would be even more worthless it counted that type of sharing).   The other issue -- would it think Mysys\Astara is the same user as localhost\Astara?  I.e. if not, then it would likly think it is shared with 'another user')...

    ARG!!!!   Why did MS try to fix a problem that wasn't broken?!?!?!  I mean -- if it is under your Documents or User dir, then mabye it should be irrelevent if it is shared with other users (thus no need for a message).  Whereas if it was in /users/public or /users/all users, or "/program..." or "/windows"...then a default of giving such a message wouldn't be so annoying.

    I think the main issue here is that many people have some sort of sharing turned on in some number of their private dirs, BUT, they don't need a message each time to tell them they are deleing shared files -- it would be like someone not being able to edit a webpage without getting a message "you are about to edit a file that is shared with other users", or you about to edit your blog which is shared with other users, are you really sure you want to do that?

    Obviously , some types of sharing are for 'transient' and often updated information that one wouldn't rely on being the same or being there tomorrow -- vs. say the download site for MS updates -- if that went away, people might be a bit miffed.

    At the very least, they seemed to violate the rule of having a 'checkbox' that says (don't show me this message again)...

    Which, since it was by design (as someone above said) means they deliberately violated established standard practices for Windows 7.  I'd say the feature isn't Win7 compatible.  Maybe the 'Approved for Windows label should be removed from Win7?  ;-)

    Tuesday, April 24, 2012 12:34 AM
  • thank you that saved me the pain of clickity clickty!
    Saturday, June 16, 2012 10:18 PM
  • SOLUTION?

     In my case, it listed these four entries:

    •   Authenticated Users
    •   SYSTEM
    •   Administrators (HOSTNAME\Administrators)
    •   Users (HOSTNAME\Users)

    Now find a top level folder whose sub-folders were giving you trouble.  Right click its Properties -> Security -> Advanced -> Permissions -> Change Permissions...  Go through the list and delete anything that's not one of the entries above.



    If One were to do the above, wouldn't "Authenticated Users" (anyone who has logged in or has mounted the file remotely with a username+password, as well as all Users on the local machine also have access to the file?   I.e. -- what you are saying doesn't make sense (though it may be true -- I haven't tried it since I haven't seen that message in ages, simply accessing most of my files through network paths where it doesn't happen).   I mean -- you are sharing the files with other users, yet you say the message doesn't come up if it is only the above users?  

    That sounds like a security bug.  If it is going to alert you to others having share access to your files, but then does it sometimes, and but not for common users and those sharing your files...how is that not a security bug?

    Astara...

    Saturday, June 16, 2012 11:24 PM
  • Move that directory into Windows directory and delete from there without any prompts. Nothing inside Windows directory can't be shared so no sharing confirmation will prompt.
    Saturday, June 23, 2012 11:44 PM
  • Move that directory into Windows directory and delete from there without any prompts. Nothing inside Windows directory can't be shared so no sharing confirmation will prompt.

    That is not true.

    My entire disk is mounted on my linux box so it can make _simple_ backups...(more reliably than anything win 7 provides...)..

    Sunday, June 24, 2012 12:04 AM
  • I have to delete 10,000 student H drive folders at the end of each school year.  Clicking OK for each folder is out of the question.

    This is what works for me.

    Instead of accessing the folder share from the server it resides on, I access it from another server. Example instead of logging into Student Server and opening the M drive and opening the Grade12 share, then deleting all the subfolders . . .

    I log into Staff Server and run \\Student\Grade12, then I delete all sub folders. I do not get the irritating message that way.

    -Lauri

    Friday, June 29, 2012 8:57 PM
  • Guys,

    No moving, no reghacks, no workarounds....

    Ensure you have the appropriate rights and then just use PS as administrator.

    Remove-Item d:\Home\* -force -recurse.



    Friday, July 06, 2012 7:46 AM
  • This works for me.  I first tried to put localhost into my "Intranet" zone, but that wasn't enough, so I had to put it in my "Trusted Sites" zone and uncheck the box that says "force all sites to use https" (or something like that).

    Overall, I think the registry hack given below by site-smith is the way to go if you do a lot of moving around and deleting of items using Explorer.

    Sunday, August 05, 2012 1:57 PM
  • Pretty sick of this Behaviour by Design. I had over 700 directories to copy and this was giving me the pips.

    My solution was to plug the hard disk into a Linux PC, mount it, then cut and paste to my hearts content. Be warned, you can do anything in this mode and compromise any MS security.

    Tuesday, July 09, 2013 10:23 AM
  • http://support.microsoft.com/kb/2493924

    "HKEY_CLASSES_ROOT\Directory\shellex\CopyHookHandlers\Sharing 

    Deleting this registry key causes the share enumeration in Explorer to be ignored while creating or renaming a folder."

    Also don't forget to restart your PC before this works.

    Thursday, October 10, 2013 2:10 PM