Error when istalling Vista sp1 : "!!0xc0190002!! 1098/71883 (GameUXLegacygdfs.dll)"


  • When istalling windows vista sp1, it goes throough eveything then reboots to start unpacing files and the system hangs with this line


    "!!0xc0190002!! 1098/71883 (GameUXLegacygdfs.dll)"


    I ask microsoft, and they had me try this


    Step 1.Rename GameUXLegacygdfs.dll in WinRE
    1. Start the computer by using the Windows Vista DVD. To do this, insert the Windows Vista DVD in the computer's DVD drive, and then restart the computer.

    Note: To start the computer from the Windows Vista DVD, the computer must be configured to start from the DVD drive. For more information about how to configure the computer to start from the DVD drive, see the documentation that is included with the computer, or contact the computer manufacturer.

    2. When the "Press any key to boot from CD or DVD" message is displayed on the screen, press a key.
    3. Waiting for the CD to load Windows files.
    4. Choose your language settings, and then click Next.
    5. Click “Repair your computer” in the lower left hand corner.
    6. Select the operating system you want to repair, and then click Next.
    7. When the “System Recovery Options” dialog box appears, click on Command Prompt.
    8. Type the following command in the opening window and press Enter after each line.

    del C:\Windows\System32\GameUXLegacygdfs.dll

    Note: I assume that your system partition is C:.

    9. Please restart the computer to check if we can restart the computer well.


    After that, please manually download and install Windows Vista Service Pack 1 in Clean Boot Mode.


    Step 2.Download Windows Vista Service Pack 1 Standalone Installer
    1. Download Windows Vista SP1 from the link below according to your System Type:


    Windows Vista Service Pack 1 for Windows Vista 32-bit (Size: 434.5MB)


    Windows Vista Service Pack 1 for Windows Vista 64-bit (Size: 726.5MB)


    2. Please save it on the Desktop.


    Step 3.Install Windows Vista SP1 in Clean Boot mode
    Please disable all startup items and third party services when booting to avoid conflict when installing Vista SP1:


    1. Click "Start", type: MSCONFIG in the search box and press Enter.


    Note: Please click "Continue" if the "User Account Control" window pops up.


    2. Click "Services", check the "Hide All Microsoft Services" box and click "Disable All" (if it is not gray).
    3. Click "Startup", click "Disable All" and click "OK".


    Note: Temporarily disabling the Startup Group only prevents the startup programs from loading at startup. This shouldn't affect the system or other programs. We can manually run these programs later.


    4. Please double click the downloaded Windows Vista Service Pack 1 Standalone Installer and follow the instructions to install Windows Vista SP1.
    To restore the computer to use a Normal Startup, repeat step 1 above. Then click "Normal Startup" on the General tab, click "OK", and then restart the computer.



    But, when I tried that, but then I got this message when trying to delete that file and try to install.


    I get this error when trying to delete the gameuxlegacygdfs.dll file using the line that was givin to me from microsoft.
    del C:\Windows\System32\GameUXLegacygdfs.dll
    ERROR: The System Cannot Find the file specified
    Any help would be greatly appreaciated.
    Joe Percy
    Thursday, July 03, 2008 3:38 PM


  • Joe


    It would be much better if you continued to work with the Support Engineer who gave you those instructions.


    Have you notified them about the error you are seeing?


    If this post helps to resolve your issue, click the Mark as Answer button at the top of this message.
    By marking a post as Answered, you help others find the answer faster.

    Ronnie Vernon
    Microsoft MVP
    Windows Desktop Experience
    Thursday, July 03, 2008 11:48 PM