none
Remote Desktop help. RRS feed

  • Question

  • All -

    I'm trying to get remote desktop to work from my Vista Ultimate laptop to my XP Pro desktop.

    What is odd - is that i can remote from the XP Desktop to the Vista Laptop with no issues.  But can not remote from the laptop to the desktop.  When I attempt the connection it tries for 1-2 seconds, and then brings me right back to the main screen to put in the computer name/ip again.  It's like it does not even try.

    I have tried to disable windows firewall on both, still no luck.  I do not have any third party programs installed... and I have validated that the terminal services service is running on both PC's.  I have also validated that port 3389 is listening on both PC's.  Running the latest service pack for both versions of windows. 

    Let me know if anyone has any ideas, or if you need further information let me know.  Appreciate your time.

    -Kevin
    Sunday, January 4, 2009 10:29 PM

Answers

  •  

     

    Hi,

     

    Thank you for your posts.

     

    I know that the your can connect to your Windows Vista computer from Windows XP with Remote Desktop Protocol connection; however, connecting to the Windows XP computer from the Windows Vista computer failed.

     

    I also noticed that the message like “the identity of the remote computer cannot be verified. Do you want to connect anyways” was received. Please let me know the exact error message. Are there any other errors?

     

    If the connection works before, we can also restore the system back to the previous status when the issue didn’t occur with System Restore.

    (Note: Performing a system restore may cause the loss of the current system settings; therefore, before doing this, please make sure that the system restore point is not too old and set a restore point for the current status.)

     

    Based on my research, I would like to suggest the following:

     

    1.     Ensure the Remote Desktop Connection (Terminal Services Client) on both of the computers are up-to-date

     

    Description of the Remote Desktop Connection 6.1 client update for Terminal Services

    http://support.microsoft.com/kb/951616

     

    2.     Adjust the Authentication Level on the Windows XP side:

     

    1)    Click Start, click Run, type regedit, and then click OK.

    2)    Use one of the following methods:

     

    To modify the registry settings for all the users who log on to the computer, locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Terminal Server Client

    To modify the registry settings for only the currently logged on user, locate and then click the following registry subkey:

    HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client

     

    3)    On the Edit menu, point to New, and then click DWORD Value.

    4)    In the New Value #1 box, type AuthenticationLevelOverride, and then press ENTER.

    5)    Right-click AuthenticationLevelOverride, and then click Modify.

    6)    In the Value data box, type the value 0, and then click OK.

     

    For more information, please also refer to the following document:

     

    Vista Remote Desktop Connection Authentication FAQ: (Please note the section “How to eliminate the ‘Remote Desktop cannot verify the identity of the computer you want to connect to…’ messages”)

    http://blogs.msdn.com/ts/archive/2007/01/22/vista-remote-desktop-connection-authentication-faq.aspx#_How_to_eliminate

     

    Thanks.

     

    Nicholas Li - MSFT

     

     


    Nicholas Li - MSFT
    Wednesday, January 7, 2009 11:00 AM
    Moderator

All replies

  • You've verified that Remote Desktop is, in fact, enabled on the XP box? right-click My Computer > Properties > 'remote' tab.
    The user account on the XP machine (that you're using to log in) does have a password, yes?
    [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Sunday, January 4, 2009 10:36 PM
  • Yes, the XP computer has the allow users to connect to this machine selected.... and the one account for it does have a password required for login.
    Sunday, January 4, 2009 10:39 PM
  • If i disable it on the XP machine, it actually takes 6-7 seconds to attempt to login and then comes back and tells me it can not connect to the remote computer.  With it enabled it only takes 1-2 seconds - doesn't give me a message just puts me back to where I can click connect again but does not establish the connection.
    Sunday, January 4, 2009 11:00 PM
  • Try this:
    On the Vista box, open Remote Desktop.  Click the 'Options >>' button, and open the Advanced tab.
    See what the pulldown menu in the Server authentication field is set to (I'm betting that it's set to "Don't connect"); change it to "Connect and don't warn me."
    [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Sunday, January 4, 2009 11:02 PM
  • Messed with that earlier - its set to warn me... I've tried connect and dont warn me as well.  I do get the message that the identity of the remote computer can not be verified. Do you want to connect anyways - to which I choose yes.

    One other thing I will note is when i click the drop down box for the computer and browse for more, and expand the workgroup it says the workgroup domain/workgroup does not contain any Terminal servers.  I noticed the XP computer was attached to a different workgroup name - so I moved it to the same workgroup as the laptop, but still no joy.
    Monday, January 5, 2009 12:17 AM
  • <<One other thing I will note is when i click the drop down box for the computer and browse for more, and expand the workgroup it says the workgroup domain/workgroup does not contain any Terminal servers. >>
    That's normal for a Workgroup enviroment.  Unless you're running a Windows Server domain at home, you aren't going to have any TS Servers there (this is different from RDP.)

    Question:
    Do you have SP1 installed on the Vista box?
    [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Monday, January 5, 2009 1:07 AM
  • Yes, SP 1 on Vista, and SP3 on the XP system.
    Monday, January 5, 2009 1:44 AM
  •  

     

    Hi,

     

    Thank you for your posts.

     

    I know that the your can connect to your Windows Vista computer from Windows XP with Remote Desktop Protocol connection; however, connecting to the Windows XP computer from the Windows Vista computer failed.

     

    I also noticed that the message like “the identity of the remote computer cannot be verified. Do you want to connect anyways” was received. Please let me know the exact error message. Are there any other errors?

     

    If the connection works before, we can also restore the system back to the previous status when the issue didn’t occur with System Restore.

    (Note: Performing a system restore may cause the loss of the current system settings; therefore, before doing this, please make sure that the system restore point is not too old and set a restore point for the current status.)

     

    Based on my research, I would like to suggest the following:

     

    1.     Ensure the Remote Desktop Connection (Terminal Services Client) on both of the computers are up-to-date

     

    Description of the Remote Desktop Connection 6.1 client update for Terminal Services

    http://support.microsoft.com/kb/951616

     

    2.     Adjust the Authentication Level on the Windows XP side:

     

    1)    Click Start, click Run, type regedit, and then click OK.

    2)    Use one of the following methods:

     

    To modify the registry settings for all the users who log on to the computer, locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Terminal Server Client

    To modify the registry settings for only the currently logged on user, locate and then click the following registry subkey:

    HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client

     

    3)    On the Edit menu, point to New, and then click DWORD Value.

    4)    In the New Value #1 box, type AuthenticationLevelOverride, and then press ENTER.

    5)    Right-click AuthenticationLevelOverride, and then click Modify.

    6)    In the Value data box, type the value 0, and then click OK.

     

    For more information, please also refer to the following document:

     

    Vista Remote Desktop Connection Authentication FAQ: (Please note the section “How to eliminate the ‘Remote Desktop cannot verify the identity of the computer you want to connect to…’ messages”)

    http://blogs.msdn.com/ts/archive/2007/01/22/vista-remote-desktop-connection-authentication-faq.aspx#_How_to_eliminate

     

    Thanks.

     

    Nicholas Li - MSFT

     

     


    Nicholas Li - MSFT
    Wednesday, January 7, 2009 11:00 AM
    Moderator
  • Hi, I just wanted to say that Nicholas Li's answer was the one that helped me, so Thank You very much Nicholas!

     

    I was trying to use Remote Desktop to connect my XP SP3 laptop to my Windows 7 Ultimate desktop and I kept getting the 'Remote Desktop Disconnected' error message: "The two computers couldn't connect in the amount of time allotted".

     

    This was driving me crazy because I had connected them previously and (besides Windows updates) I couldn't see what had changed. But no matter what I tried I just kept getting this error message. The other weird thing that was happening was that whenever I tried to the remote computer (Win7) it would knock that computer off my network! Completely off, no network address, network adapter disconnected!!!

     

    In any case making that change to my XP laptop's registry fixed the problem.

     

    I'm guessing that the registry change forces Remote Desktop to ignore the fact that the authentication seems too be wrong. I noticed that Remote Desktop client (on my laptop) complained that the machine name was not correct and the certificate was not valid. Somehow this change rides roughshod over the credentials.

     

    Maybe somebody out there could explain this better please! What does this registry tweak actually do?

     

    Whatever it did, thanks!!!

     

    Alan

    Wednesday, November 17, 2010 10:45 PM
  • UPDATE:

    I still had a problem with the Remote Desktop and was still getting the message that the two computers couldn’t connect in the amount of time allocated.

    So I checked the Event viewer of the machine that is remoting in (my XP laptop):

    Look to see if there are any messages with a red cross beside them. In my case I had:

     

    Event Type: Error

    Event Source: Service Control Manager

    Event Category: None

    Event ID: 7001

    Date: 24/11/2010

    Time: 19:11:19

    User: N/A

    Computer: HP

    Description:

    The Remote Access Connection Manager service depends on the Telephony service which failed to start because of the following error: 

    The service cannot be started, either because it is disabled or because it has no enabled devices associated with it. 



    This gave me my hint that not all the services connected with remote desktop were as they should be. So check to see:

    Are all of the remote services enabled and running?

    Is the telephony service enabled and running?


    I wasn’t too sure which of these had to running and which of these didn’t matter so I enabled the lot of them, not very scientific, but now my Remote Desktop works, maybe somebody cleverer than me can put me straight on what services are needed on the remote machine.


    I hope this helps other people who are getting the “Remote Desktop Disconnected. The two computers couldn’t connect in the amount of time allocated” error message.


    Wednesday, November 24, 2010 8:39 PM