A win7 PC as an ISATAP host, send the wrong packet with checksum==0, what shall i do?


  • I find that in my Windows 7, the IPv4 packet in which a IPv6 packet is encapsulated   always has some issues. That is, the Checksum value is 0 in IPv4 header.

    Could you tell me how can I send the right packets? I need to set up a ISATAP tunnel from a Win7 PC to an ISATAP router.

    (Sorry, I can't send the image cause i havent the right)

    Monday, November 26, 2012 3:22 PM

All replies

  • Hi,

    I would like to know where did you see the checksum is 0 in IPv4 header?

    And, could you please let me know which impact you get when you found the checksum value is 0. Based on my knowledge, there is one known-issue may be related to yours. Please try disabling the ikev2 on the rras server.

    1. Create the registry key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\RasMan\IKEv2 
    2. Create a REG_DWORD value “Disabled” and set it to 1. 
    3. Restart the services rasman and remoteaccess 


    Best Regards,


    Wednesday, November 28, 2012 9:50 AM