SharePoint Search Service Application Administration Page Not Loading RRS feed

  • Question

  • Hi,

    I have a SharePoint search Service Application running fine for a long time. Recently we noticed that when accessing the Search Administration page, it just keeps on loading without completion. The "loading..." indicator under "System Status", "Crawling History" and "Search Application Topology" just keeps spinning.

    When I tried to access the "Content Sources" link, I got an error page saying





    I saw these messages in the ULS log

    [1] SearchApi (): invalid parameter databaseConnectionString
    [2] System.ArgumentException: databaseConnectionString   
     at Microsoft.Office.Server.Search.Administration.SearchApi.AssertParameter(String parameterName, Boolean condition)   
     at Microsoft.Office.Server.Search.Administration.SearchApi..ctor(String applicationName, String databaseConnectionString, Boolean native)   
     at Microsoft.Office.Server.Search.Administration.SearchApiFactory.CreateSearchApi(String applicationName, String databaseConnectionString)   
     at Microsoft.Office.Server.Search.Administration.SearchServiceApplication.get_SettingsSearchApi()   
     at Microsoft.Office.Server.Search.Administration.AdminComponent.Refresh()   
     at Microsoft.Office.Server.Search.Administration.SearchComponent.EnsureRefresh()   
     at Microsoft.Office.Server.Search.Administration.SearchServiceApplication.get_AdminComponent()   
     at Microsoft.Office.Server.Search.Administration.SearchApi..ctor(SearchServiceApplication application)   
     at Microsoft.Office.Server.Search.Administration.SearchServiceApplication.get_SearchApi()   
     at Microsoft.Office.Server.Search.WebControls.SearchApplicationSystemStatus.GetStatusString(SearchServiceApplication searchApp)   
     at Microsoft.Office.Server.Search.WebControls.SearchApplicationSystemStatus.BindContentToTable(Int32 pageNumber, Table contentTable)


    Please share your inputs/suggestions if you have experienced before.

    Thank you,


    Friday, January 20, 2017 3:22 AM

All replies

  • Hi ken,

    Please make sure the Search services are running.

    Central Administration > Manage Services on server > Check if the search services are running.

    In addition, do an IISRESET and then check whether it works.

    Best Regards,

    Linda Zhang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact

    Monday, January 23, 2017 9:34 AM
  • Hi Linda, Thanks for the response. I did a few times before IISRESET but still can't bring it up. Search services are running. Any advice on how to furthe troubleshoot? Thanks
    Tuesday, January 24, 2017 10:49 AM
  • You could try clearing the Configuration Cache, see below: 

    1. Stop the Windows SharePoint Services Timer service (Found in Windows Services)
    2. Navigate to the cache folder
    3. In Windows Server 2008, the configuration cache is in the following location:
    4. Drive:\ProgramData\Microsoft\SharePoint\Config
    5. Locate the folder that has the file “Cache.ini”
    6. Back up the Cache.ini file.
    7. Delete all the XML configuration files in the GUID folder. Do this so that you can verify that the GUID folder is replaced by new XML configuration files when the cache is rebuilt.
    8. Note When you empty the configuration cache in the GUID folder, make sure that you do not delete the GUID folder and the Cache.ini file that is located in the GUID folder.
    9. Double-click the Cache.ini file.
    10. Select the entire contents of the Cache.ini file and delete it, replacing all the text with the number ’1′. Save the file and close
    11. Start the Windows SharePoint Services Timer service
    12. Note The file system cache is re-created after you perform this procedure. Make sure that you perform this procedure on all servers in the server farm.
    13. Make sure that the Cache.ini file in the GUID folder now contains its previous value. For example, make sure that the value of the Cache.ini file is not 1.


    From <

    Tuesday, January 24, 2017 1:51 PM
  • Hi,

    Yes, tried clearing the configuration cache but didn't work for me. Got idea where the value of "databaseConnectionString" is taken from?

    Best Regards,


    • Edited by keny2010 Thursday, January 26, 2017 4:38 AM
    Wednesday, January 25, 2017 1:16 AM
  • Hi Ken,

    Please check the system event log for group policy changes that may have occurred around the same time as the search errors. Determine if any group policies have altered permissions on 'WSS_WPG', or 'WSS_ADMIN_WPG groups'.

    Best Regards,

    Linda Zhang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact

    Wednesday, February 1, 2017 2:37 AM
  • Hi Linda,

    There were GPO updates in the past but its very difficult to pinpoint what were those changes as the GPO is not within our control (managed by a different team).

    Could you share what are the common policies on the server pertaining to the "WSS_WPG" and "WSS_ADMIN_WPG"? I will check it on the servers.



    Thursday, February 2, 2017 2:49 PM
  • Hi Ken,

    All application pool and services accounts are in WSS_WPG.

    The application pool accounts for the Central Administration and Timer services are in WSS_ADMIN_WPG.

    For more information about account permissions and security settings in SharePoint 2013, you could read the following article:

    Best regards,

    Linda Zhang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact

    Friday, February 3, 2017 1:34 AM
  • Noted. I checked all service accounts are inside WSS_WPG and WSS_ADMIN_WPG groups.

    From the error message its stated "databaseConnectionString" is invalid. Where does search service app retrieve the value for this parameter? Is it from the registry? so i can check the permissions.


    • Edited by keny2010 Friday, February 3, 2017 4:36 AM for clarity
    Friday, February 3, 2017 2:50 AM
  • Hi,

    Is the issue reported for your production farm or a staging\development farm??.

    Does your servers have adequate resources??? Sometimes resource choking might cause such an issue. This problem may occur because no memory can be allocated to the new connection. Also please do check if the TCP\IP service is enabled in your SQL configuration manager.

    Recently have you made any changes to the web.config file for the CA site??

    If the issue persists and if this is not your production farm please try re-creating the search service.

    Friday, February 3, 2017 6:27 AM
  • Hi,

    This is happening on staging farm.

    • Resource utilization are still normal.
    • Not sure if its related to TCP/IP service in SQL Configuraiton Manager or else connection to content dbs, configuration dbs and service app dbs would have failed. Correct me if I am wrong.
    • So far only noticed this issue for this search service app.
    • There were no changes in the CA web.config too.



    • Edited by keny2010 Friday, February 3, 2017 10:09 AM
    Friday, February 3, 2017 10:07 AM
  • Was there a solution to this problem in the end? I having the exact same issue.



    Monday, October 21, 2019 3:46 PM