none
Windows Update and Trusted Installer problem - high disk activity slows my PC to a crawl

    Question

  • I am not sure what happened but a few weeks ago my PC started to run very slowly and the disk light came on permanently.  I have traced it to Windows Update and the Windows Module Installer (TrustedInstaller).

    In summary if I switch both services to manual the PC works fine while the services are stopped.  If I try to run Windows Update, the Windows Update service starts and TrustedInstaller attempts to start but the service says it is "Starting" without ever getting to "Started" and the disk light comes on permanently and the PC slows to virtual stop.   I get a similar result if I try to go to the add or remove Windows Components in Control Panel.

    I cant Restore the system because all the restore points have disappeared and I dont want to reinstall Windows as the system runs fine apart from Windows Update and Trusted Installer.  I have tried running Windows Update overnight but that doesnt seem to work and have tried replacing TrustedInstaller in case that was corrupted.  I have also tried various other suggested solutions on the net, none of which have made the situation worse (which is a bonus) but they havent solved the problem either.

    Nothing seems to work.  What I assume I need to do is uninstall then reinstall both elements of Windows 7.  Does anyone have any bright ideas how to do that?

    I have Windows 7 Home Premium x64 6.1.7600

    Tuesday, November 23, 2010 10:14 PM

All replies

  • Do you have a lot of Programs installed which use the Microsoft Installer (MSI) and use MSP patches? The WindowsUpdate service scans all those MSI/MSP files.

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Wednesday, November 24, 2010 1:39 PM
  • Andre

    Thanks for the response.  The short answer is I dont know.  How would I find out?

    Wednesday, December 01, 2010 1:02 PM
  • One other question in relation to this topic which someone may be able to help me with - is it possible to get Windows Update and TrustedInstaller to output a log of what they are up to which might tell me what they are attempting to do when they get stuck?

     

    Also is it possible to reinstall Windows Update?


    Matthew Flinton
    Saturday, December 04, 2010 8:07 PM
  • I am not sure whether anyone is reading this but for the benefit of those that may have the same problem I have tried to reinstall a program (Acronis TrueImage 2010) and got the following message:

    An error occurred during the installation of assembly 'Microsoft VC80.CRT.publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="8.0.50727.762",processorArchitecture="x86"

    When I went to their website I got this message:

    This is a Windows issue

    This article applies to:

    • Acronis True Image Home 2011
    • Acronis True Image Home 2010

    Symptoms

    An attempt to install Acronis True Image Home 2011 or Acronis True Image Home 2010 fails with an error similar to the following one:

    An error occurred during the installation of assembly
    'Microsoft.VC80.CRT,publicKeyToken="1fc8b3b9a1e3b",type="win32",version="8.0.50727.762",processorArchitecture="x86"'.
    Please refer to Help and Support for more information.

    Cause

    This is an issue with your Windows operating system which is unable to install the redistributable components of C Runtime. For example, installation of Microsoft Visual C++ 2008 Redistributable Package (or similar) will fail in the same way.

    Solution

    To fix the issue, please run Windows System File Checker:

    (!) You will need to have Windows Installation Disc to run the utility. It is strongly recommended to boot from the disc to run the system file check. See also Microsoft Knowledge Base Article 929833.

    1. Hit Start-Run and type in cmd
    2. In the command line, issue the following command:

      sfc.exe /scannow

    This will check the system for corruption and repair the corrupted system files from the Windows Installation Disc.

    More information

    If the issue persists, please contact Microsoft Support since this is a Windows issue and may result in difficulties with installation of other applications as well.

    This is something I have tried before but I will have another go.  However I do have a problem because my PC (an Acer Aspire) didnt come with an installation disk but some sort of partition so I will need to work out how that works first.  If anyone out there has any top tips they would be welcome.

     


    Matthew Flinton
    Sunday, December 05, 2010 10:00 AM
  • I have now tried this (without booting from the Windows Installation disk) and got the following message:

    Windows Resource Protection could not start the repair service.

    Presumably I now need to try it again having booted from the Windows Insallation Disk I dont have. 

     


    Matthew Flinton
    Sunday, December 05, 2010 10:56 AM
  • I am inching forward.

    It appears that I can order a Windows Installation disk from Acer which will presumably cost me a bit but may be worth while as an investment for the future.

    The laptop has a recovery programme called Aer eRecovery which if I get desparate will take it back to factory settings but deletes all my programmes and/or user data depending which option I choose.

    It appears I can use a full Microsoft Windows 7 Installation disk if I can borrow one from someone else, does anyone know if this is right?

    Finally does anyone know if is possible to create the clean Windows installtion disks from the recovery partiion which I could then use?


    Matthew Flinton
    Sunday, December 05, 2010 12:14 PM
  • Windows Resource Protection could not start the repair service.

    Have you disabled the trusted installer now? this would cause the error message.

    And no, you can't create a clean DVD from a recovery DVD.

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Sunday, December 05, 2010 2:32 PM
  • Andre

    Thank you. I have set the service to manual so presumably it should start if it was working.

    So it looks like my options are to buy an installation cd or find someone else who has a Microsoft one for Windows 7 x64.


    Matthew Flinton
    Sunday, December 05, 2010 6:15 PM
  • here is the ISO to the x64 HP:

    http://msft-dnl.digitalrivercontent.net/msvista/pub/X15-65733/X15-65733.iso

    Burn a new DVD from it.


    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Sunday, December 05, 2010 8:00 PM
  • Thanks Andre I will give this a go and post the results here.
    Matthew Flinton
    Sunday, December 05, 2010 8:25 PM
  • Right following a bit of a delay (I have been busy up to Christmas) this the latest small steps forward (I hope), but no solution yet.

    Results so far:

    - ISO image downloaded

    - ISO image burnt to DVD using IMGBURN http://www.imgburn.com/

    - Had to change boot order in BIOS (I have to press F2 to get into it) to put the DVD to boot before the hard disk

    I now get the option to boot from DVD which works.  However it doesnt do what I was expecting.  I thought the system would start as normal just running from the DVD as this is what is implied from the Microsoft Knowledge Base Article I quoted on 5th December 2010.

    That is not what happens I get the option to install Windows 7 or repair my existing installation.  I have tried repairing the existing installation although when I boot from DVD it says my installation is on D:\ACER when normally it is on C:\ACER.  I tried to repair it anyway but it didnt seem to do anything, I just got a message to disconnect any device I have recently connected.  I havent recently connected anything as the laptop has nothing more connected to it that when it came out of the box.

    I do have an option to start a Command Prompt from the list of options I get when I boot from CD.  I am tempted to open one and run "sfc.exe /scannow" from that prompt.  Does anyone know if that is the right thing to do?

     


    Matthew Flinton
    Sunday, January 02, 2011 5:34 PM
  • Hi Matthew,

    I have a similar problem after installing Windows 7 (Home Premium) updates KB2522422/2492386/2506928/982018 which were published April 26/11.  The updates failed, and from then on my computer has  been exhibiting similar symptoms, although my hard drive light usually goes off after about 11 hours.  When the hard drive light is on, the system is so slow it's almost frozen.  It does this if I reboot, or also, seems to happen if I run a program that reads a lot of data, such as chkdisk or a virus scan.  SFC won't run, it stops at 5% and says "Windows Resource protection could not perform the requested operation".  I've tried two different system resotres, which says they are successfull, but the problem wasn't solved.  I have downloaded the updates directly from the microsoft site in a certain order as suggested in some threads, they installed sucessfully but it didn't fix the problem.  I've also tried the Microsoft Safety scanner which showed no infections.

     

    I'm wondering if you ever came up with a solution to your problem?  

     

    I'm running Windows 7 home premium.  Toshiba Qosmio F60, with 650 gig hard drive and 6 gig of Ram.  I have AVG free edition installed.

     

    Thanks, Gerri

    Wednesday, May 04, 2011 7:57 PM
  • I did but I took it to my local PC repair shop who sorted it out for me I am afraid however I took the disk and I think they reinstalled the installer program.  Sorry not to be more help.
    Matthew Flinton
    Saturday, May 07, 2011 12:08 PM
  • FAO GerS,

     

    Toshiba has one or two drivers which are specifically written to enable correct communication between parts of the hardware.  I have a Sony Vaio and have problems where on disabling and re-enabling some services has caused windows to load it's own drivers.  The most notable one concerns disabling the uPNP sercice, X-IP, SSDP.  and FDPHost.  I then have to ensure the driver package from Texas instruments is reinstalled to enable the correct functioning of my memory card readers.  I am wondering if you have a driver issue at the heart of your problem with the update service?

    Check in hardware management to see if you have any yellow triangles exclaimations, also worth checking all sevices are at their default settings using BlackViper's website.

    OEM manufacturer drivers can be critical, though in the case of Sony's DMIcCall.sys (Northbridge/Southbridge IO driver's signing running out of date in 2006) sometimes they too can boob.  Your windows event log may also be of value in determining your problem.

    It may also be worth drilling down into your registry and checking to see if the failed installation left some clean-up files outstanding.  If the installation fails it should automatically roll back the failure, in rare instances it will fail to do so.  This will account for failure of the restore function to function properly as it too will be suspended until it receives the clear signal to continue with normal operations.

    Older Vista hands may remember some of these problems with the SP2 installation with the only solution being a standalone updated 4.5 installer being applied manually before the service pack could be installed.

    If you have sufficient memory it may also be a good idea to clear down your pagefile, reboot twice, then re-enable it before attempting a fresh installation attempt.

    Don't forget, in some very rare occasions antivirus software can interfere with the correct functioning of installers installing to protected locations.  If in doubt set your application control function in AVG to ignore any actions by the windows installer service, (I presume this is because the monitoring software sometimes thinks the installation is rootkit behaviour and should be blocked).  Worth checking your application control logs in AVG to see what it recorded on the failed installation.

    Saturday, June 18, 2011 5:27 AM
  • I got the exact same symptom yesterday and also found out that "Windows Modules Installer" was stuck as "Starting".  I set it to "Disabled" and rebooted my computer.  It's fine now.

    I wanted to uninstall an application ("MyPhoneExplorer") and it crashed while trying to unregister an OCX.  Perhaps this corrupted something used by 'Windows Modules Installer'.  At least now, my system is back to normal, but I'm investigating further.

    Tuesday, September 18, 2012 11:47 AM