none
Hyper-V Windows 8 CPU power management problem

    Question

  • Hello,

    I have just installed Windows 8 on my home HP Microserver with AMD n36l CPU integrated. After installation of Hyper-V module, the PowerNow cpu management has stopped working. In Control Panel / Power Management I don't see CPU scaling options and the CPU is still running at highest frequency. When I remove Hyper-V, the frequency changes without any problem and it is manageable through power management. 

    Information exposed to operating system during boot:

    Processor 0 in group 0 exposes the following power management capabilities:
    Idle state type: ACPI Idle (C) States (1 state(s))
    Performance state type: ACPI Performance (P) / Throttle (T) States
    Nominal Frequency (MHz): 1300
    Maximum performance percentage: 100
    Minimum performance percentage: 61
    Minimum throttle percentage: 61

    Does anybody has similar problem? Is there some workaround?

    Thank you for any answer

    Petr Janousek

    Saturday, September 01, 2012 2:56 PM

Answers

  • So, there is some bug with Hyper-V in Windows 8 and CPU power management. On the same hardware with Windows Server 2008 R2 is everything OK.

    • Marked as answer by Petr Janousek Wednesday, September 05, 2012 1:50 PM
    Wednesday, September 05, 2012 1:50 PM

All replies

  • Hello,

    I am sorry, but have you read my question? Power Management is working without Hyper-V enabled! BIOS is configured correctly. My questin was, if somebody else has problem with Power Management with Hyper-V enabled too. OK, I will test it myself.

    Thank you for your help.

    Petr

    Sunday, September 02, 2012 7:43 PM
  • This always happen if you install Hyper-V. Use VMware or Virtualbox if you need Power saving options.

    Becasue of this, enabling Hyper-V fix freezing issues in the PR. No Power saving = no freezes.


    "A programmer is just a tool which converts caffeine into code"

    Sunday, September 02, 2012 8:48 PM
    Answerer
  • OK, I have tested it on my laptop, so it is maybe generic behavior of Hyper-V (It disables CPU power management). I have Intel i5 on laptop so it is not just about AMD.

    I am not sure how it was working with WinSrv 2008 R2. If Hyper-V cannot use a CPU Power Management, so it is quite useless on PCs :o( 

    Sunday, September 02, 2012 11:27 PM
  • So, there is some bug with Hyper-V in Windows 8 and CPU power management. On the same hardware with Windows Server 2008 R2 is everything OK.

    • Marked as answer by Petr Janousek Wednesday, September 05, 2012 1:50 PM
    Wednesday, September 05, 2012 1:50 PM
  • Hello there,

    I've just done a test with the Performance Analyzer. If you look at Hyper-V Logical Processor -> %Maximum clock frequency, you will see it fluctuate along with the workload. Therefore I seems that the bug -- if there is one -- is with Task Manager and Resource Monitor and not with the system itself.

    /Ben

    • Proposed as answer by BenoitD Wednesday, September 05, 2012 2:14 PM
    Wednesday, September 05, 2012 2:11 PM
  • I can confirm this is happening with Windows 8 Enterprise RTM with the Hyper-V role installed.

    Dell E6430 BIOS A03 (current as of September 6th, 2012)

    Intel 3rd Gen Core i5-3210M

    SpeedStep Enabled in BIOS

    CPU power state and throttle down working fine as verified with Task Manager without the Hyper-V role installed.  Intel Turbo Boost also functioning fine without Hyper-V role installed.

    With the Hyper-V role installed the CPU speed as reported in Task Manager stays at the Maximum speed regardless. Intel Turbo Boost not functioning either as reported by Task Manager.

    As noted earlier, the bug could be with Hyper-V or maybe Task Manager itself.  Just here to confirm the behavior.

    -Weaver
    • Edited by WeaverVS Friday, September 07, 2012 2:40 AM
    Friday, September 07, 2012 2:39 AM
  • In other words, the fact that Task Manager always shows maximum CPU speed (after the @ sign) does absolutely not mean that the CPU really runs at maximum speed al the time, correct?


    Well this is the world we live in And these are the hands we're given...

    Friday, September 07, 2012 8:38 AM
  • This information is good but still not answering Petr's question or mine since I am experiencing the same thing with my Intel i5 processor.  I would like to know why this issue is occurring and if or when something might be done to fix?  I don't think we should settle for "that is how it works" when task manager is not showing the user the real utilization/power management.  Thanks for looking into this MVP/Microsoft.
    Sunday, September 09, 2012 1:14 PM
  • You have to look at the value "Speed", not "maximum speed".

    "A programmer is just a tool which converts caffeine into code"

    Sunday, September 09, 2012 7:26 PM
    Answerer
  • The same behavior on Windows Server 2012: after Hyper-V role is added, the CPU clock speed runs at maximum even with no server load. Probably there is no a Task Manager display issue as CPU temperature rise too.
    Thursday, September 20, 2012 7:31 AM
  • I have experienced the same behavior with Windows 8 RTM. 

    I have a workstation with two 16 core 6272 2.1GHz Opterons.  Without Hyper-V, almost all the cores park and the processors idle at 700mhz - 1.4 ghz and the machine consumes 85 watts.  Turbo mode works perfectly, pushing the processors routinely to 3Ghz so long as only half the cores are busy.  Between 50% and 100% load, the machine runs at 2.5 - 2.1 Ghz.  Power management is working as it should; however, once the Hyper-V role is enabled, all cores are pegged at 2.1 Ghz and idle power usage soars to 185 watts.  Cores never boost beyond 2.1 Ghz and also never idle to lesser frequencies.  As you watch Task Manager, CPU processing jumps around all 32 cores.  So at idle, every core is slightly busy yet at peak frequency.  This behavior stays even after multiple reboots over multiple days.

    Removing the Hyper-V Role sets everything back to normal, power management is restored, turbo mode works again, and idle power usage returns to 85 watts. 

    I have been forced to fall back to using the less ideal type 2 hypervisor VMWare Player and Workstation to run my virtual machines.

    I have been hoping for a Windows Update patch to resolve this power mangement / thread scheduler issue; but i have not seen any yet....

    Sunday, September 30, 2012 9:12 PM
  • I have the same issue with my Dell Precision 6600 with latest BIOS-A12, I7-2820QM CPU w/ four cores/8 logical cores. Speed step is enabled. NVidia Quadro 3000M video controller.

    Any thoughts?

    Thanks,


    MWfor64bit

    Friday, October 05, 2012 2:16 PM
  • @Andre.Ziegler

    >You have to look at the value "Speed", not "maximum speed".

    Why? I was indeed to stress that Speed value here is always equal to Maximum speed meaning that CPU clock never falls back and works at its maximum (according to what taskman is showing). Or am I getting it wrong?


    Well this is the world we live in And these are the hands we're given...

    Wednesday, October 10, 2012 6:37 PM
  • I am experiencing this issue as well both in the Enterprise and personal environments. Multiple servers/workstations with Windows Server 2012. Any thoughts?
    Wednesday, October 17, 2012 4:23 AM
  • @Andre.Ziegler

    >You have to look at the value "Speed", not "maximum speed".

    Why?

    because "Speed" is the current CPU clock and this is what you want to know.

    "A programmer is just a tool which converts caffeine into code"

    Monday, October 22, 2012 9:04 AM
    Answerer
  • I can also confirm the negative effect of Hyper-V on my Toshiba Satellite R830 notebook with Intel Core i5-2410M (BIOS 3.90 / EC 1.60 version).

    At first I suspected the BIOS update I performed today or the Intel Chipset Driver update, but then it turned out clearly that installing Hyper-V on Windows 8 Pro (64-Bit) is causing the "Processor Power Management" options (with "Maximum" and "Minimum Processor State" % values) to disappear. After deinstalling Hyper-V, the "Processor Power Management" options are back.

    However, it is not clear yet if this is a bug in the Hyper-V environment or in the drivers.

    • Edited by magicaster Sunday, November 25, 2012 10:34 PM
    Sunday, November 25, 2012 10:32 PM
  • Same problem.  Windows 8 w/ Hyper-V on my Toshiba i5 M430 laptop.
    Wednesday, November 28, 2012 2:26 PM
  • Hello,

    I have just installed Windows 8 on my home HP Microserver with AMD n36l CPU integrated. After installation of Hyper-V module, the PowerNow cpu management has stopped working. In Control Panel / Power Management I don't see CPU scaling options and the CPU is still running at highest frequency. When I remove Hyper-V, the frequency changes without any problem and it is manageable through power management. 

    Information exposed to operating system during boot:

    Processor 0 in group 0 exposes the following power management capabilities:
    Idle state type: ACPI Idle (C) States (1 state(s))
    Performance state type: ACPI Performance (P) / Throttle (T) States
    Nominal Frequency (MHz): 1300
    Maximum performance percentage: 100
    Minimum performance percentage: 61
    Minimum throttle percentage: 61

    Does anybody has similar problem? Is there some workaround?

    Thank you for any answer

    Petr Janousek

    DON'T WORRY! TESTED ON A I7 LAPTOP AND FOUND OUT BY READING FREQUENCIES THAT ALTHOUGH IT DISABLES YOUR POWER MANAGEMENT FEATURES, IT DOESN'T AFFECT TURBO BOOST. I HAVE A WORKAROUND FOR THOSE WHO WANT TO HAVE A POWER SAVING PROFILE OR "STEP DOWN PROFILES":

    BEFORE ENABLING HYPER-V(OR IF YOU HAVE IT ENABLED GO TO CONTROL PANEL>>>UNINSTALL A PROGRAM>>>TURN WINDOWS FEATURES ON OR OFF>>>UNCHECK THE HYPER-V BOX>>>OK,IT MAY NEED A REBOOT) CREATE POWER MANAGEMENT PLANS FROM THE POWER MANAGEMENT SECTION IN CONTROL PANEL. FOR EXAMPLE I HAVE 5 POWER PLANS, 2 POWER SAVERS, 1 BALANCED, AND 2 HIGH PERFORMANCE ONES- ONE THAT ALLOWS "FULL THROTTLE", I MEAN MAXIMUM PERFORMANCE, AND ONE THAT PREVENTS OVERHEATING, THAT NEEDS TURBO BOOST OFF.THIS IS DONE BY SETTING MAXIMUM ALLOWED PROCESSOR USAGE TO 99% IN THE ADVANCED SETTINGS,SO THAT YOU DON'T HAVE TO GO TO THE BIOS SETTINGS ALL THE TIME.---THEN ENABLE HYPER-V, AND SWITCH BETWEEN THE PLANS YOU'VE JUST CREATED.

    PLEASE NOTE THAT THE TASK MANAGER WILL ONLY SHOW THE BASE FREQUENCY OF YOUR PORCESSOR, ALTHOUGH UTILITIES LIKE HWINFO, INTEL XTREME TUNING UTILITY, AND TURBO BOOST MONITOR FROM INTEL WILL SHOW THE REAL CLOCK FREQUENCY. THERE IS PROBABLY A BUG IN THE TASK MANAGER, OR MAYBE THE PERF COUNTERS FOR TURBO BOOST ARE DISABLED OR SOMETHING.

    • Proposed as answer by NJOKER Thursday, November 29, 2012 7:59 AM
    Thursday, November 29, 2012 7:42 AM
  • HI,

    I also faces the same problem. I need Hyper V because I am Windows Phone Developer and the Windows Phone emulator uses Hyper-V for Device Virtualization.

    Thanx

    Saturday, December 08, 2012 10:39 AM
  • Hello,

    I have just installed Windows 8 on my home HP Microserver with AMD n36l CPU integrated. After installation of Hyper-V module, the PowerNow cpu management has stopped working. In Control Panel / Power Management I don't see CPU scaling options and the CPU is still running at highest frequency. When I remove Hyper-V, the frequency changes without any problem and it is manageable through power management. 

    Information exposed to operating system during boot:

    Processor 0 in group 0 exposes the following power management capabilities:
    Idle state type: ACPI Idle (C) States (1 state(s))
    Performance state type: ACPI Performance (P) / Throttle (T) States
    Nominal Frequency (MHz): 1300
    Maximum performance percentage: 100
    Minimum performance percentage: 61
    Minimum throttle percentage: 61

    Does anybody has similar problem? Is there some workaround?

    Thank you for any answer

    Petr Janousek

    DON'T WORRY! TESTED ON A I7 LAPTOP AND FOUND OUT BY READING FREQUENCIES THAT ALTHOUGH IT DISABLES YOUR POWER MANAGEMENT FEATURES, IT DOESN'T AFFECT TURBO BOOST. I HAVE A WORKAROUND FOR THOSE WHO WANT TO HAVE A POWER SAVING PROFILE OR "STEP DOWN PROFILES":

    BEFORE ENABLING HYPER-V(OR IF YOU HAVE IT ENABLED GO TO CONTROL PANEL>>>UNINSTALL A PROGRAM>>>TURN WINDOWS FEATURES ON OR OFF>>>UNCHECK THE HYPER-V BOX>>>OK,IT MAY NEED A REBOOT) CREATE POWER MANAGEMENT PLANS FROM THE POWER MANAGEMENT SECTION IN CONTROL PANEL. FOR EXAMPLE I HAVE 5 POWER PLANS, 2 POWER SAVERS, 1 BALANCED, AND 2 HIGH PERFORMANCE ONES- ONE THAT ALLOWS "FULL THROTTLE", I MEAN MAXIMUM PERFORMANCE, AND ONE THAT PREVENTS OVERHEATING, THAT NEEDS TURBO BOOST OFF.THIS IS DONE BY SETTING MAXIMUM ALLOWED PROCESSOR USAGE TO 99% IN THE ADVANCED SETTINGS,SO THAT YOU DON'T HAVE TO GO TO THE BIOS SETTINGS ALL THE TIME.---THEN ENABLE HYPER-V, AND SWITCH BETWEEN THE PLANS YOU'VE JUST CREATED.

    PLEASE NOTE THAT THE TASK MANAGER WILL ONLY SHOW THE BASE FREQUENCY OF YOUR PORCESSOR, ALTHOUGH UTILITIES LIKE HWINFO, INTEL XTREME TUNING UTILITY, AND TURBO BOOST MONITOR FROM INTEL WILL SHOW THE REAL CLOCK FREQUENCY. THERE IS PROBABLY A BUG IN THE TASK MANAGER, OR MAYBE THE PERF COUNTERS FOR TURBO BOOST ARE DISABLED OR SOMETHING.

    Hi Njoker

     I think I have encountered this issue too.  Essentially, I am scaling out a multi server (win2008r2, win2012 )VM farm on my laptop with windows 8 Hyper-v.  I want to be able to close my laptop lid and the laptop just goes into a very low power sleep state. Instead, it seems to carry on as normal which results in it being very hot when I next take it our my bag.  Do you think your  fix can  solve this problem

    If so, may I clarify your instructions

    1) Uninstall Hyper-V buy unchecking the feature

    Do I need to backup/restore my lan settings - setting up the virtual bridge was not quite the walk in the park I was led to believe.

    2) Create Power Save Plans

    • 2 Power Save
    • 1 balanced
    • 2 high performance (Full Throttle + One the avoids overheating.)

    Out of interest why so many?

    Do you have a defaults in each case?

    When do make the switch from the default

    3) other stuff

    -What to do when I close the laptop lid when on battery .... Sleep then 20mins hypernate???????

    -what about the graphics card  (GTX 670M )  - which plan will effectively drop this down to a minimum performance or even disable it altogether.

    - what are the best powersave settings on the following so that they effectively mirror the current powersave plan, provided by windows 8 host.

    • win 8 vm
    • win2008r2 vm
    • win2012 vm

     Regards

    Daniel

    Wednesday, December 19, 2012 1:52 PM
  • Can any of you guys using Hyper-V confirm corruption of some system files after! disabling Hyper-V?

    >SFC /VERIFYONLY (will leave all untouched but lists errors found.)

    Test sequence:

    Windows 8 Pro before enabling Hyper-V - SFC finds no errors

    Windows 8 Pro with Hyper-V enabled - SFC finds no errors

    Windows 8 Pro after disabling Hyper-V - SFC finds errors


    2012-11-24 14:57:30, Info                  CSI    00000409 [SR] Repairing corrupted file [ml:520{260},l:82{41}]"\??\C:\Windows\System32\driverstore\en-US"\[l:30{15}]"wvms_mp.inf_loc" from store
    2012-11-24 14:57:30, Info                  CSI    0000040a [SR] Repairing corrupted file [ml:520{260},l:82{41}]"\??\C:\Windows\System32\driverstore\en-US"\[l:34{17}]"wvms_vspp.inf_loc" from store
    2012-11-24 14:57:31, Info                  CSI    0000040b [SR] Repairing corrupted file [ml:520{260},l:74{37}]"\??\C:\Windows\System32\drivers\en-US"\[l:32{16}]"vmswitch.sys.mui" from store
    2012-11-24 14:57:31, Info                  CSI    0000040c [SR] Repairing corrupted file [ml:520{260},l:82{41}]"\??\C:\Windows\System32\driverstore\en-US"\[l:30{15}]"wvms_pp.inf_loc" from store
    • Edited by Win7ine Thursday, December 20, 2012 4:22 PM
    Wednesday, December 19, 2012 7:41 PM
  • I experienced the same problem (also because I'm a Windows Phone Dev and the new emulator uses Hyper-V)

    The 'workaround' I am using is the following:
    http://blogs.msdn.com/b/virtual_pc_guy/archive/2009/01/21/hyper-v-r2-changes-for-no-hypervisor-booting.aspx

    Another one that might fit better to your needs:
    http://blogs.msdn.com/b/tejas/archive/2009/03/10/hibernate-and-sleep-with-hyper-v-role-enabled.aspx

    Anyone from Microsoft who reads this, the following statement is no longer true, since you're 'forcing' us to use Hyper-V when doing Windows Phone Development, which, rest assured, is quite often done on a laptop:
    "The reason for this is that supporting these features on a hypervisor based system is incredibly complicated - and Hyper-V is designed to run on servers - where sleep and hibernate are not used."

    Likewise:
    "This means that if you want to run Hyper-V on a laptop (not a recommended configuration - but we accept that many of you do this) you can set it up to sleep / hibernate while you are on the road / going from meeting to meeting - and still get full access to Hyper-V when you have wired power handy."

    Thanks for 'accepting' that we run Hyper-V on laptops.

    Kind regards,
    Bart

    Monday, December 31, 2012 4:04 PM
  • I have the same problem on Del E6410, Windows 8 with Hyper-V installed. I upgraded it from Win 7 and configured Hyper-V to replace Virtual PC when I noticed it generating noticeably more heat. Checking Resource Monitor I noticed that even when the CPU is almost idle, it's keeping the CPU frequency at 100% (on windows 7 it would fluctuate between 46% and 100%, I didn't check it on Windows 8 before I configured Hyper-V.) It would appear from the discussion that Hyper-V is disabling the CPU frequency management, has anyone seen a solution?

    I've seen a post about disabling Hyper-V service on Windows Server 2008 R2 to allow Hibernate(http://blogs.msdn.com/b/tejas/archive/2009/03/10/hibernate-and-sleep-with-hyper-v-role-enabled.aspx), would a similar change on Windows 8 allow CPU throttling (at least when you don't currently need Hyper-V)?


    Andrew S. Martin

    Friday, February 22, 2013 8:01 PM
  • I have this same issue. CPU power management goes nuts after enabling Hyper-V. CPU-Z shows rather weird bus speed too (drops to 97 MHz). This happens with i7 3770K and ASUS P8Z77-V mobo combo. Task manager shows max speed all the time, cpu-z doesn't.

    ...or could it be that cpu-z gets it right except bus speed when Hyper-V is enabled?

    • Edited by Tup3x Monday, September 02, 2013 12:51 PM
    Monday, September 02, 2013 12:41 PM
  • Hello,

    I'm glad I have found this thread as I was wondering what's going on with Hyper-V and power management. I installed it since VM workstation is causing instant clock_watchdog_timeout BSOD for no reason. Nonetheless this "no power management" thing is silly as it means more power consumption for no valid reason, which is especially annoying on a laptop! I will set the service to on-demand and reboot after using Hyper-V since that's the only solution offered by MS at this point..

    the solution being "sc config hvboot start= demand".

    Wednesday, December 04, 2013 7:58 AM
  • Hi

    It seems that speedstep is still working behind the scenes.

    The explanation short: taskmanager is showing you a virtualised cpu consumption.

    If you monitor cpu usage/speed/power consumption via 3rd party tool like CPU-Z, then it will show you a completely different picture.

    http://www.nspyre.nl/blogs/3178/Windows8-Hyper-V-V3-SpeedStep

    for full explanation

    Wednesday, April 09, 2014 10:46 AM
  • Hello,

    I'm glad I have found this thread as I was wondering what's going on with Hyper-V and power management. I installed it since VM workstation is causing instant clock_watchdog_timeout BSOD for no reason. Nonetheless this "no power management" thing is silly as it means more power consumption for no valid reason, which is especially annoying on a laptop! I will set the service to on-demand and reboot after using Hyper-V since that's the only solution offered by MS at this point..

    the solution being "sc config hvboot start= demand".

    Has anyone verified this, me just uninstalled Hyper-V, me don't have time to deal.

    Monday, June 30, 2014 10:53 AM
  • Hello,

    I'm glad I have found this thread as I was wondering what's going on with Hyper-V and power management. I installed it since VM workstation is causing instant clock_watchdog_timeout BSOD for no reason. Nonetheless this "no power management" thing is silly as it means more power consumption for no valid reason, which is especially annoying on a laptop! I will set the service to on-demand and reboot after using Hyper-V since that's the only solution offered by MS at this point..

    the solution being "sc config hvboot start= demand".

    Has anyone verified this, me just uninstalled Hyper-V, me don't have time to deal.

    check that virtualization is also turned off in the BIOS


    Corsair Carbide 300R with window
    Corsair TX850V2 70A@12V
    Asus M5A99FX PRO R2.0 CFX/SLI
    AMD Phenom II 965 C3 Black Edition @ 4.0 GHz
    G.SKILL RipjawsX DDR3-2133 8 GB
    EVGA GTX 6600 Ti FTW Signature 2(Gk104 Kepler)
    Asus PA238QR IPS LED HDMI DP 1080p
    ST2000DM001 & Windows 8.1 Enterprise x64
    Microsoft Wireless Desktop 2000
    Wacom Bamboo CHT470M
    Place your rig specifics into your signature like I have, makes it 100x easier to understand!

    Hardcore Games Legendary is the Only Way to Play!

    Monday, June 30, 2014 1:27 PM
  • Yes, I have found the same thing using hwinfo...
    Monday, November 24, 2014 10:02 PM
  • you are behaving like a little rotten cunt. beside the solution is far too easy and you question far too retarded.
    Friday, January 15, 2016 3:55 PM