none
Problems connecting Speedtouch 330 Modem to Tiscali Boradband

    Question

  • Just got a new PC with Vista and opened up a new broadband account with Tiscali at same time. They sent me a Speedtouch 330 USB Modem. I can't get it to work, the Tiscali CD is useless and Tiscali helpdesk are unable to support any queries about Vista.

    I managed to install a set of drivers from the web which appear to work since all the lights on the modem have gone solid green and manually made a dial-up connection, However when I try to connect I get Error 721: server not responding.

    I think the problem must be in the set ups for the connection. Can anyone tell me what all the settings should be for a successful connection?

    Tuesday, February 20, 2007 5:34 PM

All replies

  •  

    same thing has happened to me and the tiscali tech person made it worse by uninstalling some drives, now it totally doesn t work.

    my reaction:

    i am sending the whole lot back to tiscali, if they cant get their act together and stop passing the buck to msoft then msoft passing the buck back and everyone trying passing it to dell then i dont want their services, and the phone line they set up is *** as well. 

     

    they sent the modem they should sort it out with msoft and train the indian call centre workers on how to deal with it

     

    SEND IT BACK THEN THEY WILL GET THE MESSAGE DONT TRY AND SOLVE IT YOURSELF 

    Thursday, February 22, 2007 8:49 AM
  • Finally got it to work - no thanks at all to Tiscali.  I found a set of drivers on the web which worked no problem. I'd like to thank the person that created them (they weren't from any normal driver site), unfortunately I had downloaded so many things by that time that I can't remember where I got them from. I had to install twice before they worked and then manually set up a dial-up connection using the Vista Wizard.

    However the Speedtouch turned out to work only when connected to the main phone point. When I moved the PC back to the spare bedroom, it wouldn't pick up the broadband signal. So I went out and bought a Netgear wireless router modem. The router works fine but I can't get the the Wireless adapter (Netgear WPN111) to work. Guess what, none of the drivers work - even the Netgear Vista compatible ones. I see from the forum that others have the same problem.  

    I'm never going to buy a PC again just after the launch of a new operating system. I get the impression those upgrading have had a less tortuous time than those with new PCs.

    Sunday, February 25, 2007 10:38 AM
  • WHERE DID YA FOUND THEM??

     

    I have the simular problem !!

     

     

    mail me at glenn.vandormael@gmail.com if u can

    Friday, March 2, 2007 11:06 PM
  • I'm having the same problem using the WPN111 Vista compliant drivers and utilities. THEY DO NOT WORK. I guess NetGear hasn't gotten it right yet. It never pays to be on the "bleeding edge."
    Sunday, March 11, 2007 5:43 AM
  • I installed my modem on vista ultimate using the 3.015 drivers which are hard to find, these make the modem work, however i can't connect to tiscali, vista simply does not work with it. Unless these new vista drivers work, and ADSL router is the only way forward. Blame tiscali for consistent bad support, poor quality product and cost cutting. lets stay british and go with BT, who provist PPOE modems which will work on vista.
    Tuesday, March 13, 2007 4:59 PM
  • i have the same problem as you tiscali are the worst internet sevice provider ever it has been a week now they havent got a clue what is wrong  and thier so called tech wiz kids  dont call you back. because they dont know how to fix it the people in the idian call centre dont understand anything so im going to leave tiscali as well as report them to ofcom and tradeing standards. they should be shut down and banned from tradeing espically when thier not provideing a service they say they are. i think thier a discrace and i urge anyone else who is thinkingof signing up to tiscali broadband dont thier a waist of time and space.
    Sunday, April 8, 2007 8:07 AM
  • I too rang tiscal iafter upgrading from xp to vista, got no joy and was told to wait a few weeks untill they sort it out.

    But all u need to do is install from the cd as usual .....it lets u do this no problem.

    its only when u come to connect to the internet AFTER installation the broad band dosent work.

     

    all u need to do is click on the stdialup icon in the thompson folder.

    just  put in your password ..and hey presto it works fine.

    then just double click your web browser.....no need to install new drivers ..also i get a better broadband

    speed when downloading .LMAO.

     

     

    Monday, April 16, 2007 6:18 PM