'Telnet' is not recognized as an internal or external command


  • I am using Win 7 Enterprise SP1.
    I have "Telnet Client" checked in the Control Panel - Programs - Turn Windows features on or off.
    But, when I try to do Telnet it still says 'Telnet' is not recognized as an internal or external command.

    The weird thing is this used to work on the same machine, and it just stops working today.
    I unchecked  "Telnet Client" , then re-check it back, and reboot my machine, but still getting the error.
    On the command prompt, I tried pkgmgr /iu:"TelnetClient" , but it gave me the error "Operation failed with 0x8007000B. An attempt was made to load a program with an incorrect format."

    Monday, October 28, 2013 7:39 PM


All replies

  • Does the file c:\windows\system32\telnet.exe exist?
    Monday, October 28, 2013 9:35 PM
  • Try running SFC scan. Refer the link more information:

    Balaji Kundalam

    Tuesday, October 29, 2013 3:57 AM
  • Hi,

    I agree with Balaji Kundalam.

    In addition, I would like to suggest you try to activate Telnet by other ways to see if it works.

    How to Activate Telnet in Windows 7

    Please Note: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

    You may also refer to the below links for assistance:

    Telnet: frequently asked questions

    If the issue still occurs after you tried all the steps.

    I understand that some files cannot be repaired when running SFC /scannow, I suggest trying the following method to troubleshoot the issue:

    1. At an elevated command prompt, copy and then paste (or type) the following command, and then press ENTER:

    takeown /f c:\windows\system32\telnet.exe

    2. Copy and paste (or type) the following command, and then press ENTER to grant administrators full access to the file:

    icacls c:\windows\system32\telnet.exe  /GRANT ADMINISTRATORS:F

    3. Copy and paste (or type the following command to replace the file with a known good copy of the file:

    Copy c:\windows\system32\telnet.exe _Of_Source_File  c:\windows\system32\telnet.exe _Of_Destination

    For more information, you may refer to:

    Use the System File Checker tool to troubleshoot missing or corrupted system files on Windows Vista or on Windows 7

    Please note the section "More troubleshooting steps for advanced users-Step2: If the System File Checker tool cannot repair a file."

    Hope it helps.


    Blair Deng

    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

    Wednesday, October 30, 2013 10:20 AM
  • If your Windows 7 machine is a member of an AD, or if you have UAC enabled, or if security policies are in effect, telnet more often than not must be run as an admin. The easiest way to do this is to create a shortcut that calls cmd.exe, and then go to the shortcut's properties and click on the Advanced button and check the "Run as an administrator" checkbox, and you're all set. Scratched my head and rebooted numerous times before finding this out...
    • Proposed as answer by FVM2000 Saturday, February 07, 2015 4:29 AM
    • Edited by FVM2000 Saturday, February 07, 2015 4:30 AM typo
    Saturday, February 07, 2015 4:29 AM