Razer Megalodon USB Audio Issue


  • I'm having problem's getting the new Razer Megalodon USB headset to work properly under Windows 7. I have tried it on 3 different computer's 2 using XP and one dual booting Vista Home Premium 32bit and Windows 7 RC 7100 64bit.
    The issue is the audio keep's cutting out randomly in 7 but work fine on Vista and the other 2 computer's running XP. They don't come with any driver's windows build's the driver's once they are plugged in so I can't update them. I have all motherboard driver's up to date the same with windows update's. I have also contacted Razer support but they said they can not comment until Windows 7 is released.
    I'm at a loss as to what to try next any help resolving this problem would be very appreciated.
    Sunday, July 26, 2009 8:15 PM

All replies

  • i have the exact same problem
    Tuesday, July 28, 2009 5:23 AM
  • I have the same problem as well and I believe we at least have pin-pointed the problem OS.  I have a contact at Razer who said their engineers met last night and have determined that the problems are isolated to Vista/7 64-bit OS, not the 32-bit.  They're a bit baffled as to why but they're diligently working on a fix.  As soon as I hear word, I will post the results/fix here.  Cheers.
    Wednesday, September 09, 2009 8:33 PM
  • Thanks for the reply, It's good to know that the problem has been isolated and is being worked on. I'm looking forward to purchasing 7 64-bit next month and hope that the problem will be fixed by then.
    Please keep me up to date with any possible solution to this issue.
    Thursday, September 10, 2009 5:33 AM
  • What's interesting is that my friend and I both bought a set of these headphones.  We are both running windows 7 64bit RTM.  He was experiencing the exact same problem as you guys have described, but I, on the other hand had no issues at all.  We were both gaming on the same server for about 2 hours.  His audio dropped out probably 5-6 times over that 2 hour span, but again, I had no issues.  I'm running a Core i7 system with 12GB of RAM on an EVGA x58 Classified, GTX295.  He's running a Q6600 with 8GB of RAM on an ASUS P5K-E Wifi/AP, GTX275.  He reported to me this morning that after updating his audio drivers on his system (I think it is onboard Realtek), he was able to play for an hour with no audio cut outs.  However, firing up BF2 resulted in an instant audio drop out when the maps were loading, and he was unable to get any audio (even after updating the drivers for his onboard audio).  We are going to mess around with this more tomorrow, and hopefully we'll figure something out - but if we don't - there is a good chance these things will get returned.
    Wednesday, September 23, 2009 12:52 PM
  • Im having exactly this same problem with Call of Duty 4. In other games it havent cut out my sound, hopefully we will get the fix soon!
    Friday, September 25, 2009 5:25 AM
  • Hey guys, Razer has come through!
    I just did this an my Megalodon is sounding better than ever:

    Spread the word!
    • Proposed as answer by CautionaryTale Wednesday, October 28, 2009 6:24 AM
    Wednesday, October 28, 2009 6:23 AM
  • I have installed a purchased win7 ultimate 64-bit OS and did what you said above. All my mobo stuff are updated, same goes for my windows. My mobo is Asus Rampage Extreme.

    My Megalodon sound stops randomly when in COD4 or COD5. Haven't checked other games as I don't play other games. Also, if i am on Teamspeak while playing and the sound from the game stops others can hear me talking in Teamspeak but I cant hear them. Means that the mic works. Sometimes, when i quit the game / Teamspeak and re open both applications, the sound comes back. Sometimes I need to reboot.

    I thought the 2.7 FW update from razer resolved the above issue but apparently not.

    Any other facing similar problem?

    Any response you had from Razer?

    Monday, November 09, 2009 5:52 AM
  • Well before the 2.7 FW update from razer was available I bought a powered USB HUB and the seemed to resolve the sound cutting out issue. I still have problems with a lot of static through the mic but at least I can play game's without the sound cutting out.

    Updated to 2.7 FW I'm still running them through the powered USB HUB, sound doesn't cut out but the mic still has problems.

    I suggest trying a powered USB HUB fixed my sound cutting out.
    Monday, November 09, 2009 6:18 AM
  • cleary same issue with 64 w7, looks like razer screwed up with drivers, running at 32 w7 for 12 hours with no problems. Stil not officaly Fixed.
    Thursday, November 12, 2009 5:16 AM
  • I recently bought the megalodon. I also run W7 64bit ultimate. I get 2 problems:

    - Sound cut offs
    - People hear static noise when I talk on voice comm programs.

    I've ordered a powered USB hub, and really hoping that will solve issue no. 1.

    Will let you guys know when I get the USB hub.

    Also I'm really annoyed that razer is slacking so much with this. I mean we paid like 150$ for a headset that acts like a 5$ headset from TRUST. I'm surely never gonna buy anything from Razer again.
    Monday, February 01, 2010 11:24 AM

    Supposedly this is it... but its not working for me. Let me know if the hub solves the issue too pete... Though id rather fix it spending nothing more than i already have :(
    Saturday, February 20, 2010 5:34 AM
  • Hi Mitch

    I've hooked up my powered USB Hub a while ago. And since then my Megalodon has been working perfectly. I havent had any cut offs since I've got it. 
    I mainly/only play Modern Warfare 2 with it, and its perfect.

    I still had some trouble with the static noise people hear from me, but I fixed that with messing arround with the sensitivity & volume settings on the module and in Windows 7.

    I've gotten this USB Hub:
    Name: Prodjuser USB Hub powered

    Im not gonna install the new firmware, because it works fine for me now.

    Monday, February 22, 2010 8:39 AM
  • Hey all..

     i tried to jack my megalodon on a usb port and the led gets red (after microsoft update installs the razer drivers)

    the 2.0 and 7.1 leds on the megalodon controller flash alternately but when i try to execute the firmware updater it stays at 0%...

    it also stays at 0% when i jack my megalodon usb straight at any usb on my pc....

    any help wd be appreciated..
    Monday, February 22, 2010 7:57 PM
  • I know this thread is old, but I may have found the problem.

    I noticed my headset would cutout whenever I was listening to loud music and the room temperature was high (above 85 degrees F), or if the control pod was covered.  This made me wonder, could the problem be that the control pod is overheating and turning itself off to prevent damage?

    I also noticed that the surface of my desk under the control pod got really hot, just from the pod sitting on it.  So, what I do to prevent overheating is move the pod around on my desk 2 to 3 inches every so often.  If it cuts out on you, just move the pod to a new location on your desk, unplug it, plug it back in, and keep moving it around.

    Otherwise, you could always prop the pod up with something (like a pen or pencil) so it is not sitting on the desk, allowing airflow under it.  That seams to help too.

    Sunday, April 15, 2012 9:17 PM
  • This link does not work, Fark im at my wits end with this damn headset

    Tuesday, August 13, 2013 5:25 AM