none
Script to change language not working - Intl.cpl,, f:/C:\file.xml

    Question

  • I've installed an language pack on Win7

    I'm trying to change the language settings using the command: "control.exe intl.cpl,, /f:c:\file.xml"

    The command terminates but there is no change on the settings

    i'm using a .vbs to send the command:

    vbscript:

    Set wshShell = WScript.CreateObject ("Wscript.Shell")

    wshShell.run ("Control.exe intl.cpl,, /f:c:\file.xml")

     

    Can someone help, does anyone use this on a automated way? (i'm using this on a MDT2010 task sequence)

     

    Thanks

    Wednesday, February 02, 2011 4:10 PM

Answers

  • Ray,

    thanks for your answers, i've been looking around and i've resolved the issue.

    I've had two errors;

    - On the command, control.exe intl.cpl,, /f:c:\file.xml - the c:\file.xml has to be enclosed with double quotes, the correct command should be: control.exe intl.cpl,, /f:"c:\file.xml"

    - On the XML, there was an option that the system didn't understand, <gs:MUILanguage Value="es-VE"/> as to be <gs:MUILanguage Value="es-ES"/>

     

    Thanks

    Friday, February 04, 2011 11:45 AM

All replies

  • Where in the task sequence do you run the script? I usually create a CMD script that I configure as an application in MDT.

    After running the command you can check the logs in the Event Viewer under Applications and Service Logs\Microsoft\Windows\International\Operational

    Did you test your script on a live system?

    More information about the procedure can be found here http://msdn.microsoft.com/en-ie/goglobal/bb964650(en-us).aspx

    If problems remain, maybe you can post the contents of the XML file.


    Ray - Author of Windows 7 for XP Professionals
    Wednesday, February 02, 2011 9:19 PM
  • Hi Ray, thanks for your reply

    Yes i tested the script on a live system, it doesn't work either :(

    Here is the XML:

    <gs:GlobalizationServices xmlns:gs="urn:longhornGlobalizationUnattend">
    
     <!-- user list -->
     <gs:UserList>
      <gs:User UserID="Current" CopySettingsToDefaultUserAcct="true" CopySettingsToSystemAcct="true"/>
     </gs:UserList>
    
     <!-- GeoID -->
     <gs:LocationPreferences>
      <gs:GeoID Value="249"/>
     </gs:LocationPreferences>
    
     <!-- UI Language Prefernces -->
     <gs:MUILanguagePreferences>
      <gs:MUILanguage Value="es-VE"/>
    		<gs:MUIFallback Value="en-US"/>
     </gs:MUILanguagePreferences>
    
     <!-- system locale -->
     <gs:SystemLocale Name="es-VE"/>
    
     <!-- input preferences -->
     <gs:InputPreferences>
      <gs:InputLanguageID Action="add" ID="200a:0000200a" Default="true"/>
    		<gs:InputLanguageID Action="add" ID="0409:00000409"/>
     </gs:InputPreferences>
    
    	<!-- user locale -->
     <gs:UserLocale>
      <gs:Locale Name="es-VE" SetAsCurrent="true" ResetAllSettings="true"/>
     </gs:UserLocale>
    
    </gs:GlobalizationServices>

     

    Even if i use on a live system the comand: Control.exe intl.cpl,, /f:c:\file.xml

    It's not working

     

    Thanks

    Thursday, February 03, 2011 8:59 AM
  • Can you look in the Event Log of the live system and tell if you find any errors or warnings under Applications and Service Logs\Microsoft\Windows\International\Operational?


    Ray - Author of Windows 7 for XP Professionals
    • Proposed as answer by NextXPertMVP Friday, February 04, 2011 11:49 AM
    Thursday, February 03, 2011 10:04 PM
  • Ray,

    thanks for your answers, i've been looking around and i've resolved the issue.

    I've had two errors;

    - On the command, control.exe intl.cpl,, /f:c:\file.xml - the c:\file.xml has to be enclosed with double quotes, the correct command should be: control.exe intl.cpl,, /f:"c:\file.xml"

    - On the XML, there was an option that the system didn't understand, <gs:MUILanguage Value="es-VE"/> as to be <gs:MUILanguage Value="es-ES"/>

     

    Thanks

    Friday, February 04, 2011 11:45 AM
  • Well done!

    HTH


    Ray - Author of Windows 7 for XP Professionals
    Friday, February 04, 2011 11:49 AM
  • Hi,

     

    I’m glad to hear your issue has been resolved.

     

    I will mark your reply as answer. It could help other communities here who have the same issue.

     

    Thanks for your understanding.

     

    Regards,

    Leo   Huang

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com

     

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, February 07, 2011 2:08 AM
    Moderator