none
Moved to Server 2012 getting Access Database Corruption RRS feed

  • Question

  • We moved our company file shares to a new Windows 2012 server and are now having issues with Access databases becoming corrupted when accessed by multiple clients at the same time.  Does anyone have any ideas on what could be causing this?  We were not having any issues with this on the 2008 or 2003 servers these were on previously.
    Tuesday, January 22, 2013 4:19 PM

Answers

  • Hi,

    Please see if it related to SMB3. You could test to use SMB1 as a test.

    To disable specific SMB versions in Windows Server 2012 and Windows 8, use the Set-SMBServerConfiguration Windows PowerShell cmdlet. 

    Note: When enabling/disabling SMB2 on Windows 8 or Windows Server 2012, SMB3 is also enabled/disabled because these protocols share the same stack.

    • To disable SMB2/SMB3 for SMB Server:

    Set-SmbServerConfiguration -EnableSMB2Protocol $false

    • To enable SMB1 for SMB Server:

    Set-SmbServerConfiguration -EnableSMB1Protocol $true


    TechNet Subscriber Support in forum |If you have any feedback on our support, please contact tnmff@microsoft.com.

    Monday, January 28, 2013 6:14 AM
    Moderator

All replies

  • We moved our company file shares to a new Windows 2012 server and are now having issues with Access databases becoming corrupted when accessed by multiple clients at the same time.  Does anyone have any ideas on what could be causing this?  We were not having any issues with this on the 2008 or 2003 servers these were on previously.
    What LVM do you use? No one? Classic? Storage spaces? Simple/mirror/parity? Do you use NTFS or ReFS? Did you enable deduplication with NTFS (the most critical question)? 

    StarWind iSCSI SAN & NAS

    Tuesday, January 22, 2013 9:56 PM
  • Classic.  Simple.  NTFS.  No deduplication.  Basically, as plain as you can get.
    Thursday, January 24, 2013 8:44 PM
  • Hi,

    Please see if it related to SMB3. You could test to use SMB1 as a test.

    To disable specific SMB versions in Windows Server 2012 and Windows 8, use the Set-SMBServerConfiguration Windows PowerShell cmdlet. 

    Note: When enabling/disabling SMB2 on Windows 8 or Windows Server 2012, SMB3 is also enabled/disabled because these protocols share the same stack.

    • To disable SMB2/SMB3 for SMB Server:

    Set-SmbServerConfiguration -EnableSMB2Protocol $false

    • To enable SMB1 for SMB Server:

    Set-SmbServerConfiguration -EnableSMB1Protocol $true


    TechNet Subscriber Support in forum |If you have any feedback on our support, please contact tnmff@microsoft.com.

    Monday, January 28, 2013 6:14 AM
    Moderator
  • Same problem for me. Access Database files (one of them stable as a rock for the last 6! years) on a Windows 2012 Server (Standard - VM on Hyper-V failover cluster) suddenly getting corrupt (about every two days) during shared access from the same workstations as in the past. I will try to disable SMB3 and come back with the results.

    Regards

    Andreas Simon

    Friday, May 31, 2013 4:37 PM
  • Did this ever get resolved? We're encountering the same issue, and are resorting to creating a new Server 2008 R2 machine for our fileserving needs.

    Regards,

    Stephen Courtney

    Tuesday, July 23, 2013 3:31 PM
  • Since disabling SMB3/2, no file corruption occured any more. Worked with two different servers with two different applications. Problem solved.
    Wednesday, July 24, 2013 9:17 AM
  • Cant conclude about the thread but yes have a look at this link and see if it helps you out in controlling the data prevention...

    http://www.techrepublic.com/blog/10-things/10-ways-to-prevent-access-database-corruption/

    Thanks.

    Wednesday, July 24, 2013 1:43 PM
  • Since disabling SMB3/2, no file corruption occured any more. Worked with two different servers with two different applications. Problem solved.

    It's more of a work-around than a fix though, as you lose all the benefits added to file serving since Server 2003 was released. For now we'll stick with 2008 R2.
    Friday, July 26, 2013 9:38 AM
  • Disabled and it worked for us too. Should not Microsoft solve this problem so we could enable it again?
    Friday, October 25, 2013 4:34 PM
  • Might be you want to disable oplocks.

    http://support.microsoft.com/kb/300216

    http://support.microsoft.com/kb/296264

     

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    Friday, October 25, 2013 5:34 PM
  • I have users experiencing the same issues.  I tried disabling SMB 2/3 as recommended and then no one could access the shares at all on site.  Weird thing is I could still access them from a remote site.  Any idea why that would occur.  It just said the network location was no longer available.
    Wednesday, February 12, 2014 10:33 PM
  • We're facing the same problem in our environment. Some days after migrating our file server from 2008 R2 to 2012 R2, the access' databases that were there became corrupted.

    Any workaround/solution besides disabling SMB2/SMB3 and enabling SMB1? We don't want to lose the benefits of SMB3.

    Thanks!

    Monday, April 14, 2014 3:51 PM
  • We also are seeing the exact same issue at one of our client sites.  It seems an unacceptable solution to roll back to SMB1. 

    Our Access-based application is in use at many other organizations, and if and when they upgrade their servers to Windows 2012, I fear we will see the same database corruption.  Eventually we will be migrating all users to a SQL Server based version of our app, but some solution in the interim would be very helpful.

    Thanks for any ideas!

    Friday, April 18, 2014 4:14 PM
  • hello,

    We experiencing the same issues since we have migrated from our Windows208R2 server to a new Windows2012 server.

    I'am not able to turn off SMBv2.1, we are using a lot of SMBv2.1 features (like DNS aliases access ...). And downgrade to Windows 2008 is not, in my mind, the right way.

    This issues has been escalated to Microsoft Product Team, but no news.

    Let me know if you have any way to fix this problem;

    Wednesday, May 28, 2014 3:17 PM
  • ok, I'm on Windows Server 2012 R2, so does this problem must be fixed by disabling SMBv2 and v3 ?

    what's  Microsoft has to say about this ?


    /* Server Support Specialist */

    Thursday, July 17, 2014 1:17 AM
  • For those that have disabled SMB 2/3 on Server 2012/R2 have you noticed that the performance of databases are slower than what was experienced on Server 2003 as an example.

    I have one client who upgraded his server from Server 2003 to Server 2012 and started to get corruption in his Vision application (which is a FoxPro database). I suggested that SMB2/3 gets disabled so got him to apply the following reg file.

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters]
    "EnableOplocks"=dword:00000000
    "SMB2"=dword:00000000

    The data corruption has gone away but now the client says that the program is slower than when it was on the old 2003 Server.

    I would have expected the performance to be the same as the Server 2003 machine...

    Any thoughts on this?

    Wednesday, August 20, 2014 5:18 AM
  • I too had this issue when we moved our students from a 2008R2 server to a 2012R2 server. I effectively resolved it by applying the following Reg hack to all the affected Clients (not server) 

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters]
    "FileInfoCacheLifetime"=dword:00000000
    "FileNotFoundCacheLifetime"=dword:00000000
    "DirectoryCacheLifetime"=dword:00000000

    as suggested here http://tipsntricks.sherr.co.uk/stop-smb-corrupting-files/

    I also added .mdb and .accdb to the list of files not to dedupe, though that in its self was not enough!

    Wednesday, January 21, 2015 3:18 PM
  • The solution here is to leave SMB2/3 enabled but disable leasing.  Leasing is just an enhanced form of OpLocks.

    Here is the registry entry that needs to be added to disable server leasing for SMB2.1.  You will need to reboot after setting this entry.

    Key:  HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters
    Value:  DisableLeasing
    Type:  DWORD
    Data:  0x1

    Watch your problems go away ;)

    Chris Jackson

    • Proposed as answer by typicalalex1 Thursday, June 1, 2017 2:19 PM
    Tuesday, February 10, 2015 5:33 PM
  • We migrated from a Windows 2008 file server cluster with four nodes to a Windows 2012 R2 file cluster with two nodes.  After the migration to the new file server cluster our customers running Windows 7 SP1 started reporting Access Database corruption and slow file access.  However, if the SAME Access Database file was hosted on a Windows 2012 R2 file server NOT in a cluster there was no corruption.  I will not bore you with all the tests we ran while trying to determine the cause but here is what we did to fix the issue.  The solution was provided via an open case with Microsoft.

    1. Create the following registry entries on all Windows 2012 R2 Servers in the new file server CLUSTER and reboot.

    Key:  HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters

    Value:  DisableLeasing

    Type:  DWORD

    Data:  0x1



    • Edited by RGARRETT28 Tuesday, February 10, 2015 6:53 PM
    • Proposed as answer by typicalalex1 Thursday, June 1, 2017 2:18 PM
    Tuesday, February 10, 2015 6:46 PM
  • Thanks for this hint.

    I´m on the way to move our fileserver from a standalone 2003 to a vm with 2012 R2 in an Hyper-V-Cluster.

    Have you disabled leasing just on the VMs our on the hyper-V-nodes as well? 


    • Edited by Mike.59 Monday, March 30, 2015 7:45 AM
    Monday, March 30, 2015 7:43 AM
  • The solution here is to leave SMB2/3 enabled but disable leasing.  Leasing is just an enhanced form of OpLocks.

    Here is the registry entry that needs to be added to disable server leasing for SMB2.1.  You will need to reboot after setting this entry.

    Key:  HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters
    Value:  DisableLeasing
    Type:  DWORD
    Data:  0x1

    Watch your problems go away ;)

    Chris Jackson

    I know this is an old thread but there isn't enough information available regarding this.

    My database has been corrupting a few times a week since i upgraded to 2012 a couple of years ago. It has been 2 weeks since i made the registry change and i haven't had a corruption issue since. Fingers crossed that this is the fix. I owe you a beer if this works.

    Thursday, June 1, 2017 2:21 PM