none
Domain Computers not showing up in Network RRS feed

  • Question

  • Whenever I try to view the Network Computers on any machine on my domain, I can only see 5 servers. There should be about 15 servers and 50 workstations.

    I have confirmed that Netbios over TCP/IP is enabled.

    All the proper services are enabled and automatic. Computer Browser, DHCP Client, DNS Client, Network Connections, Network Location Awareness, RPC, Server, Workstation, TCP/IP Netbios helper

    Any help would be appreciated.

    EDIT: Also, I am able to browse to all the servers and workstations by going to \\hostname

    • Edited by tsdub86 Friday, July 6, 2012 2:06 PM
    Thursday, July 5, 2012 8:07 PM

All replies

  • Yes they are
    Monday, July 9, 2012 1:55 PM
  • I'm pretty sure the computers not displayed are windows 7 WSs. Check the network discovery settings on these workstations under Network and sharing center.

    Tunde Abagun MCP,MCSA,MCTS,MCITP en p "for the love of Computers"

    Tuesday, July 10, 2012 10:04 AM
  • I'm pretty sure the computers not displayed are windows 7 WSs. Check the network discovery settings on these workstations under Network and sharing center.

    Tunde Abagun MCP,MCSA,MCTS,MCITP en p "for the love of Computers"

    You're pretty sure? Actually they're a mix of Windows XP, Windows 7, Server 2003 and Server 2008.
    Tuesday, July 10, 2012 5:04 PM
  • Try to disable your 3rd party firewall if you have and also windows built-in firewall ,and open cmd type: net view

    Do you use wireless connection or wire connection?

    If you use the wireless in your after you select the SSID to be your connection. Windows wiil ask if you want your connection to be Work network, Public, and Private / HOME in windows 7  don't choose public try private / home  to see if the problem is fixed.




    We do not have a 3rd party firewall and the Windows firewall is disabled. We do not use wireless. It is a gigabit ethernet domain.

    Also, when attempting to run net view from command prompt, it errors out saying "System error 64 has occurred. The specified network name is no longer available"

    • Edited by tsdub86 Wednesday, July 11, 2012 8:25 PM
    Wednesday, July 11, 2012 6:23 PM
  • Is the built-in firewall are disabled on both side.windows xp and windows server?

    You have to disable the Server Message Block (SMB) Signing to fix the "System error 64 has occurred. The specified network name is no longer available" with the net view command in cmd.

    Here is a link in which you can download hotfixes to fix this problem:

    http://support.microsoft.com/kb/916846

    http://technet.microsoft.com/en-us/library/cc786681.aspx



    Yes both client and server side Windows firewalls are disabled. I went ahead and disalbed the SMB signing. We'll see if that has any effect. Thanks for the help.
    Friday, July 13, 2012 1:31 PM
  • Yeah try it.

    Please mark as answer if this work to help other in the community.

    This did not fix my problem. I figured it out on my own. For the community's benefit, this service had someone become set to manual across my domain. I set it to automatic through group policy.

    Function Discovery Resource Publication

    • Proposed as answer by Incubeus Monday, March 4, 2013 6:03 PM
    Friday, July 13, 2012 5:09 PM
  • Computer Config->Policies->Windows Settings->Security Setttings->System Services
    • Proposed as answer by Incubeus Monday, March 4, 2013 6:04 PM
    Monday, July 16, 2012 12:38 PM
  • I just wanted to say Thank you :)

    This has been puzzling me for a good week now. I tried your GPO fix of

    Computer Config->Policies->Windows Settings->Security Setttings->System Services

    and switching Function Discovery Resource Publication to automatic.

    So far it's working like a charm.

    Thanks again ! :oD


    John

    Monday, March 4, 2013 6:06 PM
  • Great work! 

    This was the last problem after an all nighter recovering a virtual environment.  I can go home now - I will worry about how this got set (I suspect windows update?) later.

    Sunday, October 27, 2013 1:45 PM
  • It's Done . Thank you. Greak work

     Run -> Services.msc

    Function Discovery Resource Publication to automatic. start this service and make it automatic in each pc & including server.

    • Edited by shammi firoz Saturday, January 18, 2014 8:51 AM
    • Proposed as answer by Labsyboy Sunday, January 21, 2018 1:51 PM
    Saturday, January 18, 2014 8:50 AM
  • thanks ..it really works...thanks a lot..
    Monday, March 24, 2014 8:36 AM
  • It is really working. Thank you!
    Friday, August 29, 2014 12:42 PM
  • Thank for this thread.  I just spent 3 hours trying to solve this problem.  All other threads I found we useless.  Thank you for sharing your knowledge!
    Saturday, November 1, 2014 9:27 PM
  • I have the exact same issue but in Windows 10. I'm using a virtual machine. My issue is that I am not able to find the system services as referred to here Computer Config->Policies->Windows Settings->Security Setttings->System Services

    I can get as far as the Security Settings but the System Services seems to be missing. I would really appreciate help with this issue.


    Edward Hinds

    Friday, August 28, 2015 7:11 AM
  • Use the Services fix. Not the GPO fix.

    Function Discovery Resource Publication

    Wednesday, January 18, 2017 8:25 PM
  • Thank you!  This fixed my problem.  I have Win 10 and the problem started recently, so I assume it was caused by the Creators update.

    StillActive

    Saturday, June 10, 2017 10:09 PM
  • Thanks for the heads up. Worked like a charm. Had spent way too much time on the problem. Cheers.

    A Wright

    Monday, March 12, 2018 9:49 AM
  • Thank you VERY much. This worked PERFECTLY.... Every system that did NOT show up in the Network explorer had "Function Discovery Resource Publication" set to Manual start and it was OFF. There are only about ten systems at this site running Windows 10.... so once I started the service and set it to Auto on each system they showed up just like they are supposed to. How this got set to manual I have no idea.... some people are saying it was a Windows update..... not sure about that but it does sound like Microsoft.
    Wednesday, March 14, 2018 8:25 PM