none
How to disable firewall as well as file and printer sharing RRS feed

  • Question

  • Hi, here's the situation. (Public Profile)

    If I disable the firewall, file and printer sharing and network discovery are enabled. If I disable file and printer sharing and or network discovery, the firewall is enabled. Is this by design, if so why? I was under the impression these services were supposed to be disabled on Public profiles. Moreover, what are the consequences of having file and printer sharing enabled on a Public profile even if there are no shared resources?

    The firewall rules seem to have file and printer sharing disabled by default, regardless of the the setting being enabled in Advanced Sharing Settings. So, what exactly does this setting do?

     

     

    Thanks for any help.

     

     

     

     

     

    Tuesday, April 20, 2010 9:06 AM

Answers

  • Hi,

     

    This symptom is by default. Usually, Windows Firewall blocks network discovery, but you can enable it. When you manually disable Windows Firewall, the “Network Discovery” and “File and printer sharing” options will be enabled automatically. Otherwise, the options will be disabled.

     

    For more information, please refer to the link below:

     

    Enable or disable network discovery

     

    Thanks,

    Novak

    • Marked as answer by Novak Wu Thursday, April 29, 2010 7:39 AM
    Thursday, April 22, 2010 3:16 AM

All replies

  • Hi,

    firewall makes wall behind  network and your computer. If you turn off this wall your pc will be fully accesible from internet...

    soo..it is by design...

    Tuesday, April 20, 2010 12:32 PM
  • Thanks for the reply.

    Unfortunately, it doesn't really explain why there is this interaction. I appreciate that disabling the internal firewall would potentially leave one open to attack, however, I would expect the opposite behavior in the circumstance. In the current situation, disabling the firewall enables file and printer sharing and network discovery, which is surely less than ideal.

    That aside, this behavior doesn't change when a third party firewall is introduced and that is a potential problem, as running two firewalls concurrently is a recipe for instability.

     

     

    Tuesday, April 20, 2010 12:41 PM
  • Hi,

    you can stop service Print spooler. Then you are not able to print, but anyone won´t be able to print (of course from internet). But why you turning off your firewall?

    Tuesday, April 20, 2010 1:16 PM
  • Hi.

    I'm really just trying to understand the default behavior being exhibited, as it makes little sense.  Please don't forget, this is the behavior for a public network , not private or domain.

    To my mind, if I disable the internal firewall, it shouldn't immediately enable these services. Quite the contrary, in fact.

    [quote]But why you turning off your firewall?[/quote]

    Because a third part fire wall is being used and as I mentioned in my previous post, having two firewalls running simultaneously, is not a good idea.

     

     Thanks
    Tuesday, April 20, 2010 2:07 PM
  •   A quick update. It would appear that even disabling the firewall service doesn't allow for file and printer sharing and network discovery to be disabled.

     

     

    Wednesday, April 21, 2010 11:00 AM
  • Hi,

     

    This symptom is by default. Usually, Windows Firewall blocks network discovery, but you can enable it. When you manually disable Windows Firewall, the “Network Discovery” and “File and printer sharing” options will be enabled automatically. Otherwise, the options will be disabled.

     

    For more information, please refer to the link below:

     

    Enable or disable network discovery

     

    Thanks,

    Novak

    • Marked as answer by Novak Wu Thursday, April 29, 2010 7:39 AM
    Thursday, April 22, 2010 3:16 AM
  • Thanks for the reply, unfortunately, it still makes no sense to me, at all. Why would anyone believe that enabling network discovery and file and printer sharing, on a public network , automatically, if the firewall is disabled, to be a sensible idea?

    If, for one moment, we disregard the likelihood of one intentionally disabling ones security, when connecting to a public network  and assume, for what ever reason this may happen, surely the most sensible thing to do would be to disable these options.

    The logic of this design decision aside, there still seems no way to disable the firewall and these Advanced sharing options at the same time. So if one chooses to use some other vendors security product, these potential vulnerabilities have to be accounted for in that vendors product, instead of simply being able to disable them in Windows.

    Please correct me if I'm missing something here.

    Thanks again

     

     

    Friday, April 23, 2010 12:54 AM
  • So, can I assume there is simply no way to disable file and print sharing and network discovery, unless I enable the internal firewall?

     

    Thanks

    Sunday, April 25, 2010 6:51 AM
  •  

    As an alternatively method, you can open “Local Area Connection Properties” in Network Connections window and uncheck the “File and Printer Sharing for Microsoft Networks” to disable file and printer sharing. If you would like to turn the feature back, you just need check the option back.

     

    Thanks,

    Novak
    Monday, April 26, 2010 6:49 AM
  • Thanks for the reply.

     

    I had already disabled NetBIOS over TCPIP on the adapter, in addition to removing the checks from the client boxes, unfortunately this has no effect on the status being seen on the Advanced sharing pages, which to my mind indicates a bug.

    Something  like this needs consistency across the board, it's either enabled everywhere or disabled everywhere, showing it as enabled in the most obvious location (Advanced sharing) whilst having disabled it elsewhere is not helpful.

     

    Thanks again

    Monday, April 26, 2010 10:57 PM
  • Hi,

     

    After clearing the “File and Printer Sharing for Microsoft Networks” option, your shared folder or public folder will not be accessed. Regarding the status in Advanced Sharing settings, they are by default and it will be changed automatically when Windows Firewall is turned on or off. Thank you for your understanding.

     

    If you have any further suggestions of feedback, I suggest you access Feedback Center and upload the suggestions.

     

    Feedback & Idea Center

     

    Thanks,

    Novak

    Tuesday, April 27, 2010 2:57 AM
  • Thank you for your help, I consider myself dismissed :)
    Tuesday, April 27, 2010 4:00 AM
  • Hi: First: I'm a different person answering...

         The reason you cannot turn off BOTH File Share AND the Windows firewall (many have tried) even though you have (as I) a much better Firewallinstalled, is due to secret agreements between the government and Microsoft whereby Homeland Security is guaranteed a back door into your computer anytime they want.  Warrants apparently no longer are needed in this country:  Welcome to the new corporate owned America.  You can thank Cheney... and greed (seriously: You didn't REALLY think this was about America's security did you?)

    mothertucker

    Thursday, July 2, 2015 12:12 AM
  •   Very unlikely in 2010, which is when this discussion took place.


    Bill

    Thursday, July 2, 2015 2:06 AM