none
Windows 8.1 - Settings search doesn't work

    Question

  • I've updated Windows 8 to 8.1 recently and for some reason settings search on start up page stopped working. If I search with "Everywhere" selected I see results but settings entries are missing. I have another account on the same machine and there everything works fine. When I try to find some of the setting shortcuts on file system windows file search takes me to "C:\Windows\ImmersiveControlPanel\Settings". Both users are members of administrators group.

    I've tried running "sfc /scannow" but there was no result.

    I've noticed a strange error in event viewer but I don't know if it is related:

    Crawl could not be completed on content source <winrt://{S-1-5-21-2367193382-1881007217-2607126721-1001}/>.

    Any help would be appreciated :)

    Monday, November 18, 2013 7:17 PM

Answers

All replies

  • Hi,

    You can try to use Search and Indexing troubleshooter to see if it can identify the problem.

    Control Panel->Action Center->Troubleshooting->View all->Search and Indexing.

    Also you can use Dism command  to repair system file.

    Dism /Online /Cleanup-Image /ScanHealth

    Click the link below for more details about the command:

    http://technet.microsoft.com/en-us/library/hh824869.aspx


    Roger Lu
    TechNet Community Support

    Monday, November 25, 2013 6:42 AM
    Moderator
  • These commands did not work for me, but I seem to have found success by taking these steps to reset windows desktop search.

      • Open Regedit.exe
      • Expand the HKEY_LOCAL_MACHINE node
      • Navigate to SOFTWARE \ MICROSOFT \ WINDOWS SEARCH
      • On the right-hand side of the screen, you should see a REG_SZ value named “SetupCompletedSuccessfully” which normally is set to a value of “1″.
      • Double-click on the value and change it to 0.
      • Restart the Windows Search service (either using the Services control panel, or the command line “net stop wsearch” followed by “net start wsearch”)

      This will result in a rebuild of your index and will also reset your crawl scopes (folders to be indexed).  It may also reset certain Indexing-related settings.


    Shawn Keene

    Monday, July 07, 2014 2:36 AM
  • Thank you Shawn!
    Your answer solved my problem!

    Regards

    Darlan
    Thursday, July 10, 2014 1:20 PM
  • How other responses in other forums, your response dont resolved the problem!!
    Thursday, July 10, 2014 1:22 PM
  • It turns out that my steps did not actually solve my problem.  I discovered that after taking those steps, the Settings search worked well for a few minutes, but then stopped.  I assumed this must have been because the Indexer was scanning something that was corrupted or otherwise failed to import into the index correctly.

    I went looking through the event viewer, and noticed a Windows Search warning log that said it could not index a source of <winrt:{xxx-xxGUID HERE}>

    I explored the Search settings in the registry but could not identify what source that belonged to, so
    I decided to just go into Indexing options and rather than just rebuild, I would remove all locations from the index. Outlook, OneNote, IE History, File Directories, all removed. Then I observed that the Settings returned results correctly.

    Then I turned back on the removed Index Locations, and set it to only index my OneDrive and Documents folders (rather than the others it had by default).

    Overnight the index was rebuilt, and this morning it's still working fine.  So I must have successfully removed whatever location was failing to index properly!  Woot.

    It's been several days now, and it's still working.


    Shawn Keene

    Thursday, July 10, 2014 1:51 PM
  • So I finally go the results to show up faster too! I allowed indexingon this folder:

    C:\Users\shawn\AppData\Local\Packages\windows.immersivecontrolpanel_cw5n1h2txyewy\LocalState\

    I wrote a little more about it here: http://cmdrkeene.com/fix-windows-8-1-returning-settings-results


    Shawn Keene

    Friday, August 22, 2014 12:47 AM
  • Yes, now it comes close to my old classicShell start menu in windows 8.1

    Now it actually finds windows apps and windows msc programs in Windows 10. Thanks


    Saturday, August 22, 2015 5:27 PM
  • I got this warning in my event but it seems to come from Onenote. I think MS has messed up all their bundles in windows 10. They give you Onenote but once you install the Office2016 with the full version of Onenote there will be lots of inconsistencies in the system.

    I tried your fix and so far its ok, i guess it cant hurt to reset the database. I hope it fixes the problem. Already spend a whole day googling for other windows errors :/

    Sunday, August 14, 2016 12:09 PM