Windows 7 pc freezes when I try to print


  • Hi all,

    I've recently purchased a new Epson Workforce 325 printer and installed it on both my desktop & laptop. The laptop prints fine but the desktop keeps freezing when I print. I've tried installing the latest drivers from the Epson website but that hasn't improved things. The desktop runs on Windows 7 64 bit and the laptop on XP.

    I've returned the desktop to the shop and the hardware has been checked and I am assured that evrything is working correctly. Windows 7 was also removed and reinstalled.

    The error message I'm getting is:

    The print spooler failed to regenerate the printer driver information for driver EPSON TX320 WorkForce320 Series for environment Windows x64. Win32 system error code 2114 (0x842). This can occur after an operating system upgrade or because of data loss on the hard drive.

    Has anyone had this problem before? Does anyone know how I can rectify this?

    Please help me end my frustration!!!


    Monday, February 07, 2011 4:07 AM


All replies

  • I have updated all of the latest drivers from the Epson website but that hasn't helped.
    Monday, February 07, 2011 4:26 AM
  • Yes, I tried that but the drivers are the most up-to-date and are working correctly. The problem appears to be with the print spooler itself, apparently and is to do with the operating system.
    Monday, February 07, 2011 11:11 PM
  • I have the same problem with my HP printers, using Word or Excel the print job goes so far and then freezes, the printer stops, the Word/Excel program freezes. I try to cancel the print job but that doesn't work. I believe it is a problem only with Windows 7 64 bit since a 32 bit computer that I have using the same printer does not have the problem. The only way I can resolve it is to restart the computer. I think the issue is that the windows spooling function is not working correctlt with the 64 bit operating system.      
    Monday, February 14, 2011 5:15 AM
  • I found what appears to be the answer on this thread:

    Goto the Start Menu and in Run type "cmd", if you are using Windows Vista or Windows 7, search "cmd" and then right-click and click "Run As Administrator" and allow the program to run.

    Then type the following statements:-

    net stop spooler

    del /Q /F /S "%systemroot%\System32\Spool\Printers\*.*"

    net start spooler

    It worked for me and I don't have the problem anymore....



    Monday, February 14, 2011 6:56 PM