Windows 7 RTM build 6.1.7600 cannot install Virtual PC RTM (Windows KB 958559)


  • I bought 7 Pro for the XP mode, and have yet to get it to install.  When 7 was released I did a clean install 64 bit version.  My version is 6.1.7600.  My BIOS is the most current available, hardware VM is enabled. MS HAV tool passes without error.  Everytime I try to install Virtual PC for Windows 7, I get the error message "Windows Update Standalone Installer, The update is not applicable to your computer."
    All of the information I've been able to find about this error seem to be with RC or betas, but I am running the RTM build 7600 x64, and I cannot get Virtual PC RTM to install.  Already tried installing as adminstrator and after MS directions for "clean boot"
    Does anyone have any more ideas as I'm pretty much out of options to try?

    Sunday, December 20, 2009 10:23 PM

All replies

  • Hi,

    Are you downloading the Windows KB 958559 for 64 bit OS? Make sure it is the proper version here. Then manually download and install it.

    Have you enabled VT in BIOS?

    Monday, December 21, 2009 6:43 AM
  • That is the location I DL to install, and I VT is enabled. I wanted to put enough info in the problem header in the hopes that someone had the same situation as me, as the XP mode is the only reason I spent the money over the Home Premium version.  Would there be anything else to look for that I haven't tried above?

    Thursday, December 24, 2009 7:55 PM
  • You must have Windows 7 Professional, Enterprise, or Ultimate to run Windows XP Mode. If you have home edition, you can use Windows automatical upgrade to become win7 professional or ultimate.
    Friday, December 25, 2009 9:04 AM
  • Yes, I am running 7 Professional build 6.1.7600
    Friday, December 25, 2009 3:43 PM
  • Hi,

    Install the following for win7 64 bit:

    amd64fre_GRMRSATX_MSU.msu 222.1 MB
    Monday, December 28, 2009 9:02 AM
  • Magon,
    I will install when I get home from work, do you think the MS RSAT has something my system is missing or not configured that would allow VPC7 RTM to install correctly?
    Monday, December 28, 2009 1:39 PM
  • Hi mmahoney626

    could you please open the registry (start regedit) and go to

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion

    What do you see in BuildLabEx and EditionID?


    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter
    Monday, December 28, 2009 2:57 PM
  • Andre,
    The key for BuildLabEX is 7600.16384.amd64fre.win7_rtm.090710-1945 and the key for EditionID is Professional, but I found them under
    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion
    I also did a search of the registry and this is the only place these two keys appear.

    I installed the RSAT, and because I didn't know what to check after that, just attempted to install VPC7 RTM, but it gave the the same message, this update is not applicable to your computer.

    What should I try next?
    Monday, December 28, 2009 11:21 PM
  • Hi,
    Ok, now we have the cause. You are NOT using the RTM Build! 7600.16384 is NOT the RTM. The RTM is 7600.16385 !

    The Installer checks for the Version 7600.16385 and so the installation fails. Where did you get your version? Here from Technet?

    Get the real RTM and install the RTM Version. Now you'll be able to install VirtualPC!


    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter
    • Proposed as answer by Andre.Ziegler Tuesday, December 29, 2009 12:03 AM
    Tuesday, December 29, 2009 12:03 AM

    I believe so.  I had even seen something on the internet that verified the image to be the true RTM, installed a little bit before RTM retail package hit the streets, and just put my key in when I got my retail version; Windows activated just fine.  But I seriously had no idea that RTM retail package was build 16385.

    What is the difference between 384 and 385?

    I don't think I'm willing to reinstall 7 and all my stuff just yet to update the build number-I got so sick of reinstalling Vista to fix problems that I'm burnt out on that and need a break; I'd just wait until SP1 comes out and updates the build number, then install VPC and XP mode for 7 SP1.

    Would it be possible to revise my BuildLabEX key to 16385, install VPC, and either leave the key modified or revise back to 16384?

    If 16384 is Technet RTM, why wouldn't MS allow VPC to install on both 384 and 385 builds??
    Tuesday, December 29, 2009 12:54 PM
  • Hi,

    the 16384 was the last RTM Escrow Build, which was build on Friday 10th July. On Monday July 13th the RTM Build 16385 was build after the sign off. This is the real RTM. Changing the BuildLabEx doesn't help you.

    From what I read, you've download a version from a torrent site. So we can't help you.

    Delete this Windows and reinstall with the real RTM (6.1.7600.16385) DVD you've purchased.

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter
    Tuesday, December 29, 2009 1:09 PM
  • Wow, now do I feel stupid....
    The link was genuine, not "unofficial", from a reputable site that claimed download this to get RTM version, install, then put your key in when you get retail version.
    I'm really sorry to have wasted your time on this but you did help me find out why I was not able to install VPC.

    Would you know if I put my retail CD in, would I be able to reinstall without losing all my programs/games etc...?
    Tuesday, December 29, 2009 11:29 PM
  • Hi,

    you could try to make a repair installation. But I don't know if this works. The best is, to completely format the partition and reinstall Windows from scratch.

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter
    Wednesday, December 30, 2009 12:48 AM
  • Thanks for the help Andre, I did some research and found that I'm not the only one with this issue.  Build 16384 can be updated to 16385 without issues, so I will try that using my DVD.  I have daily backups if things get borked for some reason.
    Wednesday, December 30, 2009 1:03 AM